[WSL] Fails to set root password after initial installation

Hi,

I’ve been trying to install openSUSE Leap 42 through the Microsoft Store on top of the Windows Subsystem for Linux (WSL).

After the installation, I’m prompted to create a new user account and set a password for it. Then I’m prompted whether to use the same password for the root user account. If I choose to use the same password then the below error appears on screen and the root account ends up without a password:

sed: -e expression #1, char 19: unterminated `s’ command

Is this a known issue? I’ve tried unregistering and reinstalling openSUSE on WSL but the same thing happens every time. I couldn’t find a bug tracker anywhere for openSUSE on Windows Subsystem for Linux so I’m not sure where to report this issue.

Below is the full session from the first second I open openSUSE up until it fails.

PS: Everything works if I choose not to use the same password for the root user.

Installing, this may take a few minutes…
Installation successful!

Please create a default UNIX user account.
The username does not need to match your Windows username.
For more information visit: Set up a WSL development environment | Microsoft Learn
Enter new UNIX username: myuser
New password:
Retype new password:
passwd: password updated successfully
Use same password for root user?
Type “y” to approve, any other key to reject: y
sed: -e expression #1, char 19: unterminated `s’ command
Default UNIX user set to: myuser
myuser@LCX1:~> sudo su

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

[sudo] password for root:
Sorry, try again.

Windows 10.1803 build 17134.345.

I don’t think so.

This does not happen during an ordinary install. Or, at least, it has never happened to me, and I have installed 42.3 several times.

I’m guessing that it is a Windows problem. But let’s see if anyone else has experience with this apparent bug.

I’m glad you found a way of installing anyway.

You’re not supposed to “install openSUSE” in WSL, it should already be installed.
And, from what I’ve seen at least by default you don’t have an option to install a particular version of openSUSE… despite the package name, the latest version of openSUSE is installed (currently LEAP 15).

Recommend you uninstall, and then re-install WSL (through the Microsoft Store), that should restore your settings to default.

Note that you are restricted in what you can do… You cannot do anything that would write to the root partition in an ordinary openSUSE install, you can only write to the equivalent of the /home partition… So, although you might have reason to run something with root permissions, for the most part that’s unnecessary because you wouldn’t have access to those “file locations” anyway.

TSU

That is what I did. I installed openSUSE Leap 42 through the Microsoft Store. I’ve already tried uninstalling it (or unregistering as Windows calls it in the context of WSL) and reinstalling it. I run into the same problem every time.

What is the difference between Leap 42 and 15? I see there are two versions in the Microsoft Store with quite the range in between their version numbers.

openSUSE did a strange dance with version numbers 15 is the newest

I doubt there is any difference between the two…
I installed openSUSE 42.2 when it was the only one offered, and it automatically installs whatever is current and latest (without updates).
LEAP 15 is the current and latest.

TSU

If you haven’t seen the following, I posted shortly after WSL was first asked in these Forums

https://forums.opensuse.org/showthread.php/529940-How-do-I-boot-into-opensuse-from-the-Windows-Subsystem-for-Linux-command-line?p=2857331#post2857331

Includes a link to the MS documentation on WSL (implemented as a FAQ).

TSU

Regarding your specific question about setting the root password…
I can’t remember whether or how I might have done it when I was doing some experimentation, I likely ran yast(Note not yast2 since WSL doesn’t support a graphical Desktop)

yast

The WSL documentation on this topic is here
https://docs.microsoft.com/en-us/windows/wsl/user-support

TSU