Writting access denied to Windows partion?

OpenSuse installed with Windows 7 installed first.
I have successfully set up GRUB to boot both OS.

Problem description:
When trying to download (save) files into ROOT/WINDOWS/E
message warns me that its not possible to write requested file.

Please explain how to allow Opensuse to write files into NTFS

Thanks in advance.

You need to edit the text file fstab, located in the /etc folder using root privilege. You can use the menu run command and type “kdesu kwrite” without the quotes and then enter the root password when requested. Do a file/open in kwrite and use the up arrow till you are at the root of the file system then go into the /etc folder and open fstab. There will be an entry for your windows hard drive and you want to change the drive options to “rw,defaults”. Here is my hard drive entry in fstab, but it will not be exactly like your drive entry.

/dev/disk/by-id/ata-ST3300831AS_3NF164YY-part1 /Windows/HDD ntfs-3g rw,defaults 0 0

Let us know if this helps. You must reboot your computer after making any changes to fstab.

Thank You,

Most Linux distributions do not mount NTSF partitions in write mode.
This is for a good reason - the NTFS specification is not open, and the code has been reverse engineered.

While NTFS write does work, I would be reluctant to write to a working Windows partition. It is much safer to create a FAT32 partition to share data, or use a NTFS partition which does not contain critical data.

Wouldn’t creating a FAT32 partition limit your ability to use the harddrive? I mean, as far as I know FAT32 won’t hold a file larger than 4gb. While I suppose it is rare to need to do that, you might find yourself needing to exchange a backup of a DVD as an iso-image. I’m just asking here…


First create a mount point for the Windows 7 partition. I’ll use /media/win7 as an example.

As root, in a terminal:

mkdir /media/win7

Now we can edit /etc/fstab.

Assuming Windows 7 is on /dev/sda1:

Alt + F2 then type or copy and paste in the Krunner box

kdesu kwrite /etc/fstab

Then add this line:

/dev/sda1/ /media/win7 ntfs-3g defaults 0 0

Make sure you save the file before closing.

Reboot for changes to take effect.


problem is solved with quite simple method.
File manipulation which I tried to do I did
without any editing or complicated commands.

I just used DOLPHIN file manager with SUPER USER

Anyway thanks for all your messages.

Benefit of having to run it as SuperUser is that one step may keep you from accidentally deleting something you shouldn’t! :wink: