Writing to NTFS

I have two sata drives as back up drives. A huge number of files on each. Now as root I can easily read and write to those drives. But as a user I can’t. I tried changing permissions (umask 0002, 0007, 0000) in fstab and nothing. I also tried installing and running ntfs-config, which was really useless for what I was trying to do. I tried to right click the folder, logged in as root, and change the permissions manually and checked the box to have it applied to all files in that folder, but it stalled each time and nothing got done.

What am I missing here? I searched Google Linux and found a lot of answers, but they where the wrong answers.

Edit: I can read those drives as user, I just can’t write to them.

The fundamental problem with writing to NTFS is that it is a journalled filesystem and you risk corruption if you write to it with journalling turned off.

If you want to share files between Windows and Linux on a regular basis, you would be far better setting up a VFAT partition for those files.

That is why the default is not to allow users to write to NTFS partitions.

Please read here:

Did you change fmask from 133 to 113 ?

Are you using ntfs or ntfs-3g to mount the partitions?

If you are using ntfs-3g, what I usually do is just delete any user,group,other permission masks, and just leave the fstab entry looking like this:

/your/disk /mount/point ntfs-3g defaults 0 0

After that, reboot, and you should be able to read/write without any trouble. I know this is probably a crude, less secure, and potentially unsafe way of doing this, but it suits me and my experience level.

If you are using the normal ntfs module, I don’t have much experience with it so I don’t recommend this method. Regardless, you should still read the link provided by oldcpu.

Thanks for the info. I was unaware I had to change the fmask as well. I will try it all as soon as I get WotLK copied from the DvD so wine can install it.

This will only be temporary, reading and writing to the NTFS. I was using Ubuntu for awhile and duel booting XP, then about a year or so ago I went back to XP only then gave up on XP and tried Vista. After installing Puppy Linux on a Mini 4GB USB HD and seeing how fast that went compared to Vista, well lets just say I will only be booting Linux from now on, by the looks of it I am staying with Suse. Ubuntu and others are great, but I am liking how far Suse has come since I first saw it (Suse 7.0) So I had all this info on the hard drives so it would be easy for Vista and XP to read. Since I am not using them I will be switching file systems. But I have a lot to move before I can do that and I am too lazy to do it right now, lol.

Edit: And yes fstab is ntfs-3g

Ok the first thing I tried was changing fmask=133 to fmask=113. Didn’t work.

Here are the two lines from fstab, do they look ok to everyone?

/dev/disk/by-id/scsi-SATA_WDC_WD1600JS-41_WD-WCANY2260326-part1 /mount/backup        ntfs-3g    users,gid=users,umask=0007,fmask=113,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_ST3320620AS_9QF8146S-part1 /mount/video         ntfs-3g    users,gid=users,umask=0007,fmask=113,dmask=022,locale=en_US.UTF-8 0 0

what’s the permission of the mount directory when your ntfs partition is mounted? ie, the permissions of /mount/video and /mount/backup ?

The permissions say that group and others can view and modify content. Doesn’t do that in practice though. I am starting to wonder if their are errors on the ntfs that are preventing this from working the right way.

I am starting to wonder if their are errors on the ntfs that are preventing this from working the right way.

I would check the drive out via windows. It will rectify any journal issues when it mounts the volume. Then you should be good for r/w access.

Problem is I don’t have Windows installed on this computer anymore, lol. Figures when I duel boot I have no issues like this. Now that I am only booting Suse this happens. It seems like this should work, I think I have done everything right and then some.

I want to thank everyone for the help and ideas. I am just going to redo the hard drives to ext2 right now and move the data around, too much to really burn onto dvd’s.

NTFS is not a good file system choice to employ in linux-only environments. The linux-3g ntfs r/w functionality is aimed at being able to share data with windows storage systems. Otherwise vfat or native linux file systems are more practical.

Well just got done a little while ago. It was a pain, only because it took so long. I now have one hard drive as an ext2 and the other as an ext3. No issues at all now auto mounting them and read/write permissions. The best thing, I didn’t screw anything up and loose any data, lol.

Now must sleep…