wpa_passphrade with wicked

I need to utilize wicked to manage my wireless, instead of network manager. I know that what I am attempting works under network manager, but fails under the ifcfg-wlan0 file in wicked.

Let’s say I run wpa_passphrase myssid mypassword
It returns:


According tyo the manpage for ifcfg-wireless:
When using WPA-PSK authentication, you need to specify your pre-
shared key here. The key is used for authentication and encryp-
tion purposes. You can enter it in hex digits (needs to be
exactly 64 digits long) or as passphrase getting hashed (8 to 63
ASCII characters long).

If I use this line in my ifcfg-wlan0 it connects correctly:

If I use:
the connection fails.

I am running LEAP 42.3 fully patched.

Any help is greatly appreciated.

Use YaST’s Networksettings module. Tick the networkdevice you want to configure and follow the steps, you’ll be able to select your SSID, set the security to WPA2 and enter the passphrase.

Yes, that is how I set it up originally. Duh…I missed where you can put the HEX key in. Thanks for the obvious kick in the right direction.I will try that and respond if it fails.

There’s an option to enter HEX instead of passphrase, quite at the bottom part of the screen.

So, I tried entering the hex key through yast and it still fails. My syntax in ifcfg-wlan0 was correct. I’m at a loss on why it does not like the hex key generated by wpa_passphrase.

Anybody running a laptop with wireless willing to try using wicked to manage their wireless NIC and see if entering the HEX key in yast fails or succeeds for them?

I will try that experiment later today.

Hi, I tested this on my Tumbleweed machine, and the HEX entry works fine, so my guess is that you made a mistake in the passphrase. FWIW, works both in wicked and in Networkmanager.

Thank you for testing. I will keep digging now that I know it is on my end.

I have to correct myself here. The file does not contain ‘WIRELESS_WPA_PSK’, but rather


Is that in your wpa_supplicant.conf file or an /etc/sysconfig/network/ifcfg-* file?

You’re right, it’s in Networkmanager’s folder, sorry. Will try again straight away.

Not OK indeed. Deserves a bugreport at bugzilla.opensuse.org against wicked, for both 42.3 and Tumbleweed.

Guess I get to learn how to file my first bug report. Thanks for testing.


I’ve marked your bug report as confirmed, and added my own comments.

I tested this on Leap 42.3, Leap 15.0 Beta, and on Tumbleweed. I ran into the same problem in all cases. It works if I use the passphrase, but not if I use the hex key.

I also notice that, on Tumbleweed, “systemd-udevd” appears to be looping. This is probably not related, so it may be an entirely different bug for me to investigate.

Doing exactly the same with Networkmanager, i.e. use the hex instead of the passphrase, works as expected. Wouldn’t that rule out a udev problem?

FWIW I’ll confirm the bug too

It looks as if the udevd problem is bluetooth related, so probably nothing to do with the “wicked” problem. I’m seeing lots of log messages about “hid2hci”.