wpa and wpa2 problems

Hello I am using opensuse 11.0. I just installed a new Ubiquiti Bullet 2HP and set it up as an AP. The thing is great. On my wife’s windows system I get 100 percent connection and 98 percent link quality and this is using wpa2. So great I have a new booming out AP. Then I go to setup my home theater system that is using Linux Mint. No problems, well there is but it’s not with the connection, Linux Mint sees the AP and connects to it just fine.

Now I go to set up Suse 11.0 on my laptop. So there is a setting for for wpa2 in NetWork Manager but it keeps changing my key. The Bullet AP says I need a password/key that is between 8 and 64 hex long. I am using a 14 character string. But suse tries to force it’s own string on me. I input the string I want to use and it seems to take it just fine. Then I try to connect and no joy. I go back into NetworkManager and the key has been changed!!! I have tried both wpa and wpa2 this happens with both of them.

I have been messing with this for some time. Mostly I like suse but this could be a killer for it. Support for wpa and wpa2 in Yast is poor, actually nonexistant, at best. It’s only available in Network Manager and the only under expert settings. WPA and WPA2 have been out for some time so it’s not a problem of just catching up.

So does anybody have 11.0 working with WPA2 or WPA?

NOTE: please don’t tell me to use something with KDE4. I am with Linus about his oppinion of KDE4. He said about KDE4 “What a disaster” and I agree completely.

You failed to mention what wireless hardware you have, thus I am
unable to tell if 11.0 had a problem with that hardware. In general
with 11.0, you will be better off using the ifup method, rather than
NetworkManager. With 11.1 NM is fine (Well there have been some
problems along the way, but it works now.), and it now works with 11.2
M7 where I have tested NM and ifup using WEP, WPA and WPA2.

There have been many changes in wireless drivers since the 2.6.25
days, which I think is the kernel in 11.0. When 11.2 is released in 42
days, please consider switching. Kernel 2.6.31 is really a lot better.

Yes I should have included that. The driver is madwifi’s ath5k. Their website says that they can do wpa2 but it doesn’t have any way to do that with Yast.

I did try setting the system up with iwconfig and ifconfig. If I’m not mistakem ifconfig calls ifup.

I have a few diferent cards and I will try them.

I can download and install 2.6.31 myself. Currently I have I’ll see if 2.6.31 makes a difference but I doubt it because yast doesn’t have an entry for wpa2.

Yes I have been using wpa2 with my wireless adapter and router with opensuse for about 2 or 3 years now. Currenlty using 11.1 with knetworkmanager to manage and setup wireless. It works pretty well.

But what driver are you using??

I did manage to get it working. But I had to pull the pcmcia card and use an ALFA usb that uses RTL8187 driver. I figured this out because my wife’s desktop is dual boot. But I’m having some difficulty in getting her to switch to using linux over windows. ( But windows is helping because it’s always screwing up). Her desktop has an ALFA USB wireless. I was able to get it working right away. I had an extra ALFA and plugged it into my laptop. Had to dump NetworkManager and setup through yast and it came up as soon as I rebooted. It didn’t work when I just pluged it in. It was recognized but it didn’t work until a reboot with it installed.

So I guess this means that there are some issues with the madwifi drivers that I was using with my pcmcia , I tried both ath5k and ath_pci. The only problem now is the ALFA is like a ball and chain. It’s got a long USB cable so it’s not as convenient. I found a ralink pcmcia card on amazon for 10 bucks so when it gets here maybe I will be freed from the ball and chain.

There is only one last thing that I could use some help with. How do I prevent NetworkManager from starting at boot up? I’m an old Slackware guy from way back ( It’s was 1992 when I first installed Slackware). I actually like setting up the system with text files. It makes fixing problem much more straight forward. I call systems that I have to click on things until I find what I want as “Being in Mac hell.” I put on my 75 year old mothers computer. She lives a thousand miles away and I admin her setup with X11VNC. I wanted a local machine that was setup the same so I could get an idea of what she was talking about if I coun’t get attached to her box.

And I guess I should apologize for my attitude of my first post. I had been tring to get this thing up for a long time and it had worn on my old bod. Just to frustrated. So if it was offensive to you I’m sorry, it wasn’t personal in any way.

So how do I dump Network Manager?

YaST (and by that I assume you mean the traditional method with IFUP) never had an extra option for WPA2, because it is not needed, wpa_supplicant is normally intelligent enough to choose the right method.

  • ath5k in 2.6.25 is still buggy (use compat-wireless instead)

  • ath_pci would be an alternative (use madwifi-drivers, i.e. from driver:wireless Repo and blacklist ath5k)

  • rtl8187 was not very reliable in 2.6.25 (for rtl8187B it was still not very usable, again use compat-wireless or upgrade to 11.1)

  • NetworkManager sometimes experienced problems if the AP had “mixed” WPA/WPA2-encryption, either switch to IFUP or switch to WPA or WPA2 exclusively in the router/AP.

For me IFUP is a shell script in /sbin. Yast is what you get when you go to administrator settings. Isn’t this the official way to setup networking as well as wireless networking?

Actually what I think will be best for me is do Linux from scratch again. It’s been many years, probably a decade or more, from the last time I built LFS. Now there is BLFS. So I will just build my own and leave these distros that have you in Mac hell behind. The thing that got my attension with suse is the package management. So I will just include apt in BLFS.

Thank you for your help. I do appreciate it. I’m a slackware guy from way back. I like the idea of using text files to administer the system. But Slack is very slow at updating to better versions, as is debian. Current Slack is at version 13. Version 13 still uses the 2.9 version of libc. This is a know buggy version and it’s been in slackware for a few versions. Version 2.10 has been available, using git, for some time now. Just so you know Mozilla lists libc 2.9 as the major reason for crashes in Mozilla and her offspring. Vlc refuses to compile completely under libc 2.9. And of course everybody is sheep and follows along the KDE4 disaster road. (KDE4 reminds me of a 12 year old girl with three hundred dollars worth of makeup on her face. Tammy Faye in software. May she rest in peace.)

The first time I loaded linux I had a handful of floppy disks. At that time one expected problems and there were ways to fix them. Now everything is obscured behind some icon. Custimization is at a minumum. You take what you’re given and you better shutup and like it (Just like MS windows). I’m not happy with that. Wep was a failure from the gitgo. WPA came in very quickly and WPA2 has been around for awhile now. To not have it in Yast ( that thing you get when you click the lizard, computer, administrator settings ) is shameful. If the OS is going to force me to do everthing their way it should be the right way, or at the very least up to date, from the beginning. I am willing to bet that the amount of time put into making pretty icons is orders of magnitude greater then what went into making wireless work properly. Eye candy has become more important then functionality because it’s geared towards sales not use. The linux distros like Ubuntu, mint, suse and mandriva are geared towards sales. And in doing that they have lost the main advantage that linux provides.
Anybody remember “Free like in Speech.”

I put suse on my 76 year old mothers computer because I knew she would like the eyecandy, all she does is check her email. I put suse on my laptop so I could have an idea what she was doing and tell her how to fix it, mostly I use X11vnc to admin her system. My nephew came in and saw suse and said “hey this is great it’s like vista.” When something is geared for the masses it’s dumbed down to it’s lowest level. That’s why vista looks like a cartoon.

The way I feel about it right now I think in about a year there will be a new distro out. One that stays up to date on the foundational software, like libc, and gives the user the power of ther system. Yea using a sharp knife can get you cut if you are not careful but I actually liked the freedom of assembler. (If you didn’t understand that last sentance don’t worry about it)

Rant over.

It does here without problems (since SuSE 9.2, the first version I used with Wireless).

“It didn’t work” is not really a useful error description.

IFUP is completely independent of the DE/WM used.

Again, it does here perfectly, even with mixed WPA/WPA2.

Some combinations wireless driver/router gave problems with networkmanager if mixed WPA/WPA2 encryption was used.

This problem is also present on other distributions, because it is related to NWM.

No problem, it is everbody’s “brith-given right” to make a fool out of himself.

Akoellh wrote:

> YaST (and by that I assume you mean the traditional method with IFUP)
> never had an extra option for WPA2, because it is not needed,
> wpa_supplicant is normally intelligent enough to choose the right
> method.

Yast is where you find the comes with knetwork manager turned on by default
in Network Settings, although you can choose ifup. I find Knetworkmanager
much more convenient although you may be forced to use ifup if you also use
scpm to switch network settings.