Workrave: muitas dependências do cinnamon no ambiente KDE

Uso o KDE e ao tentar instalar o Workrave surgem muitas dependências do cinnamon, totalizando 148.3 MiB. Em outras distros nunca vi isso. Onde posso reportar esse problema?

Em outubro de 2022 reportei no github, mas recomendaram eu reportar pro mantenedor do pacote. Procurei onde fazer isso, mas não achei.

E após instalado ele tem um bug que não aparece o tipo som das notificações.

Imagens anexas.


Olá,

O local correto para reportar Bugs costuma ser o Bugzilla:

https://bugzilla.opensuse.org/

Detalhes de como submeter bugs estão na Wiki (em Inglês):

https://en.opensuse.org/openSUSE:Submitting_bug_reports

O Bugzilla usa as mesmas credenciais (usuário/senha) do Forum.

1 Like

O pacote não deveria trazer tantos outros, o requires é relativamente pequeno.

$ zypper info --requires workrave
Loading repository data...
Reading installed packages...


Information for package workrave:
---------------------------------
Repository     : Main Repository
Name           : workrave
Version        : 1.10.48-bp154.1.60
Arch           : x86_64
Vendor         : openSUSE
Installed Size : 14.4 MiB
Installed      : No
Status         : not installed
Source package : workrave-1.10.48-bp154.1.60.src
Upstream URL   : http://www.workrave.org
Summary        : Recovery and prevention of Repetitive Strain Injury program
Description    : 
    Workrave is a program that assists in the recovery and prevention of Repetitive Strain Injury (RSI). The program frequently alerts you to take micro-pauses, rest breaks and restricts you to your daily limit.
Requires       : [43]
    libpthread.so.0()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libstdc++.so.6(GLIBCXX_3.4)(64bit)
    libm.so.6()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libstdc++.so.6(CXXABI_1.3.9)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.21)(64bit)
    libglib-2.0.so.0()(64bit)
    libgobject-2.0.so.0()(64bit)
    libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.11)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
    libgio-2.0.so.0()(64bit)
    libstdc++.so.6(CXXABI_1.3.8)(64bit)
    libpthread.so.0(GLIBC_2.2.5)(64bit)
    libX11.so.6()(64bit)
    libm.so.6(GLIBC_2.2.5)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.14)(64bit)
    libgtk-3.so.0()(64bit)
    libcairo.so.2()(64bit)
    libgdk-3.so.0()(64bit)
    libgdk_pixbuf-2.0.so.0()(64bit)
    libpango-1.0.so.0()(64bit)
    libc.so.6(GLIBC_2.15)(64bit)
    libpangocairo-1.0.so.0()(64bit)
    typelib(GLib)
    typelib(Gio)
    libXtst.so.6()(64bit)
    libsigc-2.0.so.0()(64bit)
    libglibmm-2.4.so.1()(64bit)
    libatkmm-1.6.so.1()(64bit)
    libXss.so.1()(64bit)
    libgtkmm-3.0.so.1()(64bit)
    libgiomm-2.4.so.1()(64bit)
    libgdkmm-3.0.so.1()(64bit)
    libcairomm-1.0.so.1()(64bit)
    libpangomm-1.4.so.1()(64bit)
    typelib(St)
    typelib(Workrave)
    /sbin/ldconfig

O comando acima foi executado no Leap 15.4.

Porém, como é um pacote Gnome/GTK, pode ser que traga mais coisas que não estão nessa lista.

1 Like

Reportei o bug.

Obrigado e até mais!

Não conheço o pacote, então, posso estar falando besteira mas me baseando nos requires e na lista de dependências eu chutaria que é um pacote gnome. Ele mesmo não tem muitas dependências mas usa a typelib ‘st’ que vai puxar praticamente o gnome todo. Pra quem já usa gnome não vai ter quase nenhuma dependência, agora, para que usa kde sem nenhuma outra aplicação gnome acho que não tem saída.