WMV Needs?

  • Windows Media decoder (GStreamer, x86_64)
    • Advanced Streaming Format (ASF) demuxer (GStreamer, x86_64)

Tried a WMV file today and got this request. Any one know how to fix this? Ross

Do you have the Pacman repository enabled? This usually has all of the codecs you’ll need, and they should be automatically marked for install when you run the YaST package manager for the first time.

If you are still having trouble, install the w32codecs package; this should take care of any remaining loose ends.

If not sure about packman repo, post the result of this:

zypper lr --details

Yes the Yast pkg mgr. is installed. There were 2 gstreamer plugins available

and I installed them. Still get the same request.

1 | Libdvdcss repository | Libdvdcss repository | No | Yes | 99 | rpm-md | http://suse.linuxin.dk/repo/11.1/ |
2 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.1 |
3 | repo-debug | openSUSE-11.1-Debug | No | Yes | 100 | yast2 | Index of /debug/distribution/11.1/repo/oss |
4 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | No | 99 | yast2 | Index of /distribution/11.1/repo/non-oss |
5 | repo-oss | openSUSE-11.1-Oss | Yes | No | 99 | yast2 | Index of /distribution/11.1/repo/oss |
6 | repo-source | openSUSE-11.1-Source | No | Yes | 100 | yast2 | Index of /source/distribution/11.1/repo/oss |
7 | repo-update | openSUSE-11.1-Update | Yes | Yes | 20 | rpm-md | Index of /update/11.1 |

It looks ok to me.
Do you have VLC installed. If not, install vlc and it will solve all format issues.

Vlc is installed. Although the choices offered on what to open the file with are
Banshee and Totem.

The playback of this movie requires a Advanced Streaming Format (ASF) demuxer plugin which is not installed. This is another error msg.

Drive-by suggestion, install the multimedia codecs if you haven’t already Restricted Formats/11.1 - openSUSE-Community or install them individually as i normally do via YaST. Make sure you install mplayer/vlc/w32-codecs/ffmpeg,etc


OK Mplayer was not installed. wmv video played with media player. I am not sure the video had an audio, perhaps not because none played. Totem still wanted codecs, but I do not need it if Mplayer does the job.

So am new at Suse, but like it so far, just wondering what I should have done differently after the gnome install if I had to do it over. There is a lot more to learn that is for sure. I certainly have had good support on the three questipon threads I posted.