wlan0 interface gone on some boots

Abut 30-40% of the time after a fresh boot, the wlan0 interface will not show up. My wifi card is recognized :

/sbin/lspci -nnk | grep -iA3 net

00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (7) I219-LM [8086:15bb] (rev 10)
        Subsystem: Dell Device [1028:0831]
        Kernel driver in use: e1000e
        Kernel modules: e1000e
6d:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
        Subsystem: Dell Device [1028:0310]
        Kernel driver in use: ath10k_pci
        Kernel modules: ath10k_pci

but I get no interface:


lo        no wireless extensions.

eth0      no wireless extensions.

virbr0    no wireless extensions.

virbr0-nic  no wireless extensions.

I see no errors in the journal, other than the virbr0 interface not connecting. Nothing about wireless whatsoever. Sometimes the wifi will be recognized, but NetworkManeger will be unable to establish a connection, it just sits on “configuring interface” forever. I have not yet examined the journal after this issue presents itself, I will once it happens again. After a reboot, it usually gets recognized and works fine. Advice for narrowing down this issue?


Are all the microcode updates installed?

What happens, in the failed state, when the systemd network service is restarted?

Good question about the microcode. From what I understand this is pretty basic:

dmesg | grep microcode
    0.000000] microcode: microcode updated early to revision 0xd6, date = 2020-04-27
    1.563046] microcode: sig=0x906ea, pf=0x20, revision=0xd6
    1.563221] microcode: Microcode Update Driver: v2.2.

Is there a microcode package for openSUSE? Searching microcode comes up empty. There is only one version of kernel-firmware and ucode that I can see.
Restarting network has no effect, it still doesn’t recognize wlan. Of course, it’s functional at the moment, so I’ll have to wait for the next failure to troubleshoot further. I tried restarting network and NetworkManeger in both versions of the failed state, missing or not connecting issues. It made no difference.

Have you tried kernel from kernel:stable?

There’s a couple of “ucode” packages: “ucode-amd” and “ucode-intel” …

As far as the network interfaces are concerned, there may be some microcode in the hardware specific packages or, you may have to search for some vendor specific offerings.

Is the Mainboard’s BIOS/UEFI up to date?

Not for this issue. I will try running it for a few days to see what happens.

The ucode packages are installed and up to date. Regarding the bios, I recently updated the bios to resolve an issue discussed here: https://forums.opensuse.org/showthread.php/543433-update-killed-bootloader

As a result of this update, several Fn keys no longer work, and this issue with the wifi has since presented itself, so it may indeed be an issue with the bios update. The kernel from the kernel:stable repo did not resolve the broken keys problem, and I suspect it won’t fix the wifi issue either if the bios is indeed the culprit, but I’ll give it a shot.

I tried the latest kernel from the kernel:stable repo, along with the latest firmware. No difference, I still got no wlan0 interface every now and then. I’m back on the LEAP kernel now. I did just have a recurrence of the issue where network manager will try to connect to my wifi router, and fails, repeatedly. I’m unsure as to why this is occurring, the logs don’t show anything useful:

NetworkManager[1381]: <info>  [1599623086.0192] device (wlan0): supplicant interface state: authenticating -> associating
NetworkManager[1381]: <info>  [1599623086.0193] device (p2p-dev-wlan0): supplicant management interface state: authenticating -> associating
 kernel: wlan0: associated

NetworkManager[1381]: <info>  [1599623086.0269] device (wlan0): supplicant interface state: associating -> associated
NetworkManager[1381]: <info>  [1599623086.0270] device (p2p-dev-wlan0): supplicant management interface state: associating -> associated

NetworkManager[1381]: <warn>  [1599623090.0945] sup-iface[0x55d446ca5930,wlan0]: connection disconnected (reason 2)
NetworkManager[1381]: <info>  [1599623090.0997] device (wlan0): supplicant interface state: associated -> disconnected
NetworkManager[1381]: <info>  [1599623090.0998] device (p2p-dev-wlan0): supplicant management interface state: associated -> disconnected
NetworkManager[1381]: <info>  [1599623090.1998] device (wlan0): supplicant interface state: disconnected -> scanning
NetworkManager[1381]: <info>  [1599623090.1999] device (p2p-dev-wlan0): supplicant management interface state: disconnected -> scanning

I says it successfully associated, then a few lines later says it’s associating again, then it disconnects. NetworkManager displayed a notification stating no secrets were provided. I’m not sure why this would only be happening intermittently, but if anyone has any ideas, please let me know. It usually connects successfully upon reboot. Sometimes this issue occurs, and sometimes wlan0 interface is gone completely as mentioned previously.

What happens in YaST?

  • Do all the hardware network interfaces appear in the “Network Settings” section?

I will check this on the next recurrence of the problem. From further internet surfing, the hanging on associating problem may be an issue with NM and the Atheros driver. Maybe I should just swap the wifi card to an intel card. Might be worth it. I tried using wicked briefly, and it does establish a connection much faster than NM does (compared to successful NM association). Too bad there is no GUI for it. This is a laptop, so using wicked as my default might get a bit cumbersome at times. I will update this thread when the info is available.

Huh!! It’s a Laptop with a replaceable WiFi card?

  • Are you sure?