Wireless not working

Hi there, my daughters netbook for some reason decided to turn off the wireless and I am not sure how to get it on again.

Whenever I hover the mouse over the network icon it says “Wi-Fi is disabled by hardware switch”.

This is on OpenSuse 13.1 lxde, Acer Aspire 1

Then enable it?

Post:

/usr/sbin/rfkill list all

I would have done if I found out where I can do that so far I haven’t found out how tondo that anywhere on YAST and I am not experience enough to know how to do that through the terminal.

So the question is how do I enable it?

Open a terminal and type the command given previously. If for some reason the command is not found, then the ‘rfkill’ package will need to be installed first.

If you find that wifi is soft-blocked, you can unblock with

sudo /usr/sbin/rfkill unblock wifi

*Enter your root password when prompted.

I note that you mentioned in your opening post “Wi-Fi is disabled by hardware switch”. This would mean that the wireless device is turned off (rfkill will then report as hard-blocked). You will need to locate the switch/button first.

A quick search finds numerous pages on the subject. For example
http://smallbusiness.chron.com/turn-off-wifi-acer-aspire-one-48952.html

Step 2

Locate the Wi-Fi switch. The location varies; on some models, it will be a physical sliding switch on
the front edge of the Aspire One. Otherwise it will be overlaid on the “F2” or “F3” key.

Related Reading: How to Set Up a Wireless Connection on Acer Aspire One
Step 3

Toggle the switch. If it’s the sliding kind, slide it to the other side. If it’s on a function key,
hold down the “Fn” key and press the appropriate key, then release the “Fn” key. You may also need to
use the mouse to manipulate an on-screen toggle.

Cheers, that actually worked. I do apologise I assumed that it was OpenSUSE problem as it happened shortly after an upgrade. Forgot that my youngest had been playing with nearly every button on there as well. And didn’t realise what that little switch was for.

Thanks for the update. Glad to have been of help. :slight_smile:

Rather than starting a new thread. I’ll add my new wireless problem onto this one.

I purchased a Lenovo G50-30 and I got it today. I had bought it with the view to install OpenSUSE Tumbleweed onto it. Now I’ve installed 13.2 first and the Wi-Fi doesn’t work on that one. And I think I’ve used every avenue that has been suggested(basically all the ones that I actually understand), but it just isn’t wanting to work. Apparently it’s a Realtek WLAN controller, the device name is wlp2s0.

Any suggestions?

Post the output of;
lspci -v
(run it as root)

Cut paste the wireless part and put it in CODE tags


Like this!

02.00.0 Network controller: Realtek Semiconductor co., Ltd. RTL8723BE PCIe Wireless Network Adapter
Subsystem: Lenovo Device b736
Flags: bus master, fast devsel, latency 0, IRQ 18
I/O ports at 2000 [size=256]
Memort at 90500000 (64-bit, non-prefetchable) [size=16]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Device Serial Number 00-23-b7-fe-ff-4c-e0-00
Capabilities: [150] Latency Tolerance Reporting
Capabilities: [158] L1 PM Substates
Kernel driver in use: rtl8723be
kernel modules: rtl8723be

[/size][/size]

Do you have **kernel-firmware **installed?

If not, install that package and reboot, the WiFi requires the firmware from that package.

Apparently it is.

I tried to do what one of the pinned posts suggested and this is what I got:

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

         Subsystem: Lenovo Device b736
         Flags: bus master, fast devsel, latency 0, IRQ 18
         I/O ports at 2000 [size=256]
         Memory at 90500000 (64-bit, non-prefetchable) [size=16]
         Capabilities: [40] Power Management version 3
         Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
         Capabilities: [70] Express Endpoint, MSI 00
         Capabilities: [100] Advanced Error Reporting
         Capabilities: [140] Device Serial Number 00-23-b7-fe-ff-4c-e0-00
         Capabilities: [150] Latency Tolerance Reporting
         Capabilities: [158] L1 PM Substates
         Kernel driver in use: rtl8723be
         Kernel modules: rtl8723be


   02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
 03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)


   00:00.0 0600: 8086:0f00 (rev 0e)
 00:02.0 0300: 8086:0f31 (rev 0e)
 00:13.0 0106: 8086:0f23 (rev 0e)
 00:14.0 0c03: 8086:0f35 (rev 0e)
 00:1a.0 1080: 8086:0f18 (rev 0e)
 00:1b.0 0403: 8086:0f04 (rev 0e)
 00:1c.0 0604: 8086:0f48 (rev 0e)
 00:1c.2 0604: 8086:0f4c (rev 0e)
 00:1c.3 0604: 8086:0f4e (rev 0e)
 00:1f.0 0601: 8086:0f1c (rev 0e)
 00:1f.3 0c05: 8086:0f12 (rev 0e)
 02:00.0 0280: 10ec:b723
 03:00.0 0200: 10ec:8168 (rev 10)


      11.538721] rtlwifi: wireless switch is on


   enp3s0    no wireless extensions.
 

 wlp2s0    IEEE 802.11bgn  ESSID:off/any   
           Mode:Managed  Access Point: Not-Associated   Tx-Power=off    
           Retry short limit:7   RTS thr=2347 B   Fragment thr:off
           Encryption key:off
           Power Management:on
            
 lo        no wireless extensions.  


   enp3s0    Interface doesn't support scanning.                                                                                                                                                    
                                                                                                                                                                                                  
 wlp2s0    Interface doesn't support scanning : Network is down        


[/size][/size]

You’re using Wicked I suppose?
That has problems with wireless devices in particular, at least the version included in 13.2 (updates are available meanwhile which should fix those problems or at least most).

Try to switch to NetworkManager (in YaST->Network Devices->Network Settings->Global Options), then click on your desktop’s network icon and you should see a list of networks you can connect to.

If you installed all updates, you may switch back if you want to, but if you use Wicked you have to configure the wireless connection in YaST. NetworkManager’s settings are not migrated/used.
I’d recommend to stay with NM for wireless connections though.

You’re using Wicked I suppose?
That has problems with wireless devices in particular, at least the version included in 13.2 (updates are available meanwhile which should fix those problems or at least most).

Try to switch to NetworkManager (in YaST->Network Devices->Network Settings->Global Options), then click on your desktop’s network icon and you should see a list of networks you can connect to.

I looked at Wicked and truthfully I ran in the other direction. But what I did try was I put on Wicked and then back to Network Manager and got


Error: No Network Running.

And where did you get that?

What does “systemctl status network.service” say?

Are you sure you did not select “Network Services disabled” by mistake?

Got it on both. “NetworkManager Service” and “Network Services Disabled”.

network.servce.service
Loaded: not-found (reason: No such file or directory)
Active: inactive

For the latter it’s obvious.

But I asked where you get that error message, not with which option.

network.servce.service
Loaded: not-found (reason: No such file or directory)
Active: inactive

You made a typing mistake there.
Again:

systemctl status network.service

or just:

systemctl status network

I got that when I did “(in YaST->Network Devices->Network Settings->Global Options)”.
As for the spelling error, sorry my bad. Here it is in better form

NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled)
   Active: active (running) since Fri 2015-07-10 18:57:31 BST; 15min ago
 Main PID: 9207 (NetworkManager)
   CGroup: /system.slice/NetworkManager.service
           └─9207 /usr/sbin/NetworkManager --no-daemon

Jul 10 18:57:31 linux-ujon.site NetworkManager[9207]: <info> (enp3s0): created default wired connection 'Wired connection 1'
Jul 10 18:57:31 linux-ujon.site NetworkManager[9207]: <info> (wlp2s0): using nl80211 for WiFi device control
Jul 10 18:57:31 linux-ujon.site NetworkManager[9207]: <info> (wlp2s0): driver supports Access Point (AP) mode
Jul 10 18:57:31 linux-ujon.site NetworkManager[9207]: <info> (wlp2s0): new 802.11 WiFi device (driver: 'rtl8723be' ifindex: 3)
Jul 10 18:57:31 linux-ujon.site NetworkManager[9207]: <info> (wlp2s0): exported as /org/freedesktop/NetworkManager/Devices/2
Jul 10 18:57:31 linux-ujon.site NetworkManager[9207]: <info> (wlp2s0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Jul 10 18:57:31 linux-ujon.site NetworkManager[9207]: <info> (wlp2s0): preparing device
Jul 10 18:57:31 linux-ujon.site NetworkManager[9207]: <info> use BlueZ version 5
Jul 10 18:57:31 linux-ujon.site NetworkManager[9207]: <info> ModemManager available in the bus
Jul 10 18:57:37 linux-ujon.site NetworkManager[9207]: <info> startup complete

Hm. As I said, it’s of course normal if you get that after selecting “Network Services disabled”, but if you switch to “NetworkManager Service” and click on OK, you should not get it any more afterwards.

As for the spelling error, sorry my bad. Here it is in better form

Well, looks ok. It detects the wireless and the wired interface.

So, have you tried to click on the desktop’s network icon?
Do you see any connections there?

Also, there’s a checkbox to enable/disable wireless (top-left corner in the KDE applet), make sure that this is ticked.