Wireless in terminal

Hi,After today’s brillant update I can’t log in to openSUSE with plasma session. The solution is to either downgrade packages that caused the trouble, or to install the patch openSUSE released. Both these solutions require the Internet connection. The case is that I can’t establish one, since I don’t have a cable connection, I jest have a Wi-Fi.

Since I can access my openSUSE via cmd line only at the moment, I wanted to configure the wireless connection via cmd line following this tutorial:

http://www.blackmoreops.com/2014/09/18/connect-to-wifi-network-from-command-line-in-linux/

Before I start pasting my errors, can anyone tell me, if what’s written there is good? The solution given there doesn’t work for me and I want to know if I should follow a different tutorial, or start troubleshooting what I’ve got in here.

Regards,
Radek

Case closed, as I connected via cable finally and installed the patch openSUSE provided. Maybe sometime in future I’ll get back to WiFi configured in terminal. Now, though, I don’t need it.

When using wicked it should just work in text mode too, but I suppose you are using NetworkManager.
NetworkManager does come with a text mode frontend, “nmtui”. Login as your user and run that, and you should be able to connect.

Oh, and if Plasma5 doesn’t work, you should also be able to select a different session at the login screen. The rather minimal “IceWM” should be installed as fallback in any case.
To get back to the login screen when Auto-Login is activated, press Ctrl+Alt+Backspace twice.

If you need to connect to WiFi using a terminal, it’s not extremely difficult but does require some learning.

First, assuming you are connecting to a **password-protected WiFi,
**
Network Manager (full name Gnome Network Manager) is a GUI frontend for the CLI app wpa_supplicant which is installed by default in all openSUSE installs (last I checked) no matter whether you’re actively using WiFi or not. So, it’s available by default.

You can invoke** wpa_supplicant** directly in a terminal or console, the following displays the usual help and of course a MAN should also be available for full documentation. If you have connected to a WiFi connection before, then those settings should be remembered and visible in the wpa_supplicant.conf file including the hashed password (Again… Last I checked, even if Network Manager stores the password elsewhere a hashed copy has always also been written to wpa_supplicant.conf). If prior settings exist, then in combination with a little documentation as needed, creating a new entry is not that difficult.

wpa_supplicant --help

You can also use nmtui if you can get it to work as wolfi suggests (years ago, it didn’t work for me so I learned how to just invoke wpa_supplicant directly).

If your AP is open (no password) or uses deprecated encryption,
Then I prefer to use the utility** iw** instead of wpa_supplicant. It’s much simpler so is much easier to use, avoiding the wpa_supplicant complexity when it’s not needed. It’s also not installed and available by default, so you need to download some way and copy to your openSUSE (hopefully you have an install DVD?)

Both of the above would be invoked directly from the command line to manage and make <wireless connections>, TCP/IP configuration would be configured separately, but typically you just set the interface connections to DHCP in YAST.

HTH,
TSU