wine set up

My pc is dual boot win 7 and open SuSE12.2.

I have already installed wine.

I want to try to run some games, windows 7 refuses to run.

Serious sam gold (first and second encounter, which I have not tried yet on win 7, so it might work) )
Starwars republic commando, I cant get it working on win 7 32 bit.;

Last night I did a first attempt.

Some qt ? frontend of wine started, and it wanted me to point to the 64 bit and 32 bit libraries.
I have no idea were I can find those.

Should I maybe install wine tricks ?

Second Question
Do I need a no cd hack ?
( a few years ago I tried to get Aliens vs Predator working through wine.)
To get the installer to work, I needed a no cd hack, because under linux, the copy protection, could not find the cd’s.

( all games are 100 % legal on cd or dvd )

Third Question
Should I try serious sam native under linux ?
Loki seems to have beta installers ?

linux installers for linux gamers

the front end is called Q4


I removed wine and Q4

added another repo:
which gives wine and wine tricks

openSUSE 12.2: Index of /repositories/Emulators:/Wine/openSUSE_12.2

I gave up, and installed the games on Windows.

Ty for the help.

I never use front ends for wine. On 64-bit openSUSE I just forbid the installation of wine-32bit and install the wine i686 package. If you do that make sure to install mesa-32bit and asound plugins for pulseaudio for 32-bit.

As I understand it winetricks is a part of wine now, not something you need to add. I suggest you search the WineAppDB: WineHQ - Wine Application Database for the games you wish to install and try out various suggestions which you get there. Wine changes a lot so look for suggestions related to your version of it first. Use winetricks to install native .dll, fonts etc. which some games will require to have available for running properly, according to what is suggested on the WineAppDB site.

If you haven’t installed the wine-mono package I suggest you do so, this package will substitute for .NET which is a hassle to install. It should be available from the emulator repo. I use it alongside the default Wine version for OS 12.2, Wine 1.5.6-2.1.2.