WINE on 64-bit

Does anyone have any experience running WINE on 64-bit OpenSuse 11? I had been running 32 bit, and was able to run Steam under WINE and play games like Counter-Strike. I decided to bite the bullet, and since I had 4 gb of RAM and a quad-core system, installed the 64bit version of OpenSuse. I installed Steam with no problems, but Counter-Strike starts up, appears to load, then dies back to the desktop. I then have to readjust the screen resolution but otherwise everything is fine with the environment. But Counter-Strike simply won’t run. Since I had no issues under 32bit OpenSuse, I figure this has to be a 64bit issue.

Was wondering if anyone here had any experiences with WINE using 64bit.


Start it in a terminal & see if there are any dependency errors. I had to go into windows and copy over some xyz.dll (s) for some I’m running.

BTW, Wine is still 32-bit in x86-64 afaik.

Thanks for the advice. The first time I ran it from a terminal - it worked!! The next few times it didn’t. Pretty bizarre. I didn’t see anything that looked like a problem from when it died and went back to the desktop. I’ll keep looking into it.