wine and .NETFramework

Hi Everybody!

I have had some problems with installing dotnet11, 20, 30 on OpenSuse 11.3 x86_64. A every time got the same error msg:

pinter@linux-izby:~> sh winetricks dotnet20
Instaling .net 2.0 runtime. Can take several minutes. See MicrosoftDotNet - The Official Wine Wiki for tips.

prerequisite gecko already installed, skipping
Setting Windows version to win2k
Executing early_wine regedit c:\winetrickstmp\set-winver.reg
Executing cp -f /home/pinter/.winetrickscache/dotnet20/l_intl.nls /home/pinter/.wine/dosdevices/c:/windows/system32/
Executing wine reg delete HKLM\Software\Microsoft.NETFramework\policy\v2.0 /f
DELETE - HKLM\Software\Microsoft.NETFramework\policy\v2.0 (null) 0 0 1
Error: The system was unable to find the specified registry key or value

Note: command ‘wine reg delete HKLM\Software\Microsoft.NETFramework\policy\v2.0 /f’ returned status 1. Aborting.

I don’t know what to do. Installed corefonts too, still the same. Anybody met with this problem yet?

I just installed an application which needs .net 2.0 and after that i was able to install the framework but now i run in to a new error msg which says i can’t install this app on 64bit system :smiley:

Ok, solved it!
I just put back the 32bit version of wine and everything works just fine.

So all i did was the following:
Installed a program which needs the .NETFramework and then I was able to install the framework from winetricks. dotnet11 was just all right on 64bit system, but i had no luck with the dotnet20 and 30 version. I deleted the 64bit wine and gecko, reinstalled the 32bit version, done the installation again, and now i run .NET 2.0.

Problem solved, hope this will help for some users around who suffer with the same :slight_smile:

All the best to you guys!

Hello,
Sorry about my poor English, I’m from Argentina, and very new to the Linux world.
I want to know if my application is able to run under Linux, and I find the same problem as you.
Could you show me step by step commands to fix it?
Thank you very much.