Windows PC can't access SUSE11.1 Folders

I’m new to Linux, having played around with various versions of SUSE, I have now become committed to making this version my main OS.

I have no problems with Internet access, and my Linux machine can see and open folders on both Vista and XP machines. The XP and Vista machines can see the Samba machine, but cannot access the folders, the resultant message saying that permissions aren’t granted or that the description isn’t a valid host neme.

My system is running the SUSE machine , a Vista machine, and a mobile wireless / broadband hub into a 5 port hub. Plus two laptops connecting through the Network 3 wireless hub. All working fine apart from the access to the SUSE machine.

what have I missed, please help

Hi, maybe you’ve missed this sticky: Opening Samba ports in the Firewall in openSUSE 11.1 - openSUSE Forums and some threads, e.g. Help me get samba to work on 11.1? - openSUSE Forums. If you opened the firewall for samba before you applied the changes to the samba-server file, you may have to restart your firewall or close the samba ports and then open them again. Good luck!

Thanks for the help.
OK, the Firewall GUI changes had already been actioned, so I tried the terminal changes that you suggested, doing both and restarting the SUSE system gave me communication both ways, then after restarting the Vista System, access from Vista to SUSE was perfect, but I had lost access from SUSE to Vista, the windows system not showwing at all. Deleting the UDP changes made no difference, reinstating the UDP changes and deleting the BROADCAST changes made windows visible again, but took me back to a situation where I can see, but can’t access SUSE from Vista.

what am I doing wrong?

Ok, you want to do to things. (i) make your suse box accessible from windows and (ii) make shares on other computers in your network visible for openSUSE.
To do (i) you edited the samba-server file and opened the firewall. To do (ii) go to the Broadcast section of the firewall in yast and add samba browsing for your network. There’s an example somewhere near the bottom of the sticky. Good luck!

Hi again and thanks for the help.
all the settings mentioned had previously been activated. So I decided to deactivate the firewall and try again, this did the trick. So with no firewall at all everything worked OK. On double checking the Firewall configuration again, I confirmed that Samba server was listed in the allowed field - it was, but on checking the drop down list again, I noticed another Samba setting, this was “Samba Server (samba-server~)”. So I added this to the allowed services…rebooted, and everything now works with the Firewall reactivated.

thanks again.


Thank you man. :wink: