Windows boot option doesn't appear in Grub menu

Hi all,

I installed LEAP 15.1 , all went fine, except that GRUB doesn’t mention a choice to boot Windows in the menu. Thought I had already seen the problem in these forums, but cannot find it back. Here’s my hard drive partition:

Apparaat Op. Begin Einde Sectoren Grootte ID Type
/dev/sda1 * 2048 206847 204800 100M 7 HPFS/NTFS/exFAT => ‘windows boot ??’
/dev/sda2 206848 1174611967 1174405120 560G 7 HPFS/NTFS/exFAT => ‘windows partition’
/dev/sda3 1174611968 1176129535 1517568 741M 7 HPFS/NTFS/exFAT => windows recovery
/dev/sda4 1176129536 1953525167 777395632 370,7G f W95 uitgeb. (LBA) => extended partition
/dev/sda5 1176131584 1239046143 62914560 30G 83 Linux => root “/”
/dev/sda6 1239048192 1919950847 680902656 324,7G 83 Linux => “/home”
/dev/sda7 1919952896 1953525167 33572272 16G 82 Linux => swap (wisselgeheugen)

I run Windows10 , fully updated. How do I add the option in the GRUB menu please?


The two problems that I have seen:

(1) For some odd reason, the entry isn’t there after install. But it is there after you run

grub2-mkconfig -o /boot/grub2/grub.cfg

You could try that.

(2) One of those systems uses EFI booting, and the other uses traditional BIOS/MBR booting. That does not seem to be your issue.

Be sure that fast boot in Windows is off or Linux will not see the Windows partition.

Yes, that solved the problem! Thanks!

I’m glad to hear that it is now working. And thanks for reporting back.

Having same issue after fresh install on PC, do I run that command in terminal or grub 2 terminal?
I told the linux installer not to touch windows, and now windows does not even appearon f12 boot menu

Just run that in a terminal in your openSUSE system. The command does need to be run as root (or put “sudo” in front of the command). You can use “konsole” or “gnome-terminal” or “xterm” or similar.

ya did not work… what would be the best step to diagnose the problem

It might be less confusing to start your own thread. And please provide the output from:

efibootmgr -v
fdisk -l

Those commands should be run as root.