Windos10 guest unable to find and load Guest Additions

Well, this is the latest update of Tumbleweed with kernel 5.1.7. Tried to install Windows 10 on VirtualBox 6.0.8 which was installed via YaST. However, after Windows 10 was installed, tried to install Guest Additions from VirtualBox menu Device, but a host popup (it’s not inside the Windows guest VM) saying unable to find the Guest Additions virtual CD, and prompt to download it from VirtualBox site directly. The downloading however always terminates due to network issues.

I’ve not used VMs for some times. Previously install and usage of VMs on VirtualBox didn’t have any issues. Not sure what went wrong this time on the latest Virtualbox on the latest openSUSE Tumbleweed. Anyone has this type of issue too?

Download the guest.iso and move this iso to the cd in the virtualbox-gui (you must not unzip it).

Start Windows and install it

You can also download and install it directly in Windows…

Normally the Guest Additions iso should already be part of every Virtualbox install (and it’s important to be using the iso that corresponds with your installation version).

When you start a Guest, you should find a link to load the iso as a menu item in that graphical console window. Enable that and then you should be able to view the contents of the iso in your HostOS File Manager (eg PCManFM, Doilphin). Find the Linux install and “run” it

There are significant changes in Virtualbox 6.x compared to 5.x, read the docs
https://forums.opensuse.org/showthread.php/535644-FYI-Virtualbox-6-0-Guests?highlight=additions

TSU

The link to find the guest additions iso for all versions is

http://download.virtualbox.org/virtualbox/

Did you install the extension pack (without it, nothing will actually work properly)? If not, download it from here: https://www.virtualbox.org/wiki/Downloads
To install open the VirtualBox Manager. Open File - Settings - Extensions (I use the German Version, so my translation might be wrong), here you can add the extension pack, you will be asked for your root password during the process.

As far as I know, downloading the Guest Additions from inside Win10 is still broken, but you can download the Iso as mentioned in the previous post and then install after you have started Win 10. Two possible option: 1. right click on the cd-rom icon and add it, 2. devices - optical drive (or similar) and add it.
You could also add it with the VirtualBox Manager without starting Win10, just click on the Win 10 entry, then preferences - storage, here you can add the Iso as well.

Don’t forget to actually run the installation routine from inside Win 10.

Guys…

  1. Extensions which is installed in the HostOS is completely different than Additions which are installed in the Guest.
  2. The ISO <can> be downloaded but you run the risk that the content in the ISO won’t match your installation.Although there is some “give” in that oftentimes an ISO will work for multiple versions of Virtualbox, it’s usually an unnecessary risk because the ISO normally should be included as part of every HostOS install. Although you can do a file search on your system, the VBox Virtual Manager should automatically know where the ISO is and can access it as I described in my previous post.

If there is a problem locating the link in the Guest graphical console, post.
I suppose a screenshot can be posted describing exactly where it is.

TSU

Yep, extension pack was always installed right after Virtualbox was installed.

Anyhow, unlike what VM was used to be installed on Virtualbox, this time the Guest Additions has to be manually downloaded directly from Virtualbox site and then installed. Pretty weird. Either Virtualbox or openSUSE or both have some issues/bugs. The Guest Additions CD used to be automatically loaded once clicked on the Device mune.

And one more thing is that the Virtualbox Guest Tools such as virtualbox-guest-tools-6.0.8-1.2.x86_64 and virtualbox-guest-kmp = 6.0.8 provided on YaST are useless and have conflicts with others as shown the example below when virtualbox-guest-tools was tried to be installed:

virtualbox-guest-tools-6.0.8-1.2.x86_64 requires virtualbox-guest-kmp = 6.0.8,but cannot meet this requirement
providers that cannot install: virtualbox-guest-kmp-default-6.0.8_k5.1.7_1-1.2.i586[download.opensuse.org-oss]
virtualbox-guest-kmp-default-6.0.8_k5.1.7_1-1.2.x86_64[download.opensuse.org-oss]
virtualbox-guest-kmp-default-6.0.8_k5.1.7_1-1.2.i586[openSUSE_20190502-0]
virtualbox-guest-kmp-default-6.0.8_k5.1.7_1-1.2.x86_64[openSUSE_20190502-0]
virtualbox-guest-kmp-default-6.0.8_k5.1.7_1-1.2.i586[openSUSE_20190509-0]
virtualbox-guest-kmp-default-6.0.8_k5.1.7_1-1.2.x86_64[openSUSE_20190509-0]
virtualbox-guest-kmp-default-6.0.8_k5.1.7_1-1.2.i586[openSUSE_20190509-0_1]
virtualbox-guest-kmp-default-6.0.8_k5.1.7_1-1.2.x86_64[openSUSE_20190509-0_1]

virtualbox-guest-xxxxx is only inside a guest if you install openSUSE as guest.

Not on a host.

@tsu
There is no guest.iso inside my Virtualbox build by the one from the Virtualization Repo.

Thats only inside if you install the Virtualbox from the Oracle-Repo.