Win 10 dual boot gone nuclear

I have a dual boot desktop with win10 and opensuse 42.3 that was working until recently.
I am not sure if it was the new win 10 update or an opensuse update.

Currently I can only boot win 10 and there is no GRUB menu at boot. (I am saying GRUB, maybe I specifically mean GRUB2)

Originally I installed win 10 first and then opensuse, using EFI.

I have win 10 and opensuse 42.3 on the same hard disk. Here is the output of fdisk -l:

I have followed the usual steps to re-install GRUB2, specifically:

  1. I made a 42.3 install usb. I tried the “Boot from hard disk” option, which just hangs.

  2. I tried the “Boot Linux installation” option, which allows me to select the correct partition (sda5) but then has two options for the kernel. After proceeding with default options (for both kernel versions) the computer hangs and does not boot.

  3. I tried using the “Rescue system” option, following the 2nd post on this page: I set /mnt/efi… to sda1. This seems to re-install the GRUB but when I restart I have no boot option for opensuse.


  1. Is the choice of 2 kernel versions when i use the Boot Linux installation option a problem?

  2. Don’t know why everything is listed as a Microsoft basic data now …

  3. Where should I go from here?


That is unlikely to be the problem.

  1. Don’t know why everything is listed as a Microsoft basic data now …

This is not unusual. You can treat “Microsoft basic data” as “undetermined”

  1. Where should I go from here?

I’m thinking about that.

You probably just need to reinstall grub. You already did that, but I can’t tell whether you did that the right way.

What do you normally have mounted as “/boot/efi”? I presume it is “/dev/sda1”. I’m guessing that “/dev/sdb” is the USB that you used for rescue-boot.

Maybe, from a rescue boot, run:

efibootmgr -v

and post the output.

Could you please start up the “Rescue system” from the installation media and post the output of

# parted -l

and as already asked for by nrickert the resiult of “efibootmgr -v”.



Sorry for the late reply. here is what was asked for:

It looks as if the firmware (BIOS) has somehow lost the entry to boot opensuse.

That can be put back.

Maybe a quick check to make sure that all of the files are in place.

Boot your flash drive, and get a root command prompt (as you did for the previous output).

mount /dev/sda1 /mnt   ### mount EFI partition
ls /mnt/EFI/opensuse

You should see files “shim.efi”, “grub.efi”, “MokManager.efi” and “grub.cfg” (as well as some other files).

If those are all there, then:

efibootmgr -c -L opensuse-secureboot -l '\EFI\opensuse\shim.efi'

That should put back an entry for booting openSUSE.

Possibly your EFI firmware (BIOS) is removing entries from time to time.

This worked perfectly!
Thanks for everyone’s help.
nrickert - You sir are a legend in both space and time, many thanks!!

I’m glad you have it working.

The bad news, is that this might happen again. So maybe keep some notes on what to do.