Wifi woes,

Hi I can’t for the life of me figure out how to get my wireless on.

Its normally switched on by a switch on the front of the laptop but that does not seem to work with linux

I am running opensuse 11.0 the pc is an acer aspire 5670 laptop.

I have read the stickys and from them I have this info from trying out the various tests. I see on the end test that it has a line that says access denied. Dont’ know if that has any bearing on the problem???

Thx in advance

New Note 3

03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

03:00.0 0280: 8086:4222 (rev 02)

iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.23ks
iwl3945: Copyright(c) 2003-2007 Intel Corporation
PCI: Enabling device 0000:03:00.0 (0000 -> 0002)
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 17
PCI: Setting latency timer of device 0000:03:00.0 to 64
iwl3945: Detected Intel PRO/Wireless 3945ABG Network Connection
iwl3945: Tunable channels: 13 802.11bg, 23 802.11a channels
phy0: Selected rate control algorithm ‘iwl-3945-rs’
iTCO_wdt: Intel TCO WatchDog Timer Driver v1.02 (26-Jul-2007)
iTCO_wdt: Found a ICH7-M TCO device (Version=2, TCOBASE=0x1060)
iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
ACPI: PCI interrupt for device 0000:03:00.0 disabled
ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 22 (level, low) -> IRQ 22
PCI: Setting latency timer of device 0000:00:1b.0 to 64
ieee1394: Host added: ID:BUS[0-00:1023] GUID[00c09f0000746bd3]
cs: IO port probe 0x100-0x3af: clean.
cs: IO port probe 0x3e0-0x4ff: excluding 0x4d0-0x4d7
cs: IO port probe 0x820-0x8ff: clean.
cs: IO port probe 0xc00-0xcf7: clean.
cs: IO port probe 0xa00-0xaff: clean.
Adding 2104472k swap on /dev/sda5. Priority:-1 extents:1 across:2104472k
device-mapper: uevent: version 1.0.3
device-mapper: ioctl: 4.13.0-ioctl (2007-10-18) initialised: dm-devel@redhat.com
loop: module loaded
kjournald starting. Commit interval 5 seconds
EXT3 FS on sda7, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
fuse init (API version 7.9)
type=1505 audit(1225820978.254:2): operation=“profile_load” name="/bin/ping" name2=“default” pid=1670
type=1505 audit(1225820978.471:3): operation=“profile_load” name="/sbin/klogd" name2=“default” pid=1680
type=1505 audit(1225820978.570:4): operation=“profile_load” name="/sbin/syslog-ng" name2=“default” pid=1681
type=1505 audit(1225820978.630:5): operation=“profile_load” name="/sbin/syslogd" name2=“default” pid=1686
type=1505 audit(1225820978.751:6): operation=“profile_load” name="/usr/sbin/avahi-daemon" name2=“default” pid=1705
type=1505 audit(1225820978.807:7): operation=“profile_load” name="/usr/sbin/identd" name2=“default” pid=1715
type=1505 audit(1225820978.847:8): operation=“profile_load” name="/usr/sbin/mdnsd" name2=“default” pid=1719
type=1505 audit(1225820978.890:9): operation=“profile_load” name="/usr/sbin/nscd" name2=“default” pid=1720
type=1505 audit(1225820978.946:10): operation=“profile_load” name="/usr/sbin/ntpd" name2=“default” pid=1721
type=1505 audit(1225820978.986:11): operation=“profile_load” name="/usr/sbin/traceroute" name2=“default” pid=1722
IA-32 Microcode Update Driver: v1.14a <tigran@aivazian.fsnet.co.uk>
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
ip6_tables: (C) 2000-2006 Netfilter Core Team
powernow: This module only works with AMD K7 CPUs
ip_tables: (C) 2000-2006 Netfilter Core Team
nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
ADDRCONF(NETDEV_UP): eth0: link is not ready
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 17
PM: Writing back config space on device 0000:03:00.0 at offset 1 (was 100002, writing 100006)

lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:""
Mode:Managed Channel:0 Access Point: Not-Associated
Tx-Power=0 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
Subsystem: Intel Corporation Device 1001
Flags: fast devsel, IRQ 17
Memory at 8c000000 (32-bit, non-prefetchable) [size=4]
Capabilities: <access denied>
Kernel driver in use: iwl3945
Kernel modules: iwl3945[/size]

Obviously your wlan card works OK, you just have to make it associate with your AP. To achieve this, go to YaST/Network Devices/Network Settings and ADD a wireless connection (just follow the prompts, remembering to fill in the right settings as required: your ESSID, WEP/WPA encryption etc.) It’s best to set it to activate at boot (via Network Manager). After a reboot (and possibly a little extra tinkering) it should work perfectly.

OK my wireless is now working after putting in the ssid etc and doing a reboot, but if I click on the signal icon down on the task bar a popup appears with the available wireless networks.

When I click on my router the connection is broken and can’t reconnect, I get asked for password info even when i enter it it still doesn’t connect.

I had to reboot to get it to connect again.

What gives??

Is your AP hidden? If so try making it visible. Also try restarting the
network rather than a reboot;

sudo /sbin/rcnetwork restart

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 13:33, 1 user, load average: 0.09, 0.14, 0.17
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

I tried the rcnetwork restart thing and it does not solve the issue of reconnecting to my router.

Only a complete restart of the pc makes it reconnect to the wireless router

BTW the router brodcasts its ssid and its using wpa encryption.

Then if you try removing the module and re initialize;

rmmod <module name> && modprobe <module name>

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 15:52, 2 users, load average: 0.28, 0.16, 0.15
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Thanks, but how do i know what to type in the <module name> I’m finding this command line stuff a steep learning curve so please go easy and have patience.


Just a quick question did you install the iwl3945-ucode firmware rpm?

sudo zypper se iwl

There are a few modules involved can you post the output of;


lsmod show a list of all the modules running.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 21:45, 4 users, load average: 0.07, 0.10, 0.05
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

del@linux-tdk3:~> sudo zypper se iwl
root’s password:
Downloading repository ‘PK_TMP_DIR’ metadata [done]
Downloading repository ‘openSUSE BuildService - Mozilla’ metadata [done]
Building repository ‘openSUSE BuildService - Mozilla’ cache [done]
Downloading repository ‘openSUSE-11.0-Updates’ metadata [done]
Building repository ‘openSUSE-11.0-Updates’ cache [done]
Downloading repository ‘Packman Repository’ metadata [done]
Building repository ‘Packman Repository’ cache [done]
Reading installed packages…

S | Name | Summary | Type
i | iwl3945-ucode | Firmware for Intel PRO/Wireless 3945ABG WLAN Cards | package
| iwl4965-ucode | Firmware for Intel Wireless WiFi Link 4965AGN Ca-> | package
del@linux-tdk3:~> lsmod
Module Size Used by
ip6t_LOG 23428 7
xt_tcpudp 19584 2
xt_pkttype 18304 3
ipt_LOG 22788 8
xt_limit 19076 15
af_packet 38656 4
binfmt_misc 28040 1
snd_pcm_oss 64256 0
snd_mixer_oss 33408 1 snd_pcm_oss
snd_seq 73664 0
snd_seq_device 25100 1 snd_seq
ip6t_REJECT 21376 3
nf_conntrack_ipv6 33528 4
ipt_REJECT 20352 3
cpufreq_conservative 24456 0
xt_state 18944 8
cpufreq_userspace 22660 0
cpufreq_powersave 18176 0
iptable_mangle 19712 0
acpi_cpufreq 26380 0
iptable_nat 23688 0
nf_nat 35736 1 iptable_nat
speedstep_lib 21508 0
iptable_filter 19840 1
ip6table_mangle 19584 0
nf_conntrack_netbios_ns 19200 0
nf_conntrack_ipv4 27652 7 iptable_nat,nf_nat
nf_conntrack 79188 6 nf_conntrack_ipv6,xt_state,iptable_nat,nf_nat,nf_conntrack_netbios_ns,nf_conntrack_ipv4
ip_tables 30224 3 iptable_mangle,iptable_nat,iptable_filter
ip6table_filter 19712 1
ip6_tables 31376 3 ip6t_LOG,ip6table_mangle,ip6table_filter
x_tables 33668 11 ip6t_LOG,xt_tcpudp,xt_pkttype,ipt_LOG,xt_limit,ip6t_REJECT,ipt_REJECT,xt_state,iptable_nat,ip_tables,ip6_tables
ipv6 281064 15 ip6t_REJECT,nf_conntrack_ipv6,ip6table_mangle
microcode 30608 0
fuse 66332 5
loop 35332 0
dm_mod 78676 0
arc4 18432 2
ecb 20096 2
snd_hda_intel 386716 3
crypto_blkcipher 36484 1 ecb
pcmcia 55924 0
snd_pcm 100100 2 snd_pcm_oss,snd_hda_intel
snd_timer 40712 2 snd_seq,snd_pcm
snd_page_alloc 27400 2 snd_hda_intel,snd_pcm
iwl3945 106332 0
iTCO_wdt 28580 0
snd_hwdep 26372 1 snd_hda_intel
acer_wmi 27700 0
fglrx 1818912 30
yenta_socket 43020 1
tifm_7xx1 24064 0
firmware_class 25984 3 microcode,pcmcia,iwl3945
iTCO_vendor_support 20228 1 iTCO_wdt
snd 79544 14 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
rsrc_nonstatic 29696 1 yenta_socket
tifm_core 26780 1 tifm_7xx1
i2c_i801 26128 0
intel_agp 43460 0
ohci1394 48432 0
container 21504 0
sr_mod 33448 0
mac80211 190616 1 iwl3945
wmi 24488 1 acer_wmi
joydev 28224 0
led_class 21764 1 acer_wmi
ac 22916 0
battery 31108 0
button 25360 0
soundcore 24264 1 snd
rtc_cmos 27168 0
pcmcia_core 55188 3 pcmcia,yenta_socket,rsrc_nonstatic
ieee1394 107016 1 ohci1394
agpgart 50868 2 fglrx,intel_agp
i2c_core 41108 1 i2c_i801
serio_raw 23428 0
cdrom 50588 1 sr_mod
rtc_core 37148 1 rtc_cmos
cfg80211 35592 1 mac80211
rtc_lib 19328 1 rtc_core
tg3 128516 0
sg 52020 0
ehci_hcd 52492 0
uhci_hcd 40848 0
sd_mod 45336 5
usbcore 164812 3 ehci_hcd,uhci_hcd
edd 26440 0
ext3 156040 2
mbcache 25348 1 ext3
jbd 73504 1 ext3
fan 22660 0
ata_piix 38532 4
libata 176604 1 ata_piix
scsi_mod 168436 4 sr_mod,sg,sd_mod,libata
dock 27536 1 libata
thermal 40348 0
processor 67500 4 acpi_cpufreq,thermal

So the firmware is installed, the above modules would need to be
removed and re probed, I would try the iwl3945 and mac80211 first…
but it’s all very strange, it should work without the issues your

Are you sure your system isn’t trying to connect to another AP in the
area? What is the output from;

sudo /usr/sbin/iwlist <your_interface> scan

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1 day 15:42, 1 user, load average: 0.01, 0.08, 0.16
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Thanks malcolm,

this is the message returned from the terminal.

del@linux-tdk3:~> sudo /usr/sbin/iwlist <your_interface> scan
bash: your_interface: No such file or directory

I guess that i’m supposed to put something in place of “your_interface”

but to be honest I have run out of patience with linux, its too involved for my abilities.

I have other problems like earlier when a youtube window hung maximised i couldn’t work out how to get back to the desktop and had to power off and restart.

So I am going to go back to windows, it seems more friendly for the terminal shy.

Give me spanners and hammers any day.

Thanks for all your help though.