WIFI password not remembered

Hey fellow Geekos,

I’ve had a problem with my laptop remembering my home WIFI password for ONE user. My laptop is configured with four users and for three users the WIFI automatically connects. However for one user the WPA password prompt appears every time - no matter how many times I try to tell it to remember the darn thing. Anyone got any suggestions?

> cat /etc/os-release 
PRETTY_NAME="openSUSE Tumbleweed (20160417) (x86_64)"

Thanks in advance,


I am guessing that you are using KDE/Plasma 5. You should indicate desktop when asking for help.

Try this on your own account.

Go into Edit Connections for your home wifi connection.
Click the WiFi security tab.

Look at the line with the password. There should be two icons near the right of that line. But they are probably overlaid on top of one another. Maximize the edit window – or, unmaximize it. Either will fix the overlay problem, and you will now see two separate icons. One of those is to make the password visible. The other one is on where to store the password. There are three choices – store for this user, prompt every time, or store centrally for all users.

Best it to set it to store centrally.

When you have made that change for yourself, have the other users just delete their connection.

Now, back on your own account, go to edit connections again. And set that connection to be shared by all users. This will ask for the root password.

Once that is done, everyone should be able to connect using your connection definition.

Thanks for that, it helped a lot. Sorry about missing out the desktop info.

I fixed it by just changing the password storage to central for that user (it had previously been locally/encrypted). I seem to be unable to use the option for allowing the connection for everybody, because every user is then prompted for the root password every time. Still, fixed as is.

Many thanks again. Neil