WiFi needs WEP code after each boot

I was delighted yesterday when the 32 bit Beta 1 DVD installed without any problems on my Samsung NC10 netbook.
But I found that I couldn’t get WiFi to work with ifup (my usual method) so I had my very first attempt at using network manager (plasmoid).

I eventually got it to work but each time I reboot, even though there is a connection it apparently needs “authorisation” before I can access the internet. It turns out that I have to enter the WEP code each time.

Have I missed out some essential step in the process?

That “ifup” problem has been reported as a bug:

Feel free to add comments on your situation to that bug report.

As for your use of NetworkManager - you probably did something wrong.

Click on the network icon in your tray (a normal “left” click). Select “manage connections”. In the screen that comes up, click the “Other” selection in the left margin. One of the selections you can make is where to keep your network passwords. As I recall, there are three choices. The first is to keep them in secret storage. The second is to store them in files. The third is to enter the network key each time.

It sounds as if you are using the third selection. I recommend the second choice. With the first choice, you would be prompted for the kwallet password each time, and that is rather annoying since the network password is not stored in kwallet anyway.

Apart from that, when setting up a wireless connection, I click on the wireless connections tab, then click “Add” to add a new network. There is a choice between “wireless” and “shared” - choose “wireless” (“shared” turns out to be a strange way of spelling “ad hoc”).

Next, enter the SSID, and give the network a name if you don’t like the default. Then click on the “security” tab, and enter the WEP key there. If you set the connection to “Connect automatically” (and perhaps to “System Connection”), then it should remember everything needed. It will ask for the root key to save those settings. At least with both “System Connection” and “Connect automatically” both set, it should connect automatically in the future with no effort from you.

I hope that helps.

Aha - that’s done the trick. Many thanks for your help and the info about ifup.
It’s amazing how easy it is to miss these little details!