WiFi instantly disconnects after upgrading kernel-firmware-* from 20240519-1.1 to 20240618-1.1

Updated this morning, and after a reboot WiFi was stuck in a tight connect/disconnect loop. I rolled back the update and installed bits at a time and narrowed it down to the kernel-firmware-* packages. The upgrade was from 20240519-1.1 to 20240618-1.1. The issue is identical whether I boot with kernel 6.9.4-1 or 6.9.5-1.

There’s stacktraces in dmesg in iwlwifi that look very relevant, I’ve uploaded the WiFi related dmesg contents here: dmesg - Pastebin.com


seeing the same problem after this morning update



1 Like

Temporarily fix

wget https://downloadcontentcdn.opensuse.org/repositories/home:/mixaill:/branches:/Kernel:/HEAD/openSUSE_Tumbleweed/noarch/kernel-firmware-iwlwifi-20240618-500.1.noarch.rpm

sudo zypper install kernel-firmware-iwlwifi-20240618-500.1.noarch.rpm

sudo reboot

Request to OpenSUSE upstream: Request 1181983: Submit kernel-firmware - openSUSE Build Service


Since I need a separate /boot partition, I can’t boot into an older snapshot and of course I have no internet without that package correctly working.

Can I use YaST to undo some specific changes? I can’t locate the correct path to restore though. Anybody has any idea?

You can roll back by running sudo snapper rollback <number> when booted normally. Obviously you want to then reboot immediately because anything you do after running that command will be lost! My boot menu doesn’t have options to boot into a snapshot, I’ve never investigated why, I probably should!

Unfortunately I tried that command, but didn’t solve. Guess I’ll try to use USB Tethering with my Android device, but this TW is becoming to feel very disappointing. No snapshots, tested packages that seem untested.

By the way, for bootable snapshots I opened this: How to boot in a snapshot - English / Install/Boot/Login - openSUSE Forums

In my case, I need to use a separate /boot partition, which kind of “breaks” the functionality of bootable snapshots. Systemd-boot can work since some… “stuff” move to /boot/efi (in this case a larger partition is needed), but it’s still in testing and not supported in YaST.

Unfortunately the whole wget with the temporary fix etc etc did not solve the issue.

Time to check the Live ISO and re-test with it. If wifi works, then something else happened when updating.

Eventually, I’ll re-install and think about Slowroll in the future.

Yeah, it turns out that several models of Intel WiFi adapters were affected, while I tried to fix AX210 only.

For proper fix you need to install a new kernel

Please note that these packages are unsigned and require a MOK key enrollment after reboot. Do not try to install them remotely with secure boot enabled.

1 Like

I’ve reinstalled with Slowroll and blocked the kernel package so it doesn’t get updated. I really have no reasons for it to be updated since it works, I can unblock it with YaST as soon as I know (maybe never) that the issue is fixed and then switch to normal Tumbleweed repo.

Yeah me too. These are incredibly common WiFi adapters on laptops so a LOT of people will see this issue and the QA servers are probably not using these so it makes sense why they didn’t catch it.

Newer kernel or locking the firmware works but in any case this is going to hit a lot of people.