Wifi doesn't work on 11.4 KDE x86-64 with Broadcom 4312

Wifi works on 11.3 with installed the broadcom-wi & broadcom-wl-kmp-desktop,but this trick doesn’t work on this new 11.4.
Any suggestion? :expressionless:

Install Broadcom Drivers from Packman

If you made any attempt to install the b43
Do this: sudo /sbin/modprobe -rv b43

Shutdown and then restart

Check the wl driver function

Thanks for your suggestion bro,but still ain’t work…

On 03/10/2011 12:36 PM, caf4926 wrote:
> ‘Install Broadcom Drivers from Packman’ (http://tinyurl.com/2c72nor)
> If you made any attempt to install the b43
> Do this: sudo /sbin/modprobe -rv b43
> Shutdown and then restart
> Check the wl driver function

With 11.4, you may also use b43 with the BCM4313. You need to

sudo /usr/sbin/install_bcm43xx_firmware

That command needs a network connection.

Thanks bro,but your suggestion ain’t work…

Please give the output of “hwinfo --wlan”. By default the new brcm80211 module will be used in 11.4 for broadcom wireless devices which is extremely unstable. It may be conflicting with the “wl” driver from packman.

Also take a look here please:
opensuse11.4 users who have BCM4013 wireless cards, please pay attention to this thread

Hi all,

I’m also having a lot of trouble getting wireless working with 11.4. It was running fine with 11.3, but as soon as I installed 11.4 I started having a lot of trouble.

I’d already installed 11.4 earlier in the day on another laptop and had similar problems. The hardware was also with Broadcom, I think, but probably an older version and it hadn’t ever given me problems in 11.3 before (I’d installed a couple of SUSE versions on that one in the past). This time it didn’t work, but I was able to get it working with

sudo /usr/sbin/install_bcm43xx_firmware

That was a 32-bit system. Then I moved on to the next computer, which needs 64-bit. Popped in the 64-bit KDE Live CD (checksum checked it out okay) and installed it without a problem. As I’d expected, though (I knew this from 11.3 on this laptop) it wasn’t able to use the WLAN card yet. I tried the same command to install the firmware with an ethernet connection, but it didn’t help, even after a restart.

As a next step I added the Packman repository and installed the following packages:

I left the system and it froze after a while, I couldn’t even unlock the screen, so I installed the whole system again. This time I installed the two packages above from Packman without using install_bcm43xx_firmware.

After restarting the kernel showed up in grub, but the system would freeze while booting, so I booted with the old kernel and installed:

It would boot, but also wasn’t able to use the wireless card.

Now I’m not sure where to go or what to do from here. Anybody have any tips? I’d greatly appreciate them!!

Here’s some additional info:
The wireless switch on my laptop is turned on, but the light indicating that it’s on isn’t.
Every time I enable wireless in KNetworkManager the “show more” button pops u for a second and then disappears. The button doesn’t stay checked.

Output from /sbin/lspci:

05:00.0 Network controller: Broadcom Corporation BCM43225 802.11b/g/n (rev 01)

Output from /sbin/lspci -n:

05:00.0 0280: 14e4:4357 (rev 01)

Output from dmesg | less:

    7.906684] brcm80211: module is from the staging directory, the quality is unknown, you have been warned.
    7.909543] brcm80211 0000:05:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    7.909553] brcm80211 0000:05:00.0: setting latency timer to 64
    8.229200] wlc_bmac_attach:: deviceid 0x4357 nbands 1 board 0x4da macaddr: 00:26:82:ad:65:98
    8.673286] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
    8.673741] wl_set_hint: Sending country code US to MAC80211
    8.673747] wl0: Broadcom BCM43xx 802.11 MAC80211 Driver 5.75.11 ( (Compiled in . at 01:58:44 on Feb 23 2011)

Output from /usr/sbin/iwconfig:

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

Output from sudo /usr/sbin/iwlist scan:

wlan0     Interface doesn't support scanning : Network is down

Output from hwinfo --wlan:

16: PCI 500.0: 0282 WLAN controller                             
  [Created at pci.318]
  Unique ID: y9sn.9jxkxN6uGA4
  Parent ID: qTvu.ol2YwXEQdsC
  SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:05:00.0
  SysFS BusID: 0000:05:00.0
  Hardware Class: network
  Model: "Broadcom WLAN controller"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4357 
  SubVendor: pci 0x14e4 "Broadcom"
  SubDevice: pci 0x04da 
  Revision: 0x01
  Driver: "brcm80211"
  Driver Modules: "brcm80211"
  Device File: wlan0
  Features: WLAN
  Memory Range: 0xd6400000-0xd6403fff (rw,non-prefetchable)
  IRQ: 17 (no events)
  HW Address: 00:26:82:ad:65:98
  Link detected: yes
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v000014E4d00004357sv000014E4sd000004DAbc02sc80i00"
  Driver Info #0:
    Driver Status: brcm80211 is active
    Driver Activation Cmd: "modprobe brcm;)80211"                                               
  Driver Info #1:                                                                             
    Driver Status: wl is active                                                               
    Driver Activation Cmd: "modprobe wl"                                                      
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #7 (PCI bridge)

Right now I’m trying my hand at installing the driver provided by broadcom (Broadcom.com - 802.11 Linux STA driver) with limited success

Thanks so much,

Hi Daniel

From your output, it seems that ur using the brcm80211 driver
this driver is not very stable as of now (as i experienced similar problem, altho my card is bcm4313)

u said ur wireless was working fine back in 11.3, did u use broadcom wl driver back then?
if u did, the quickest way to solve ur problem is prbly just to blacklist brcm80211 and reactivate the broadcom wl driver

just go to /etc/modprobe.d and edit the file 50-blacklist.conf
add blacklist brcm40211 to the end

by doing this, my wireless started working flawlessly again :smiley: , so it could work for u as well

Thanks for the quick response!

alright, I tried adding blacklist brcm40211 to the end of /etc/modprobe.d/50-blacklist.conf. Restarted, no difference… Sadly.

I’d also uninstalled all the broadcom stuff from packman before trying to install the drivers provided by broadcomm, so after having added the line to the end of 50-blacklist.conf I used YaST to install broadcom-wl again.

Interestingly enough, when selecting broadcom-wl, YaST automatically selected broadcom-wl-kmp-xen instead of broadcom-wl-kmp-default like before. Anyway, I installed it, but wasn’t able to boot with that kernel, like before, so I booted with the old kernel again and installed broadcom-wl-kmp-desktop (I have really no clue about kernels, but it worked before so I figured why not try it again). Still can’t boot with that kernel. I’m starting to think my newly installed system might be so convoluted that once I get wireless working I’ll write down how I did it, do a complete fresh install again and then do just the relevant steps.

So I guess the problem wasn’t brcm40211… :frowning:

u r supposed to just stick with the default kernel and install broadcom-wl-kmp-desktop :stuck_out_tongue:
xen as far as i know is for virtual machine
as for the broadcom wl driver, did u check the kernel version it’s for? the last few digit of the version number should give u a clue
it has to correspond to ur current kernel version, which is i believe, otherwise the module wouldnt load

by the way, can u please post the ur .bashrc file?
as i accidentally overwrote my .bashrc file just now…

Oh okay… I’m going to reinstall the entire system now and not touch the brcm40211 :stuck_out_tongue: Then I’ll try installing broadcom-wl-kmp-desktop. No virtual machine :smiley:

I’ve got kernel… The version number of broadcom-wl-kmp-desktop v., so it looks like it’s the right version for my kernel… We’ll see how it works when I’ve freshly installed it for the third time…

Oh, and my .bashrc file has following content:

# Sample .bashrc for SuSE Linux
# Copyright (c) SuSE GmbH Nuernberg

# There are 3 different types of shells in bash: the login shell, normal shell
# and interactive shell. Login shells read ~/.profile and interactive shells
# read ~/.bashrc; in our setup, /etc/profile sources ~/.bashrc - thus all
# settings made here will also take effect in a login shell.
# NOTE: It is recommended to make language settings in ~/.profile rather than
# here, since multilingual X sessions would not work properly if LANG is over-
# ridden in every subshell.

# Some applications read the EDITOR variable to determine your favourite text
# editor. So uncomment the line below and enter the editor of your choice :-)
#export EDITOR=/usr/bin/vim
#export EDITOR=/usr/bin/mcedit

# For some news readers it makes sense to specify the NEWSSERVER variable here
#export NEWSSERVER=your.news.server

# If you want to use a Palm device with Linux, uncomment the two lines below.
# For some (older) Palm Pilots, you might need to set a lower baud rate
# e.g. 57600 or 38400; lowest is 9600 (very slow!)
#export PILOTPORT=/dev/pilot
#export PILOTRATE=115200

test -s ~/.alias && . ~/.alias || true

Haven’t done anything with it, it’s just the default one I guess.

thank you :smiley:

and wish u best LUCK

Hi bro,this is the output of hwinfo --wlan:

30: PCI 900.0: 0282 WLAN controller
[Created at pci.318]
Unique ID: y9sn.bL_9V016GP1
Parent ID: H0_h.6vrbguIpoXB
SysFS ID: /devices/pci0000:00/0000:00:06.0/0000:09:00.0
SysFS BusID: 0000:09:00.0
Hardware Class: network
Model: “Hewlett-Packard Company BCM4312 802.11b/g Wireless LAN Controller”
Vendor: pci 0x14e4 “Broadcom”
Device: pci 0x4315 “BCM4312 802.11b/g”
SubVendor: pci 0x103c “Hewlett-Packard Company”
SubDevice: pci 0x137d “BCM4312 802.11b/g Wireless LAN Controller”
Revision: 0x01
Driver: “b43-pci-bridge”
Driver Modules: “ssb”
Device File: wlan0
Features: WLAN
Memory Range: 0x51100000-0x51103fff (rw,non-prefetchable)
IRQ: 18 (no events)
HW Address: 00:21:00:45:92:14
Link detected: yes
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: “pci:v000014E4d00004315sv0000103Csd0000137Dbc02sc80i00”
Driver Info #0:
Driver Status: ssb is active
Driver Activation Cmd: “modprobe ssb”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #5 (PCI bridge)

And the output of /sbin/lspci -n:

09:00.0 0280: 14e4:4315 (rev 01)
0a:00.0 0200: 10ec:8136 (rev 02)

I’ve uninstalled all broadcom wi stuff,now stick with 11.4 desktop kernel & looking for solution.

Hey there,

Just a heads up, I tried it again and again it was a no go. I’m really disappointed about this - I’ve always had great experiences with OpenSUSE and it’s my favorite operating system. But to be operational now I’m going to have switch to another distro or another version, at least for a while. Really too bad, especially since I’ve seen what 11.4 now has to offer - I just can’t use it with this particular computer to get into the Internet with wireless.

Does anybody have any other ideas? So far I’ve tried:

  • Installing the firmware with /usr/sbin/install_bcm43xx_firmware
  • Installing broadcom-wl with the appropriate kernel packages

Nothing’s worked - I think the kernel route might have worked, but my system was never able to boot with the kernel that was installed with the broadcom-wl package.

I tried every step on a freshly installed system (meaning my system was reinstalled I think four times lol! )

Anyway… Very sad about having to forego SUSE until I can get back to Europe, but since I only have one computer here I really have to make sure I’m able to work effectively. If anybody can think of another possibility, I would be VERY happy to hear about it. Thanks!


From my experience the “broadcom-wl” package will pull in the wrong version. If you have the package “kernel-desktop” installed you need to manually install “broadcom-wl-kmp-dektop” to match the kernel.

As I have written in the other brcm80211 thread, for me the best success in disabling the brcm80211 was to rename the firmware symbolic links in /lib/firmware/brcm.

After that, the broadcom-wl package worked fine.

It’s pretty chaotic at the moment with broadcom wireless hardware as there are 3 conflicting drivers available.

  1. The b43 that is listed as your current used driver is the old reverse engineered open source driver. To get the correct firmware for this driver the script /usr/sbin/install_bcm43xx_firmware is available.
  2. The brcm80211 is the new open source driver, supported officially by broadcom, but very immature. The firmware for this driver is included in the “kernel-firmware” package.
  3. The “wl” driver is the official non-free driver from broadcom and the one that is (for me) working best. The firmware is included in the driver package from packman.

So, this is how I would have to install OpenSUSE 11.4 on my HP laptop:

  1. Go into the BIOS menu and deactivate the wlan/bluetooth card and the wireless switch, otherwise the LiveCD won’t boot.
  2. Install OpenSUSE and use wired LAN to do an update and install “broadcom-wl” and “broadcom-wl-kmp-desktop”.
  3. rename the firmware links of the brcm80211 driver. That was, for me, more effective than blacklisting it:

mv /lib/firmware/brcm/bcm43xx-0.fw /lib/firmware/brcm/ORIGbcm43xx-0.fw
mv /lib/firmware/brcmbcm43xx_hdr-0.fw /lib/firmware/brcm/ORIGbcm43xx_hdr-0.fw
  1. Reboot to the BIOS settings and reactivate the wireless card.
  2. Boot into OpenSUSE. your system should now use the “wl” driver.

From my experience the “broadcom-wl” package will pull in the wrong version
Correct, it tried to do that for me also.

Hi All

I’ve got a BCM4313 (EEEPC1015PEM) with similar problems:

linux-qm7m:~ # lspci
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

It was solved by installing the following rpm for 11.3, which has not made it into 11.4 as of release:

11.946470] brcm80211: fail to load firmware brcm/bcm43xx-0.fw
11.946485] brcm80211: Failed to find firmware usually in /lib/firmware/brcm

wget http://download.opensuse.org/repositories/driver:/wireless/openSUSE_11.3/noarch/brcm80211-firmware-0.610.809.0-1.1.noarch.rpm

rpm -Uvh brcm80211-firmware-0.610.809.0-1.1.noarch.rpm

I’m not sure it works for 4312 but worth testing.

The file “/lib/firmware/brcm/bcm43xx-0.fw” is part of the package “kernel-firmware” in 11.4. Please check if it is properly installed (and beware of conflicts with your manually installed firmware package!).

Very helpful tip. I just installed OpenSUSE 11.4 again on the laptop and tried exactly that out with a completely fresh system. Didn’t do anything. Funny thing is, before I’d always see an additional kernel that I could boot with in GRUB. This time I don’t - probably due to the fact that I downloaded the drivers that are compatible to my kernel? In any case, it didn’t make any difference. If I try to switch on wireless in KNetworkManager it simply doesn’t work. :frowning:

Are you sure you have:

  • The correct driver listed in “hwinfo --wlan | grep Driver:”? it should be “wl”
  • reactivated your wireless card in the BIOS
  • switched the key on your laptop keyboard on (You sadly cannot see its state in KNetworkmanager)