wifi connection how to?

I have OpenSUSE Leap 15.1 installed on my PC. I would like to use my wifi network. I tried to use YAST2 but could not achieve internet access. Then I found a tip on the net to use Network Manager. Where do I find it and how to use it?

What Desktop Environment are you using? You should have an applet in the desktop to manage network connections, that is an interface to NetworkManager.
Should you prefer a text interface, open a terminal and try:


Check “man nmtui” for details. You might also check “man NetworkManager” or “man nmcli” for a command line interface.
The following pages might also be useful (but maybe some content is not up to date):

You may be suffering from a well-known bug in the Leap 15.1 ISO. It tells you that it is installing network manager and then installs wicked.

Go to YaST>System>Network settings (ignore any error messages). Make sure the Network Setup Method is NetworkManager Service.

Go to YaST>Servces Manager and make sure that NetworkManager is set to On boot and Wicked is set to Manually. Save any necessary changes.

Close YaST; open a terminal, enter su followed by your root password and enter:

rm /etc/resolv.conf
init 6

When you reboot, all should be fine.

I got a similar problem, thanks for the links.

The details of setting and using NetworkManager are here: <https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha-nm.html>.
As far as openSUSE is concerned, there is some basic information regarding NetworkManager here: <https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha-network.html#sec-network-nm>.
[HR][/HR]If your Desktop is GNOME then, the information which references the above Reference manual entry is here: <https://doc.opensuse.org/documentation/leap/gnomeuser/html/book.gnomeuser/cha-gnomeuser-use.html#sec-gnomeuser-use-connections>.
Once again for GNOME, the information regarding the “Password Wallet” «a “Key-Ring”» you’ll need to store the WLAN “secrets” is here: <https://doc.opensuse.org/documentation/leap/gnomeuser/html/book.gnomeuser/cha-gnome-crypto.html#cha-gnome-crypto-prefs-keyrings>.
[HR][/HR]If your Desktop is KDE Plasma then, the information mentioned above is also relevant for the NetworkManager Plasmoid.
Information regarding that KDE Plasma Password Wallet is here: <https://docs.kde.org/stable5/en/kdeutils/kwallet5/index.html>.
You’ll need this information to automatically unlock the Wallet on login: <https://wiki.archlinux.org/index.php/KDE_Wallet>.
This is also useful: <https://wiki.archlinux.org/index.php/NetworkManager#Encrypted_Wi-Fi_passwords>.

Thanks for all of you! I have somehow fiddled with Yast2 and eventually managed to get my wifi connection working. But here comes the rub, occasionally I lose my connection. I found that unplugging my tp-link usb wifi adapter and then replugging it solves the problem, it starts blinking and wifi works again. I have a dual boot PC (win7/OpenSUSE…) and this very rarely happens in windows but is almost regularly happening in Linux. It cannot be a simple contact problem as then it would also regularly happen in Windows. But as I said I only have this phenomenon in Linux. Do you have an explanation?

tp-link usb wifi adapter

Please show us:

uname -a

I tried to photo my terminal image and paste it here but this did not go. So now I will copy:

lsusb: Pixart Imaging, inc. Optical Mouse
Intel Corp. Integrated Rate Matching Hub
Linux Foundation 2.0 root hub
Holtek Semiconductor, Inc. Keyboard
Intel Corp. Integrated Rate Matching Hub
Linux Foundation 2.0 root hub

uname -a: Linux linux-ticm 4.12.14-lp151.27-default #1 SMP Fri May 10:13:15 UTC 2019 (862c838) x86_64 x86_64 x86_64 GNU/Linux

I tried to photo my terminal image and paste it here but this did not go. So now I will copy:

Why when your Wifi is working?

But you have to plugin the USB-Wifi-Adapter which is not shoen…

I have tried once again to plug in the adapter and run lsusb and uname -a, for lsusb I got the same answer as before but this time also:

Realtek Semiconductor Corp RTL 8188EUS 802.11n wireless Network Adapter … so it is now there

uname -a: Linux linux-ticm 4.12.14-lp 151.27- default # 1 SMP Fri

May 10 141:13:15 UTC 2019 (8

The problem remains sometimes I get the wifi working and then the adapter blinks, at other times I have to unplug and replug the usb adapter to get the wireless connection. When the usb adapter blinks thewifi is on!

This does not happen when the use the windows 7 boot on the SAME PC!!!

You can copy and paste what the command is showing:



ich@linux64:~> lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 005: ID 06f8:3005 Guillemot Corp. Hercules Dualpix Exchange
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 004: ID 0c4b:0500 Reiner SCT Kartensysteme GmbH cyberJack RFID standard dual interface smartcard reader
Bus 001 Device 008: ID 0a5c:21e8 Broadcom Corp. BCM20702A0 Bluetooth 4.0
Bus 001 Device 006: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Important is the ID f.e.:

Bus 001 Device 008: ID 0a5c:21e8 Broadcom Corp. BCM20702A0 Bluetooth 4.0

Here is the full answer to lsusb:

BUs 001 Device 006 ID 0bda:8179 Realtek SEmiconductor Corp. RTL 8188 EUS 802.11h wireless network adapter

I tried to plug into another USB port but the situation remains, after booting to linux the adapter is nopt working, while it works like a breeze when booting into Winodws7

With the user “root”, can you please show us the output of:

 # lsusb -v -s 001:006

Can you also, please take a look into the systemd Journal?

  • With the user “root”, “journalctl --this-boot”.
  • Anything related to “RTL 8188” and, the associated device, is of interest.

I have the responses to these commands but how can I copy the bash window content in order to send you a text file containing it. I tried ctr shift c to copy but I cannot paste it either by ctr shift V or ctr V.
The journal is very extensive I cannot copy it by hand…

Two choices:
for a very long paste, redirect the command output to a file instead, like:

journalctl --this-boot > journal.txt

then work with the text file;

for a short copy, select the output to copy by dragging your mouse over the terminal, then CTRL+SHIFT+C should copy to the clipboard (then the usual CTRL+V should paste into the editor window).

You don’t have to.
[HR][/HR]Please, do the following – the example is, “What happens when I plug a USB-Stick into the machine and then, remove it.”:

 # journalctl --follow
-- Logs begin at Mon 2020-01-13 23:39:41 CET. --
Mai 04 10:53:16 xxx kernel: usb 2-2: new high-speed USB device number 2 using ehci-pci
Mai 04 10:53:16 xxx kernel: usb 2-2: New USB device found, idVendor=abcd, idProduct=1234
Mai 04 10:53:16 xxx kernel: usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Mai 04 10:53:16 xxx kernel: usb 2-2: Product: UDisk
Mai 04 10:53:16 xxx kernel: usb 2-2: Manufacturer: General
Mai 04 10:53:16 xxx kernel: usb 2-2: SerialNumber: Љ
Mai 04 10:53:16 xxx kernel: usb-storage 2-2:1.0: USB Mass Storage device detected
Mai 04 10:53:16 xxx kernel: scsi host7: usb-storage 2-2:1.0
Mai 04 10:53:16 xxx mtp-probe[32019]: checking bus 2, device 2: "/sys/devices/pci0000:00/0000:00:13.2/usb2/2-2"
Mai 04 10:53:16 xxx mtp-probe[32019]: bus: 2, device: 2 was not an MTP device
Mai 04 10:53:17 xxx kernel: scsi 7:0:0:0: Direct-Access     General  UDisk            5.00 PQ: 0 ANSI: 2
Mai 04 10:53:17 xxx kernel: sd 7:0:0:0: Attached scsi generic sg9 type 0
Mai 04 10:53:17 xxx kernel: sd 7:0:0:0: [sdh] 7989248 512-byte logical blocks: (4.09 GB/3.81 GiB)
Mai 04 10:53:17 xxx kernel: sd 7:0:0:0: [sdh] Write Protect is off
Mai 04 10:53:17 xxx kernel: sd 7:0:0:0: [sdh] Mode Sense: 0b 00 00 08
Mai 04 10:53:17 xxx kernel: sd 7:0:0:0: [sdh] No Caching mode page found
Mai 04 10:53:17 xxx kernel: sd 7:0:0:0: [sdh] Assuming drive cache: write through
Mai 04 10:53:17 xxx kernel:  sdh: sdh1
Mai 04 10:53:17 xxx kernel: sd 7:0:0:0: [sdh] Attached SCSI removable disk
Mai 04 10:53:24 xxx kernel: usb 2-2: USB disconnect, device number 2

Therefore, taking the above example as a template, remove your USB-WiFi device, with the user “root” in a Terminal Window: “journalctl --follow”, plug in your USB-WiFi device and, note the journal trace – <Ctrl-C> to stop the trace – highlight the Journal text in the Terminal Window – either <Shift-Ctrl-C> or, with the mouse <Right-Click> “Copy”, to copy the text off the the Paste Buffer – paste the text into a newly created text file.

  • Once the text file has been saved, you can use it’s contents as a basis to search the Journal for the events which occur when your USB-WiFi device is “discovered” by the Linux Kernel, either at boot time or, any other time …

[HR][/HR]Looking at everything which is going on here, I suspect that, either:

  1. At each boot the USB-Hub responsible for the port where your USB-WiFi device is plugged in, is getting a different USB-Bus address or,
  2. Your machine is suffering from an intermittent issue with that USB-Hub – the same issue that one of my Laptops suffers from time to time – a reboot usually, mostly always, fixes the issue …

[HR][/HR]If, the problem is the former, you’ll need multiple Network Manager profiles for each possible USB-Bus address your USB WiFi device receives at boot time.

  • Ditto for Wicked or, any other method being used to manage the machine’s network …

Thank you I will follow your advice. Meanwhile a different question maybe you can answer me within this thread (I do not know how to start a new thread I cannot find the option on your website). So my question is. how do I know whether my OPenSUSE Leap 15.1 is a 323 or 64 bit linux version?

It’s only 64-bit.

  • The 32-bit version was dropped several years ago with Leap 42.1.
uname -i

will show you the architecture of your installed system, e.g. x86_64 for 64 bit.


Your next question, 32-bit applications running on openSUSE Leap 15.1 is answered here: <https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha-64bit.html>.