Wierd Sound Issue

I just installed OpenSuse 11 yesterday. I can’t seem to get the sound configured correctly. For some reason its using the internal computer speaker in addition to feeding audio out of the rear speaker port on the computer. I want to disable the internal speaker and just use the external speakers.

Its a business class HP / Compaq, Core2Duo, OpenSuse 11 64bit

Have you tried experimenting with the Alsa Mixer program?

Yes, no settings seem to help.

Did you try switching OFF the internal speaker ?

I don’t know the exact syntax, but it is something like:

amixer set ‘PC Speaker’,0 off
amixer set ‘PC Speaker’,0 0% off