Widevine in Chromium?

I don’t know if this is the correct forum for this (? applications, ? multimedia) but I have recently switched from using to Chrome to Chromium and cannot watch Netflix with it. Chrome requires a plugin called “Widevine” to play Netflix. There is a widevine plugin for Chromium available through packman which I have installed but Chromium fails to see it (it is not listed in chrome://plugins). Has anyone else encountered this problem, or better yet, found a solution for it?

openSUSE 13.2 x86_64 KDE.

I don’t know about whatever you might have found in Packman,

But a quick Google search suggests that…

  • A solution was developed by Ubuntu contributors which I’d guess should work for everyone else, but of course in their wisdom built and posted their work on an Ubuntu-only platform (Launchpad). You can read the bug report and fixes here

  • I’d recommend you file a bug at https://bugzilla.opensuse.org hoping that someone in the main Chromium project would be willing to integrate… if it doesn’t violate any principles. You’ll notice as discussed in the bug that the problem may be a matter of extending branding to the “chrome” namespace (I don’t know if that is actually the case) and I don’t know if that would be acceptable to the Chromium people. I assume the alternative is to approach the Widevine people and ask them why they made that namespace a requirement to successfully build their code, if they removed that requirement then in the long run it would mean wider adoption and use.


You might also take a look at this.

Suggests that the plugin might work with a tiny bit of manual modification.


Thanks, tsu. Suggestion #2 worked. I had tried the ubuntu solution but it didn’t work for me.