Why trying to contact Google time servers?


Updated one of my TW 64 KDE today to the latest version, just to find out that it is now trying to contact Google time servers, which are blocked in my firewall.

Have blocked access events in my perimeter firewall logs, trying to reach:

My time is set in YaST to be obtained from specific NTP server (specified by IP, not hostname).

Is this a new “feature” of Firefox 57? Only application running on this machine.

Very strange…

…had a look back in the firewall logs, earliest I could find:

Nov 18 09:25:55 …,…,123,

So it started last Saturday morning…

Did updates on 17-NOV… strange…

Don’t see it here with Firefox 57 and Gnome shell, just the normal ntp comms with ntp servers as configured.

Maybe a plugin or a DE feature…?

…on Friday updates FF57 was not included, I checked /var/log/zypper logs…

Very strange, as no other applications are running on this machine, besides plain vanilla TW64bit with KDE.

And only AddOn on FF is No Script…

Here you go… systemd… mine are remmed out… I’m guessing yours are not.

cat /etc/systemd/timesyncd.conf

# See timesyncd.conf(5) for details.

#FallbackNTP=time1.google.com time2.google.com time3.google.com time4.google.com

…looks EXACTLY the same way on this machine… Sorry…

I had a look in the logs of ntpd, there is no error for the configured NTP server and no events loged for these Google NTP servers. Must be something else…

So what’s the status of;

timedatectl status

      Local time: Tue 2017-11-21 11:02:22 CST
  Universal time: Tue 2017-11-21 17:02:22 UTC
        RTC time: Tue 2017-11-21 17:02:22
       Time zone: America/Chicago (CST, -0600)
 Network time on: no
NTP synchronized: yes
 RTC in local TZ: no

Is Network time on?

Looks normal

timedatectl status
      Local time: Tue 2017-11-21 18:11:27 CET
  Universal time: Tue 2017-11-21 17:11:27 UTC
        RTC time: Tue 2017-11-21 17:11:27
       Time zone: Europe/Berlin (CET, +0100)
 Network time on: yes
NTP synchronized: yes
 RTC in local TZ: no

What is network time?

Turn this off;

Network time on: yes

timedatectl set-ntp false

I would surmise if you do that google will disappear…

FWIW, those were introduced to smear time for the leap second… Google turns on free public NTP servers that SMEAR TIME • The Register

…turned this networktime off. Will have an eye on the firewall logs.

Why is this suddenly turned on for ONE machine? Several TW here…?!?

It’s systemd-timesyncd - disable the service or change your settings in /etc/systemd/timesyncd.conf

for example, this is what I use:

#FallbackNTP=time1.google.com time2.google.com time3.google.com time4.google.com

FallbackNTP=0.uk.pool.ntp.org 1.uk.pool.ntp.org 2.uk.pool.ntp.org 3.uk.pool.ntp.org

The FallbackNTP servers are hard coded to use google - see man timesyncd.conf - so even though in the default config they are commented out… they are still used unless you explicitly set your own.

Edit: OK… see you’ve disabled it now.