Why am I getting Firefox instead of

This is becoming supremely irritating.

The Update applet tells me I have a security update for Firefox, specifially

Then it downloads and installs Firefox - which happens to be a complete POS!

Firefox 3.0 is a disaster - the right click menu doesn’t work properly, it crashes on God knows how many Web sites that used to work fine in earlier versions.

It’s crap.

But the real complaint is - WHY is it being mis-represented by the updater as an earlier version? Whose brilliant idea was that?

Now I have to go through the whole **** uninstall process again and reinstall

  • richardstevenhack,

at a guess, you enabled the Mozilla community repository. Disable that and you’ll keep Firefox 2.
BTW, I don’t see the problems you have. It is terribly annoying when I scroll, but else it works fine. I suggest you rename your .mozilla folder and start from scratch for testing purposes, maybe it is just some add-on acting up.


I am sorry to hear that richardstevenhack has had such problems with Firefox 3; our experience has been the complete opposite: we upgraded to 3.0.1 recently with YaST; the upgrade ran smoothly and Firefox has worked flawlessly since then; we added download.opensuse.org/repositories/mozilla/openSUSE_10.2/ as we are running 10.2

I haven’t had any problems with FF3, but the updater doesn’t upgrade between major versions. What probably happened is that you have both on your system and the launcher is pointing to FF3. You have to edit the launcher. Another thing is that the way the wrapper script is written, it is not possible to run both at the same time, because it will try to look for an existing running instance, whether FF2 or FF3.

FF3 has issues with fonts in KDE and the work arounds are not acceptable in my opinion. It has issues with flash and flv files on certain sites, many won’t play, and many crash the browser.

I have used FF3 extensively, after applying all the work arounds just to get it to render fonts decently on an LCD screen, it certainly looked fine, but the crashes and issues with flv files is problematic in an age where just about every web site is using flash for something, and most are now using it for video rather then media players.

FF2 just works, no issues, no crashes, all files play as expected and I don’t have to install crap from another DE to make fonts look correct and don’t have to configure font rendering in another DE then run dameons in the background from that DE.

Making FF3 dependent on a specific DE is a huge mistake. The crashing and inability to play certain flv files is baffling to say the least.

No problems with Flash here either. I installed the Flash player from the one-click installer for restricted formats. The recent update to X11 fonts seems to have improved readability. And I’m on a LCD screen also.

I should add that it’s worth working out how to get FF3 working as FF2 has less than 6 months life left.

Check this out ken

Community Repositories

Plays fine here. Not exactly a wallpaper I would choose, but it’s your desktop. :slight_smile:

Plays fine for me in everything but FF3. In FF3 nothing shows up at all, and there are a few other sites I have the same problem with, as are numerous other people with FF3 regardless of the OS they use.

Figured out the flv/flash problem.

Adblock was causing the problem.

Installing Adblock Plus works with no ill side effects

That’s why I use Opera. :slight_smile:

I use Flashblock which blocks autoplay of flash, the new annoyance, after animated gifs. Also I regard autoplay of flash as a hazard. What if an exploit is found in Flashplayer, updates for which we are at Adobe’s mercy?

OK, so the fact that I had the Mozilla community in my repositories meant I got one instead of the other.

That’s still wrong. If the applet shows, that’s what I should have gotten without my having to edit anything.

As for trying with a fresh profile, I did that, too. No change. Firefox right click on every third or fourth or whatever click will automatically select one of the right click menu options on its own instead of displaying the right click menu. This has been reported by other people as well, according to Google. Probably not that common because many people don’t use the right click as much as I do.

And there’s the problem of numerous crashes and slowdowns on various sites I frequent which did not happen in FF2. I suspect that FF3 has serious issues with JavaScript on those sites.

I’m not touching FF3 until it goes to 3.1 or something - or at least fixes the right click problem. I use right click a LOT to save images from the Net and FF3 is completely useless to me now.

On 07/30/2008 richardstevenhack wrote:
> I’m not touching FF3 until it goes to 3.1 or something - or at least
> fixes the right click problem. I use right click a LOT to save images
> from the Net and FF3 is completely useless to me now.


as mentioned before, the right click issue doesn’t seem to be a general bug. Did you try and start FF3 from a fresh profile, as I suggested? I fear you’ll see the same problem with future versions of FF.


Nice video, how did you make it?

FF3.01, KDE 3.5.9 “release 49.1”, Suse 11.0, Kernel i686

Upgraded from Suse 10.3 using the mini-iso CD and it worked “out of the box”, after I added the Mozilla repo and did a full update.

FF3 plays BBC, & CNN & YouTube without complaint. Added the newest Compact Menu, Tab Mix Plus, AdBlock Plus, NoScript, DownloadHelper & FastDial extensions and it is a real improvement on FF2. The Noia 2 Extreme theme has been upgraded at last, so I’m a happy surfer!

Part of the issue with 3.0.x as opposed to 2.0.x has to do with a different plugin standard (Netscape Navigator had the same issue between 2.x and 3.x back when IE was a joke); if you have plug-ins that you’re used to with 2.0.x, you often have to re-download them for 3.0 and later because the plug-in spec changed. However, I can safely say that, so far, Firefox 3.0.x is the best Firefox yet (not just in Linux, but Windows as well).

No, that’s not quite true. If you want to stay true to the versions installed with the core OS, then you shouldn’t enable third-party repos in the OBS.

The updater, at the end of the day, resolves based on versions, not on repos. If the Mozilla repo had FF upgraded to 3.0, then you will receive that as an update since you selected to include that repo. TBH, you shouldn’t have attached this repo unless you wanted to remain current with the latest builds.

If you wish to revert back to the original, just disable the Mozilla repo. Then in Yast Software Management, select firefox. It will probably be in hilighted in red since your version is newer than the most recent version in your repos (once Mozilla is disabled), but you can still force-update it by selecting it, which will force Yast to download it from the core openSUSE repos and bring it back to 2.0.whatever.

Hope this helps…