Which Netbooks does openSUSE work best with?

Was wondering if there were any Netbooks that openSUSE works well on out-of-the-box?

I understand that some of them require one form of tweaking or another (wireless wrappers, manual configs, etc.) and maybe all of them require some form of tweaking which would presumably be done by the OEM if they were to sell a Netbook with openSUSE pre-installed.

So if none of the Netbooks are out-of-the-box working then which one has the fewest or easiest tweaks?

Curious just to know of any advantages one Netbook has over the others. I know most of them can handle a Linux distro of one form or another with enough tweaking unless it comes installed.

I’m more curious about openSUSE specifically on these things.

I bought my wife an Acer Aspire One.

Installed openSUSE 11.1 and every single piece of harware in worked on first boot.




Intel Video 3D acceleration

Camera card readers

Function Keys


simply everything works, I didn’t have to fuss with anything.

She is using it for a Linux CLI/Bash scripting college course. rotfl!

I would imagine everything works because they sell a Linux version so all the drivers are available.

It runs faster then the default install of WinXP that it came with.

The only reason we bought the one with WinXP is because it was all WalMart had. :stuck_out_tongue:

Great little machine. openSUSE thrives on it

That’s great to hear!

Just realized you were from CT.

I am right on the MA CT line.


I work in Hartford and live ~1 hr West.

I have a hp 2133 netbook
cpu: 1.2 VIA
(the new hp 2133 have 1.6…1.2 is ok, 1.6 is better)

ram: 2GB DDR Kingston (yes you can uprgade this netbook like i have done)

hd: 120GB (its really fast…but it needs more batery!)

vga: chrome9 (i hate this chip…it works only with vesa driver…actually i m waiting for support…:’()

cam: works!

keyboard: thats the best on this netbook…ok i like the alu-look too

I use openSUSE 11.1 on this netbook…it works great! So great, that i have sold my bigger notebook…:wink:

Have you added the following repository?

Then search for xorg-x11-driver-video-chrome9 :wink:

Chrome9 driver by VIA. Supported Hardware: VIA UniChrome Family
(CLE266, PM800/CN400/CN300, P4M800CE/P4M800Pro/CN700/VN800,
CX700/VX700, K8M890, P4M890, CN896/P4M900, VX800)

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86_64 Kernel
up 1 day 3:11, 1 user, load average: 0.04, 0.06, 0.08
GPU GeForce 8600 GTS Silent - Driver Version: 180.22

I know Lenovo is offering a European version of their netbooks with either Xp home or SLED 10 offered. It’s a fair bet to think that the US version would gladly run openSUSE.

Ohh thank you so much!! :wink: And it should work only with the yast installation?..or are there some changes to tip in the console?

I have an Asus Eee PC 1000. Everything worked right off the 11.1 install disk with no problems. When first starting up the screen looks a little crazy at times but fixes itself.

I noticed a little lag with the display and it was having an issue not brining the screen on after a restart. After the 0803 BIOS update and the kernel update it seems to be working great!!! A lot faster and more responsive then after the initial install.

I also have a Kohjinsha S130BG (Asia specs.) much nicer than the US model. Not a whole lot worked with this one: no wireless, no GPS, no web cam, no T-DMB TV.

The touchscreen worked slightly but needs calibrated badly and the display looked alright. Hard drive works good in 11.1, The 11.0 does not detect it.

I have not really started tinkering with this one yet though.

I have also been tinkering with the Fujitsu Lifebook U1010 (Asia Specs) I was able to get most things working on this with the exception of the touchscreen (BIOS related problem,) camera and special buttons. The sound quality of the built in speaker is very nice and very very loud compared to the Asus and the Kohjinsha.

The Asus is my favorite right now, because everything works great with no problems. If everything worked on the Kohjinsha though it would be at the top, hands down.

You will probably need to run sax2 at runlevel 3 and install the
driver, logout from you DE Session, then ctrl+alt+F1 and login as root

init 3
sax2 -r -m 0=via
init 5 && exit

I use the openchrome one on my pico itx system.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 0:31, 2 users, load average: 0.49, 0.23, 0.19
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

So far it looks like

  • Acer Aspire One works out of the box
  • HP 2133 works out of the box with some added tweaks for the Crhome9 driver available
  • EeePC 1000 works out of the box and the lag with the display is fixed with a BIOS and Kernel upgrades
  • Lenovo (S10?) European model comes with SLED option and if the US version has the same specs should work with openSUSE
  • Fujitsu Lifebook U1010 worked except touchscreen (BIOS issue), camera and special buttons

This is great to hear! Keep them coming! :slight_smile:

Can you please explain step by step what i have to do…

  1. find the driver in yast and install it
  2. start the terminal, su, and password (thats not a problem)
  3. now what? tip in the terminal
    sax2 (enter)
    runlevel 3 (enter)
    init 3 (enter)
    sax2 -r -m 0=via (enter)
    init 5 && exit (enter)
    …is this right?

Almost right, just don’t need that sax2 and runlevel commands :slight_smile:

  1. Yes, download/install the driver via YaST
  2. Logout of your GUI/DE session and use the command ctrl+alt+F1 to get
    to the console login.
  3. Login as root user
  4. Run the commands;

init 3 <enter>
sax2 -r -m 0=via <enter>
(Also remember to check you display is correct eg refresh rate, size
init 5 && exit <enter>

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 1:47, 1 user, load average: 0.09, 0.33, 0.37
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Thanks! :wink:

aspire one works but DO NOT PUT 11.0 ON IT graphics is mad and wifi doesnt work install 11.1

On Mon, 2009-01-26 at 19:06 +0000, dragonbite wrote:
> Was wondering if there were any Netbooks that openSUSE works well on
> out-of-the-box?

HP Elitebook 2530p works pretty well out of the box. BUT, it’s NOT a
netbook. It’s a full tilt powerhouse in a teeney tiny package.
Supports up to 8GB of memory, it’s the size of a piece of letter
sized paper (if that’s not too big). HAS a built-in DVD-RW.
Plays full 1080p video. You can choose between a 3 cell, 6 cell
and 9 cell battery. I know you can get over 3 hours off the
6 cell (but I haven’t measured the exact amount).

Web cam works… but maybe not supported with all packages.
The fingerprint reader DOES NOT work.

I have tested 1Gb network, WiFi (WPA), dual monitors (it has
a VGA out port) and several USB items. Suspend to disk works
fine… but not suspend to ram.

I have not tested the microphone yet.

Netbooks are cute, they just aren’t terribly powerful… which
is why I like the 2530p.

I done it step by step…the chrome9 driver i get from the build service with the 1click installation…
but when i run the command:
“sax2 -r -m 0=via”
i get the answer: “your current configuration will not be read in”
“Sax: no X-Server is running”
“Sax: will start own server if needed”

so i tip in the rest of the commands:
init 5 && exit (but i get no answer)

I had no idea haw to get out of the terminal…so i finali push the button and the system shut normally down…
after starting second time the pc…i wanted to look if the 3d or the 2d is working…but when i start sax in yast it changes into the console modus for a short time and when i tip something it gets back to gnome…whats this??

I test it a bit by watching a video…and i mean it is slower than ever…

If an x server didn’t start you still running a vesa one. Post a new
thread in the hardware forum, will see if the openchrome one works…

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 11:03, 1 user, load average: 0.21, 0.21, 0.15
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22