Which File to choose to boot from UEFI Bios/boot option

Advice Required

I am installing Leap onto my Dell Laptop on to a separate Hard Drive so that I can use either Windows or Leap without dual booting from one hard drive. I have downloaded and made a bootable USB Drive using Rufus. My issue is that my Dell XPS laptop uses UEFI Bios and does not allow me to select the USB Drive itself. Instead it is asking for a specific file from the USB Stick. Can somebody please let me know which file I need to select to be able to boot and install Leap from? If you need any more infomation or if i am missing something please let me know and I will try to fill in.

On my desktop, I have to enter the bios and make usb the default uefi by bringing the usb on top of the list of bootable drive. When booting with the installer it detects the iso in the usb drive and start the install process. Sometimes there is a case that it won’t automatically boot from the iso. In the bios under uefi while the usb stick containing the opensuse iso you will see the opensuse uefi as an option and you can start from there. Maybe the bios setup differ from one machine to others but you can start from what I mentioned. Good luck and hopefully someone will chime in with more information that can help.

It is not clear what you are actually trying here.

My experience with Dell computer is as follows:

While booting, hit F12. You may need to continue hitting F12 until you see a boot menu. Then it should list the boot options available.

In my experience, it will show the USB drive as:


with probably a description of the USB device (such as “San Disk”).

If you are attempting to set boot option is the BIOS settings, that’s probably a mistake. Best to just use F12 as indicated.

If you want the file details, then booting a USB drive normally uses the file “bootx64.efi”, or that could be “BOOTX64.EFI”, and the full path will be: “\EFI\BOOT\bootx64.efi”. But I have never had to describe it in that much detail with a Dell system. Just using F12 is the better way to handle this.

I have no idea what Rufus does to your USB and you probably should be addressing your question to Rufus community. The standard way to create bootable openSUSE USB is to dd the image onto the full drive (not partition).

That would be the standard way for someone who has a working Linux installation. Many without a working Linux installation will not have access to dd.

Since discovering Ventoy, it has become my “standard way” - setup once, then simply copy .isos, or other bootable image files, to it, or remove them from it, with any OS that supports whatever filesystem you selected for .iso files on your Ventoy device.

Hi there, many thanks for the reply. I will try to expand a bit more. I was hoping that the option to select the USB drive would be there however its not. When i enter Bios to select the bootable media, it asks you add a bootable device. When you go to add a bootable device it brings up the usb drive, but is asking for a specific file within the .opensuse iso file itself. I have tried to select different files with.efi file name but to no success.

It is requiring a specific file from within the iso imagae on the drive.

I tried creating a virtual machine ti run this from in windows 11, however i need it to connect to be able to plug an ethernet cable in, but it would not regconise it even after creating virtual switches and selecting different options.

Any help would be greatly appreciated.


You just repeated what you said before. Again - we do not know what Rufus put on this USB so we cannot tell what file to select. The standard bootable image would be \EFI\Boot\bootx64.efi, but if firmware fails to detect USB as bootable, this file is probably missing.

Well, as you are apparently blocked by Google …

  1. chrysocome.net - dd for windows
  2. Rawrite32 (netbsd.org)
  3. Rufus dd mode (which is arguably well hidden in the current Rufus)

As long as it correctly guesses the parameters needed by your particular image to actually find itself after boot … and your image supports the filesystem used on Ventoy medium … it never worked for any image I tried.

I can’t recall any failures. I just cleaned old .isos off mine after upgrading it to latest Ventoy version. Before cleaning, mine included:


Well, maybe it became better. Still, it adds yet another layer of indirection that can have its own problems.

I think I may have tried it with images that were rather picky at finding their content. There is no way to emulate CD-ROM after kernel has been loaded, so they failed.