Which C++ IDE should I use which is NOT outdated as CodeLite ?


I’m looking for an C++ IDE which is not outdated as CodeLite on YaST (I searched it on YaST, its version is 5.4. It is too old. Currently newest version is 10)

Also I tried Code::Blocks and CodeLite by source code and those were too hard for a Linux newbie. Lost while installing dependencies and gave up.

So I want to install the IDE on YaST which is simple and nice.

My best regards.


Click on “Show other versions” and you’ll see an entry for version 10.0 from home:fusion809

http://software.opensuse.org/find is your friend and should be part of your toolkit.

If you look at the openSUSE Software URL for CodeLite, there’s a private build for version 10: <https://software.opensuse.org/package/codelite?search_term=CodeLite>

If you’re prepared for a somewhat more complex IDE plus a move to KDE and Qt5, take a look at KDevelop: <https://software.opensuse.org/package/kdevelop5>

Thank you very much. I did as you said. But it says ‘show unstable versions’. I think they are not tested or sth.

Anyway, I’ll try to install it and respond here.

All my best wishes

Unstable should be renamed “User Contributed”, because that’s what it really is.

Thank you @dcurtisfra. What do you mean ‘private’ ?

By the way I’m not a complex programmer. I just need a simple IDE. Because I’m tired of typing g++ file.cpp then ./a.out. :slight_smile:

There is also a warning:

Please be aware that the following packages are from unofficial repositories. That means they are not reviewed by openSUSE and may contain unstable or experimental software.

I tried to install version 10. But I get error:

An error occurred while initializing the software repository.
http-download.opensuse.org-058147d7:[http-download.opensuse.org-058147d7|http://download.opensuse.org/repositories/home:fusion809/openSUSE_Leap_42.1/] Valid metadata not found at specified URL
-Unknown error reading from ‘http://download.opensuse.org/repositories/home:/fusion809/openSUSE_Leap_42.1/
-System management is locked by the application with pid 32372 (/usr/lib/YaST2/bin/y2base).
Close this application before trying again.

Try again?

The builds are not part of the Quality Assurance (QA) process associated with the official openSUSE repositories.

Once someone has determined that, the quality of what they’ve built in their private build environment is “good enough”, they can (if they wish to do so) submit that packet version to the openSUSE QA for acceptance into the main openSUSE build environment where it can be picked up by that part of the community who aren’t interested in “it may possibly be OK” RPM packages.

On the other hand, once one has learnt the basics of programming and, wishes to maybe earn a living by participating in the production of computer applications, one will normally (assuming that, one wishes to earn enough to survive in this world) have to submit to the practices associated with working in a team of programmers, and managers, and Project Managers, and Testers, and QC/QA folks.

  • Meaning, you are going to have to come to terms with Change Management (SCCS, RCS, Subversion, Sablime, et al) and the integration of those processes with a Change Request system (Bug Reports).

This means that, it is usually quite nice having an IDE which not only browses effectively through the C++ classes but, also integrates into the Change Management system and has an acceptable work-flow from “Please take a look at this customer complaint” through to “submitting the change(s) needed to alleviate the issue raised by the customer”.

Bottom line: IMHO an IDE needs to hack the issues of C++ class browsing and be integrated into the Change Management system being used.

Packaging is nice,
But you can also download a 10.0 rpm directly from codelite
From the above page, you can try running the following command

zypper in https://repos.codelite.org/rpms-10.0/fedora/codelite-10.0-1.fc25.x86_64.rpm

Also on that codelite “downloads” page are instructions for building from source