Where is my other hard drive?

I have Win XP on a SATA drive. I can’t locate it in Open SUSE 11, which is on a IDE HD. Thanks.

Hi, you can (1) try to mount it by hand or (2) use the partition tool of yast.
(1) by hand: Type fdisk -l, to see your harddisks. When you`ve located your xp disk try to mount it to a directory you created before.

 mount -t ntfs-3g /dev/yourxpdrive /the_folder_you_want_to_mount_it_to 

If that works, the next step would be to edit your /etc/fstab in order to mount the drive automatically.

(2) Yast: Go to Yast → system → partitioner. Open the harddisks drop-down menu, navigate to your windows disk and click edit. Select “do not format” and “mount partition”, then choose a mountpoint (maybe you’ve to create one before).
My setup is linux on a sata disk and an ide disk for data wich I mounted to /mnt/data. Remember, you’ve to be root to do all this. Good luck.

What do you meamn by ‘locate’.

Did you use YaST > System > Partitioning > say Yes else you will not see anything. What is in the list there?

Hehe, same time as supertimorplusfort. His advice does not contradict mine.

Sorry, I’m a newb. My USB hard drive backup shows on desktop. In other distros I have played around with, even Puppy, all hard drives show up with a click to mount or unmount. Not available in Open SUSE for some reason without some work.

In Nautilus File Manager/FileSystem Root is Xed out. Do I need to give it administrative permission? If so how?

In File Manager, under Beau (my name), I made a folder WD2500SATAXP for the mount point. I assume this is not correct. It is easy for me to find things there as I am not totally familiar with the file system.

What I meant was to “mount” the drive. Sorry.

Appreciate the help.

OK, in terminal I found the command SU gets into Root.
As mentioned I made a folder under /home/Beau/ named WD2500SATAxp .
In Root:
mount -t ntfs-3g /dev/SDA1 /home/Beau/WD2500SATAxp
If I remember it put some files in there but I had to log off and get back into XP.
At the begging of my XP drive C: I see a bunch of Open SUSE folders and files. I deleted most but some would not. I guess I’ll have to boot into XP in Safe Mode or find a way to delete them. That got messed up somehow as there shouldn’t be SUSE stuff there.

I just tried both versions of Mandriva, Puppy, and Kubuntu and they all display drives to be mounted. Just puzzles the heck out of me why Open SUSE doesn’t so going to give up for a day or so. It, of course, is necessary to be able to access other drives easily.

Otherwise love Open SUSE 11 Gnome. All my hardware works. :wink:

Thanks for the help folks. I’ll check back later.


Look in the /media folder. It should show up here along with your cd drives.

There is nothing in my /media folder.

Also I have tried every conceivable way to remove from my XP C: drive .nautilus/metafiles/ and the 2 .XML files there. Very frustrating.:frowning:

The internal Windows XP drive I want to mount is /dev/sda

Folder made for that drive I want to mount:

HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10, 1

root’s password:

Identify NTFS partitions:
sudo /sbin/fdisk -l

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x88a966fe

Device Boot Start End Blocks Id System
/dev/sda1 * 1 30401 244196001 7 HPFS/NTFS

Disk /dev/sdb: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xeb29eb29

Device Boot Start End Blocks Id System
/dev/sdb1 1 262 2104483+ 82 Linux swap / Solaris
/dev/sdb2 * 263 2126 14972580 83 Linux
/dev/sdb3 2127 4865 22001017+ 83 Linux

From: HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10, 11

Here is what I ran in terminal:

/dev/sda /Home/Beau/WD2500SATAXP ntfs-3g defaults 0 0

“Permission Denied”



/dev/sda /Home/Beau/WD2500SATAXP ntfs-3g defaults 0 0

should look like this

mount -t ntfs-3g /dev/sda1 /home/beau/WD2500SATAXP

Then your drive should be accessible as root.
The code you typed in is the notation used in /etc/fstab, not in a terminal and /dev/sda1 is your ntfs partition, not /dev/sda. Linux is case sensitive so /Home/Beau should be /home/beau.
The easiest way to mount it permanently is Yast (see my previous post), otherwise you’d have to add a long string similar to the following to your fstab: “/dev/disk/by-id/scsi-SATA_HTS541040G9AT00_MPB2LAXHCBBA1M-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0”.
Good luck!

Followed the directions in Yast and set the mount point to /home/beau/wd2500sataxp . It lists in the partitioner under sda1.

In /home/beau/wd2500sataxp nothing is there.

I also tried the temporary mount as instructed but get:
“Bad mount point” AND “No such file or directory”.

I really appreciate the effort you and others have given me on this but I’ve spent too many hours on it and must move on. I’m going back to my live CD boot of Puppy for awhile.

Thanks very much.


Well of course when you declare a directory as being a mount point, that directory must exist. So /home/beau/wd2500sataxp must exist as a directory (or map, or folder, or how your nomenclature is).

YaST will create it for you (after all it is the GUI for making things easy). But when you mount by hand (before you let YaST do it) you must see that all prerequisits are fullfilled, so create the dir by hand.

I redid it the YaST way (using a directory it listed) and the system hung for a very long time. Had to hard boot. Tried twice. What I need is a simple way to mount and unmount drives that show on my desktop with a click like the other distros I have used. I like Open SUSE but it doesn’t have this feature I need.

Thanks again for your help.
<end of thread>