Where did Gnome and KDE store informations?

Some month ago I installed openSUSE 11.1.
It worked not bad, but I wanted to get the newes release of Firefox. So I did an upgrade to 11.2
This wasn’t a good idea, because I got lots of problems. Yast2 refused to work with an error message: unknown option -s (or similar). The regular updates didn’t work also.
Then I decided to do a new installation. Now I’m having a new problem: Display settings (Anzeige-Einstellungen) reports: Monitor unknown (Monitor unbekannt).

Possible resolution settings are: 800 x 600; 640 x 480; 400 x 300; 320 x 240;
Possible refresh rates are: 60 Hz or 56 Hz @ 800 x 600

I need 1024 x 768 @ 76 Hz. In the previous installation it worked well.

YAST2 Hardware informations shows me in Monitor > Monitor > Resources > Resolution: High: 768; Vertical frequency: 76; Wide: 1024
The VGA controller is also correct shown in Display > 3d Blaster Savage 4

Gnome and KDE are GUIs. Did anybody know, where the information about Display resolutions an refresh rates is stored in the system, like fstab etc.? I’m still having a copy of my previous installation. I would like to copy the data, making the system running 1024 x 768 @ 76 Hz. Thank you for helping me!

You wanted a new version of firefox so you upgraded your whole system? Did you try looking around, perhaps in the mozilla repository?

Anyways, the display settings can be found in /etc/X11/xorg.conf

There may be a way to salvage this but first we have to see your repository list. So could you please open a terminal and copy and paste the output of:

zypper lr -d

Take Care,


I’m not familiar with Linux, I came from Win 98SE and needed a safe system for web purposes, like banking. I don’t know how to handle tar.gz, etc. So I upgradet the whole system only for a new browser release, and got a lot of new problems.
Now I’m having Firefox 3.5.6, but there is a newer release: 3.6 It should work 25 percent faster!

zypper lr -d output:

1 | http-download.opensuse.org-95811dbb | Aktualisierungen für openSUSE 11.2-0 | Ja | Ja | 99 | rpm-md | Index of /update/11.2 |
2 | openSUSE 11.2-0 | openSUSE 11.2-0 | Ja | Nein | 99 | yast2 | cd:/// |
3 | repo-debug | openSUSE-11.2-Debug | Nein | Ja | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
4 | repo-non-oss | openSUSE-11.2-Non-Oss | Ja | Ja | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
5 | repo-oss | openSUSE-11.2-Oss | Ja | Ja | 99 | yast2 | Index of /distribution/11.2/repo/oss |
6 | repo-source | openSUSE-11.2-Source | Nein | Ja | 99 | yast2 | Index of /source/distribution/11.2/repo/oss |

/etc/X11/xorg.conf - there was no such file in the directory! Only /etc/X11/xorg.conf.install. Something has been wrong with my new installation.
Now I copied the file /etc/X11/xorg.conf from my backup drive, and now the display is working with 1024 x 768 @ 87 Hz!


SaX generated X11 config file

Created on: 2009-02-15T13:29:37+0100.

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)


It’s from my previous installation, 11.1, one year ago!
Thank you very much!

How can I get an install the newest release from Firefox?

Hi. Just add the Mozilla repository. Adding repositories is explained here.
If you can’t find it in “Community repositories”, here’s the link for 11.2: Index of /repositories/mozilla/openSUSE_11.2
Then you can install Firefox with Yast. Should the software management be unwilling to upgrade to 3.6 just click the “Versions” tab and select 3.6.

Nothing wrong with “no xorg.conf”. It’s obsolete in 11.2; if it’s there it’s being used, otherwise autodetection and -configuration is used. Is the Savage (kernel) supported?

Yes and no. It depends on your hardware. In most cases, removing xorg.conf may provide a solution but you should not consider it as a rule. In other cases, adding an xorg.conf will solve the issue (dual screen, broken or unrecognized monitor, unrecognized input devices, etc). Normally using an older xorg.conf from a previous installation is a good help, provided you didn’t change the monitor or graphic card. The input devices settings (mouse, keyboard) will be ignored - but that’s usually not a problem.

Kde and Gnome both provide an applet to change the resolution when xrandr is running, which should normally be the case.

“Is the Savage (kernel) supported?” - Sorry, what’s that?

openSUSE 1.3 an 11.1 worked well with the Savage 4.

I wondered about the failsafe mode (without xorg.conf): The Display resolution was 1024 x 768, but in normal mode there was only 800 x 600 @ 60 Hz!

Thank you very much. Firefox 3.6 is now running.