Weird kaffeine problem

I got small problem with Kaffeine. It doesn’t want to run while previewing video files WITH kaffeine works without problems?? I have Packman repo active, downloaded w32 codecs and xine codecs. Kaffeine doesn’t want to run from terminal. I have mplayer also and it works with no problems. I tried reinstalling kaffeine, didn’t work. I tried removing config files kaffeinerc, didn’t work. I don’t know what to do anymore.

Can you start kaffeine from a konsole, typing: kaffeine
and post here the errors that you get.

Also, please provide the output of:
rpm -q kaffeine
rpm -qa xine
rpm -qa ffmpeg0

Nothing happens when i type kaffeine in terminal, no errors nothing, just empty terminal after typing it.

rpm -q kaffeine kaffeine-0.8.7-2.7

rpm -qa xine gives no output

rpm -qa ffmpeg0 gives no output

I have ffmpeg installed.

OK, I’m bad. :slight_smile: … I meant to type instead (asking you to post the output from):
rpm -qa | grep xine
rpm -qa | grep ffmpegplease, can you type the above two lines and provide the output.

Note, your kaffeine version is NOT packaged by Packman. This could be part (but not all) of your problem.

rpm -qa | grep xine

rpm -qa | grep ffmpeg

Looks like i have KDE backports kaffeine, that may give problems? What’s the point of that repo if it gives so many problems omg…

ok that looks good. Your kaffeine version is not good.

Repos such as KDE backports should be used VERY SPARINGLY. ONLY use if there is a specific app version that you ABSOLUTELY MUST HAVE. The backports can cause problems (as you can see). So avoid them.

If you look back over my posts, I recommend ONLY 4 repos: OSS, Non-OSS, Update, and Packman. IF one wishes to add more, they had better know what they are doing, and how to solve them, as problems can happen (as you have now learned).

I disabled KDE community and backports repo, downgraded kaffeine and it’s still not working, are there any logs i could look to see where the problem is?

Should i delete some config folders or files in order for them to recreate when running kaffeine?

I’m not at a linux pc right now, but there could be other files to remove (I’m guessing) other than just kaffeinerc. Do you look under .kde/share/apps (or something like that) for a kaffeine directory ? If there is such a “beast” rename it to kaffeine.bak and try to restart kafffeine.

Are you certain you picked up the Packman kaffeine and not the Novell-SuSE-GmbH kaffeine in what you called a “downgrade” ?

Well i ticked the packman version and made downgrading “update”, confirmed i have this version by disabling packman repo and checking available versions and yes i have packman repo now but it looks like KDE backports repo made uite a mess leaving me with much more “upgraded” apps. Need to downgrade everything and i’ll never touch KDE backports repo again :slight_smile:

What i’m doing right now is i’m downgrading every app that is marked red to packman or OSS version. Hope it helps

Well what do You know, it helped :slight_smile:
I’m not sure what but i think it was kdelibs3 from KDE backports that caused some problems. Can’t point it to exact package because i downgraded everything :slight_smile:

There should be a sticky to avoid enabling these repositories, such problems like these make people think it’s the OS fault…

I forgot to mention, …

I recommend you install libffmpeg0 (packaged by Packman). My view is that libffmpeg0 is a better app to install than w32codec-all, all thou both are good, and adding both is IMHO a good idea. By adding libffmpeg0, that will provide some dependencies, and some of these dependencies will include codecs that do not come with w32codec-all.

Well i did and it didn’t add any other packages, i got w32, libxine1, libxine-codecs. I don’t use gstreamer since yauap in amarok had such crappy quality when playing mp3.