Webkit browsers crash Google.com?

I’ve installed 13.1 32 bit on a couple of old machines with Athlon and Sempron Thoroughbred processors.
I seem to have an issue with webkit based browsers crashing google.com (and some other websites that use javascript applets).

In the last 6 months I have used Midori in Manjaro and Slitaz without an issue.
I’m afraid I don’t know what versions I tried there or in Opensuse or which webkit version they used.

The latest browser I tried was Surf 0.6 from the Utilities:suckless repository
This uses libwebkitgtk-1_0-0 version 2.2.2 from the official repositories.
It seems to work fine other than the symptom described.

I’m happy using Seamonkey as my main browser but would like a decent lighter alternative with a different layout engine to run alongside. Has anybody else got similar issues or suggestions to get round the problem?
Is there a webkit browser in the official repositories I should test to confirm the issue?

Konqueror, Rekonq, Epiphany come to mind.

But I think your problem is rather related to the flash-player.
The latest versions (starting with 11) crash if your CPU doesn’t have SSE2 support. Athlon and Sempron Thoroughbred CPUs do not have SSE2 support.

So try to uninstall flash-player. Do the crashes disappear?
You should be able to download and install the older version 10 from Adobe’s site. That one should work on your CPUs.

I doubt webkit is the cause of your problem.

Probably the most readily available browser with advanced and recent version of website would be Chromium from the OSS.

If you want to see more detail about whatever is going on and have some technical expertise, you can launch the integrated debugger in Chromium (or any other Chrome family browser, maybe other webkit browsers as well) by the following keystroke combination, then visiting the problem webpage



I was aware of the flashplayer issue and generally try to avoid flash. I rarely need it. I have a renamed version 11.2 from Chrome 19
It works ok with Seamonkey, although really I avoid Flash whenever possible, it’s very slow on 10-12 year old machines.

Deleting it didn’t help. But it did get me thinking whether the issue was SSE2 related, moments later a search enginge hit!
The bug I’m seeing looks similar, if not the same as https://bugzilla.novell.com/show_bug.cgi?id=862267#c

I just tried konqueror on google.com, and nothing crashed.

That was 64-bit. I can fire up a 32-bit system running 13.1, to see what happens. I know that I have konqueror there. I can also install “rekonq”, “midori” and “epiphany” to further test.

But maybe you could first describe what you see happening, so that I know what to look for.

Chromium works fine and does not seem affected.
Checking the dependencies it does not rely on libwebkitgtk-1_0-0 version 2.2.2 which I now suspect could be at the root of the issue.

I opened Surf in a terminal, when crashing it just reports an “Illegal instruction”. Surf is so minimalistic I think I’m out of my depth, I can’t work out where I might find a log with anything more useful.
I’ll put a little more time into this later this week and reinstall Midori which I hope will allow debugging even if it just confirms the bug report https://bugzilla.novell.com/show_bug.cgi?id=862267#c

If that’s the case I think I’ll just forget about a secondary browser for now or maybe spend some more time with w3m which I’m beginning to love.
Ideally I want something less resource hungry than Chromium (uses more RAM than Seamonkey which acts as both my web browser and mail client).
I’m running XFCE built from a minimal X install. Without the required libraries on my system the footprint for the KDE browsers is unacceptably high. Even Ephiphany will add more than 200mb.

But especially “Illegal Instruction” would point to the flash-player/CPU problem I mentioned.
Again, flash-player just crashes on Athlon/Sempron Thoroughbred CPUs. It seems that this crash makes Surf (or libwebkit) crash as well.

Did you try to uninstall flash-player?

Could you please post the file /proc/cpuinfo?
F.e. run this in a terminal window and post the output:

cat /proc/cpuinfo

Sorry, didn’t notice this post when I replied.

Ah, ok. That page mentions that this is compiled for SSE only, which should work for you.

Deleting it didn’t help. But it did get me thinking whether the issue was SSE2 related, moments later a search enginge hit!
The bug I’m seeing looks similar, if not the same as https://bugzilla.novell.com/show_bug.cgi?id=862267#c

Yes, this sounds indeed like it could be your problem. Maybe you should add a comment to the bug report, it seems to have been forgotten.

I can’t try myself, because I have no Athlon/Sempron system here at the moment.
I have two that I could try at the weekend, but that has no hard disk in it, and the other one runs Windows and is quite full.
Well, maybe I’ll try with a LiveUSB… :wink:

Ok got Midori to debug, seems to confirm previously reported issue to my eyes…

|Program received signal SIGILL, Illegal instruction.
0xb3647175 in ?? ()
#0 0xb3647175 in ?? ()
#1 0xb557abc9 in JSC::JITCode::execute(JSC::JSStack*, JSC::ExecState*, JSC::VM*) () from /usr/lib/libjavascriptcoregtk-1.0.so.0
#2 0xb555ea51 in JSC::Interpreter::execute(JSC::ProgramExecutable*, JSC::ExecState*, JSC::JSObject*) () from /usr/lib/libjavascriptcoregtk-1.0.so.0
#3 0xb56832be in JSC::evaluate(JSC::ExecState*, JSC::SourceCode const&, JSC::JSValue, JSC::JSValue*) () from /usr/lib/libjavascriptcoregtk-1.0.so.0
#4 0xb5bdc1eb in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#5 0xb5bdc4c5 in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#6 0xb5dab542 in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#7 0xb5dac9b7 in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#8 0xb5f6cf21 in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#9 0xb5f6d83c in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#10 0xb5f569ca in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#11 0xb5f56a62 in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#12 0xb5f598d0 in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#13 0xb5f59b78 in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#14 0xb5f5a560 in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#15 0xb5d2f91d in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#16 0xb60abcef in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#17 0xb609f761 in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#18 0xb5a38e91 in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#19 0xb609ebda in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#20 0xb609f8bd in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#21 0xb6086b57 in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#22 0xb6086d3c in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#23 0xb60ece24 in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#24 0xb60ecf54 in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#25 0xb60e3585 in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#26 0xb6787e44 in ?? () from /usr/lib/libwebkitgtk-1.0.so.0
#27 0xb767ee0b in ?? () from /usr/lib/libgio-2.0.so.0
#28 0xb76a3181 in ?? () from /usr/lib/libgio-2.0.so.0
#29 0xb76a31bb in ?? () from /usr/lib/libgio-2.0.so.0
#30 0xb7eb4530 in ?? () from /usr/lib/libglib-2.0.so.0
#31 0xb7eb77de in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#32 0xb7eb7b88 in ?? () from /usr/lib/libglib-2.0.so.0
#33 0xb7eb7feb in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#34 0xb7aded10 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#35 0x0806b014 in main ()|

Will add a comment to existing bug report as suggested.