WebGL Works In Google Chrome, But WebGL Does Not Work In Mozilla Firefox?

Hi,

Below WebGL video game:
https://fallenangelsoftware.com/stuff/files/PacDudeHero4110PercentTurbo/index.html

works in Google Chrome, but does not work in Mozilla Firefox?

Running current openSUSE Tumbleweed KDE 64Bit
with nVidia GeForce GT 1030 2GB GDDR5 PCIexpress GPU
with current nVidia Linux proprietary display driver version 450.80.02.

Any ideas?
Thanks!

Jesse

That is a nice open question, but you must be able to test that yourself I assume?

Hi,

I did test: works in Chrome, does not work in Firefox on my desktop.
Just wondering if it’s the desktop itself or an issue with the source.

Ran the game just now on Windows 10 desktop and it works fine on Firefox so I don’t know…
The Linux desktop I originally ran the game on is is severely under powered.
It’s probably the desktop, but just want to be 100% sure.

I plan on sending the above WebGL game to a company interested in hiring me.
Just want to be 100% sure it works properly before sending…

Jesse

https://get.webgl.org/ firefox/intel check

The link in top post works in chrome, but firefox shows a black page only. Read the text displayed by chrome and post as suggested.

Hi,

Got it running(very slowly) on openSUSE Mozilla Firefox browser.
Seems like openSUSE Firefox is not using WebGL?
Runs 100% full-speed on openSUSE Google Chrome.

I’ve got the most up-to-date nVidia driver and a fairly new nVidia GPU.
Any ideas?

Jesse

working for me in Firefox 83
In Chrome it loads instantly but in Chromium and Firefox I appear to get a blank (black) screen, but after minimizing the browsers and bringing them back up again the (game?) loads

Not with Nvidia, Intel and AMD(?) AFAIK, see info in about:support under graphics, if it’s enabled via about:config webgl.disable is false.

Works Ok with Leap 15.2 + FF 83.0 + AMD Vega + Mesa 3D.

To enable WebGL, set webgl.force-enabled to true.

Hi
Yup, that got it working, thanks :slight_smile:


WebGL 1 Driver Renderer    NVIDIA Corporation -- GeForce GT 1030/PCIe/SSE2

With Firefox Linux users often need to adjust FF parameters.
Use page “about:config”, search for “some_parameter.enabled” or “some_parameter.force-enabled”, etc.

What puzzled me: The link of post #4 shows a rotating cube and says: “Your browser supports WebGL” while your link says WebGl needs to be enabled and adds: “Now, cross your fingers, restart Firefox and try running a WebGL application. It’s probably best to undo those changes if smoke starts pouring from your PC.”

A general “WebGL does not work” might be open to various interpretations… It might work badly or not work at all or something else.

Keep in mind that FF just introduced a new engine for supporting hardware acceleration very recently (a couple months ago) after trialing on MSWindows for about 6 mths. If this might be an issue, you should check/uncheck the hardware acceleration to see if you get better performance with either setting (And I’m sure that Mozilla appreciates your feedback if hardware acceleration doesn’t improve your performance).

And,
Don’t rely on just your game.
Search for some WebGL benchmarks and run some tests with various settings to try to identify what work and what doesn’t.
If you haven’t done this before, do what you can and if you have specific questions about what you’re doing or seeing, go ahead and post again.

TSU

Which engine?

It’s actually a very significant recently new feature in FF.

TSU

I.e. VA-API?
But FF + Youtube goes to use AV1 and AVIF now if they are enabled…