webdav mount üver systemd.mount klappt, über autofs nicht

Hallöchen,

ich habe hier ein merkwürdiges Verhalten bzw ich finde den Fehler nicht. Ich habe zwei “entfernte” Verzeichnisse, die ich mounten möchte, und zwar an den Ort /mnt

Ich habe hier zwei ordner erstellt: LINUXSERVER und magentacloud. Beide Ordner sind durch den Benutzer uid=1000 gid=1000 beschreibar/lesbar.

Hänge ich die beiden Freigaben üver die fstab und systemd.automound ein klappt es:


192.168.2.10:/mnt/wd-red-2t/daten    /mnt/LINUXSERVER    nfs    x-systemd.automount,noauto,retry=0,x-systemd.idle-timeout=20,nolock,rw,timeo=14,x-systemd.device-timeout=20,soft,nofail    0 0
https://webdav.magentacloud.de/        /mnt/magentacloud davfs noauto,x-systemd.automount,_netdev,nodev,user,rw,uid=1000,gid=1000 0 0

Da ich aber gelegentlich das Problem habe (bzw früher hatte ich “nur” das nfs-share gemontes), dass der Laptop (WLAN-Verbindung zum Netzwerk) nicht richtig herunterfährt, da das Netzwerk früher beendet wird, als die Freigaben wieder audgehangen wurden (das Problem kann man häufiger lesen in Foren im Zusammenhang mit systemd.automount).

Also habe ich auf autofs umgestellt.
Das Einhänfen des nfs-shares klappt auch ohne Probleme.

auto.master:

/mnt auto.nfs --timeout=30 --ghost
/mnt auto.magentacloud --timeout=30 --ghost

auto.nfs:

LINUXSERVER -fstype=nfs,rw,retry=0 192.168.2.10:/mnt/wd-red-2t/daten

Aber bei webdav habe ich Probleme:
auto.magentacloud:

magentacloud -fstype=davfs,user,uid=1000,gid=1000,file_mode=700,dir_mode=700,rw :https://webdav.magentacloud.de

Der Order /mnt/magentacloud “verschwindet” und ich kann nicht darauf zugreifen. Wenn ich per Hand die Adresse in Dolphin eintrage, erhalte ich die Fehlermeldung, dass der Ornder nicht existiert. Halte ich autofs an, so erscheint der Ordner wieder.
Ich habe natürlich die Einträge in der fstab entfernt bevor ich autofs aktiviere!

Die Datei /etc/davfs2/secrets existiert und funktioniert auch, sonst würde ja sicherlich der Mount üder die fstab nicht klappen.

Wo liegt also das Problem mit dem webdav und autofs???

Gruß
mairo

Ich mach es eigentlich immer nach der Anleitung auf framp’s Seite, die funktioniert zuverlässig.

mount und umount kann ich als User mit krusader machen.

https://www.linux-tips-and-tricks.de/de/netzwerk/190-wie-kann-man-medienspeicher-oder-smartdrive-unter-linux-einbinden/

Mein Eintrag in der fstab:

https://webdav.magentacloud.de/            /home/XXXXXXX/WebDav    davfs  user,noauto,rw                0  0

Danke,

die Seite ist sehr gut! Aber die Einbindung über die /etc/fstab klappt ja bei mir… Es ging mit halt darum, das alles über autofs zu regeln… Wenn es nicht anders geht, dann machr ich es über die fstab und den systemd.automount.
Mit autofs hatte ich halt am Laptop nie Probleme mit dem Herunterfahren (also das Netzwerkfreigaben noch eingebunden waren und nicht richtig audgehangen werden konnten, weil das Netzwerk schon beebndet wurde…)
Letztendlich ist es mir egal wie es funktioniert, Hauptsache es funktioniert ohne „Nebenwirkungen“

Gruß
mairo