WebCam - Works in all distros but SUSE

I have an old web cam Phillips SPC 600NC - This is supposed to be supported in the gspca Driver.
It works in all other linux Distro’s but Suse - I am currently running Suse 11.4 - When I plug the camera in - the dmesg is
[48246.444056] usb 4-1: New USB device found, idVendor=0471, idProduct=0327
[48246.444059] usb 4-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[48246.444062] usb 4-1: Product: USB camera
[48246.447123] gspca: probing 0471:0327
[48246.452055] sonixj: Sonix chip id: 11
[48246.476055] sonixj: Unknown sensor 0000 - forced to mi0360
[48246.478117] input: sonixj as /devices/pci0000:00/0000:00:1a.1/usb4/4-1/input/input8
[48246.478224] gspca: video0 created
Any Idea’s - I know the video is working because I have know problems with other webcam

If gspca driver then there is a wiki on this !

The gspca is included in the kernel. Take a note of this webpage: HCL:Web cameras - openSUSE

Some applications still don’t work very well together with the gspca drivers, a workaround is to preload a libv4l-compat library:

LD_PRELOAD=/usr/lib/libv4l/ <application> 

before starting the respective application, i.e. for kopete you would type:

 LD_PRELOAD=/usr/lib/libv4l/ kopete 

This compat-library can be found in the package “libv4l”, which is available from OSS-Repo or (recommended) from Packman. (see - Additional YaST Package Repositories](

If you have a 64 bit system, you preload the library with:

 LD_PRELOAD=/usr/lib64/libv4l/ <application> 

If you want to run a 32 bit application (i.e. skype) on a 64 bit system, you first need to install “libv4l-32bit” (only available in the Packman repository) and run the preload-command used for 32 bit.

If this works for you, you can add the LD_PRELOAD-command to the startup command of your menu entry/desktop shortcut via menu editor or with right-clicking the desktop icon => properties => application => command respectively.

Thanks - But I tried that before I posted - This camera is listed a supported by GSPCA Driver - But not with SUSE 11.4 - Could this be a bug that needs corrected ?

I just googled this line (from your dmesg output)

sonixj: Unknown sensor 0000 - forced to mi0360

There seem to be a lot of problems across several distros with this Philips device. Several bug reports on this topic.

Typically webcams are inexpensive. And I’ve never been happy with webcams that use the gspca driver. I gave away the ones myself had (and our family had) to MS-Windows users. And I replaced them with UVC compatible webcams. UVC is becoming the “defacto” webcam standard for all operating systems, and not just GNU/Linux.

If you have any choice in the matter, my recommendation is to dump your gspaca device for a UVC compatible webcam. For example, the Logitech Webcam C210 (which I purchased for my sister) is UVC compatible and is very inexpensive.

I agree with oldcpu’s practical advice here.

If you would really like to try to get this to work though, then lets have a look at what gspca modules are loaded when you plug in your Philips webcam

lsmod |grep gspca

AFAIU, for your webcam, the ‘gspca_sonixj’ module should be loaded. If its not loaded, maybe you could try removing any existing ‘gspca_***’ module(s) with 'modprobe -r ', then manually load the ‘gspca_sonixj’ module with

modprobe gspca_sonixj

If you can coax it to work manually, then it should be possible to automate with a suitable udev rule.

Thanks for the suggestions. IT’s not that important - It was just annoying me that the stupid thing worked in ubuntu, mepis, mint and other distro’s and I couldn’t get it to work in SUSE - (the distro I use daily).
By the way my lsmod mod returns the proper Driver

Penguin:~ # lsmod |grep gspca
gspca_sonixj 29536 0
gspca_main 28942 1 gspca_sonixj
videodev 81448 1 gspca_main
Penguin:~ #

I’ll just chalk this one up as a SUSE bug. Thanks again all