Webcam software

XFCE Desktop

I just bought a brand X webcam to use for video calls with my desktop computer. It works with Skype and Google Hangouts. The Internet told me I should try webcamoid or cheese for recording videos. I downloaded both. Webcamoid is overly complicated for my liking. Cheese is simpler but the output images are tall and narrow, likely because it expects output to a wide screen monitor and mine isn’t.

Could someone please recommend simple software for recording? Possibly run from a console. Thanks in advance.

Hi
In cheese, go to the preferences to set the image size etc…

I do not see any kind of menu to set preferences.

Hi
On my system it’s top right three dots…

https://forums.opensuse.org/attachment.php?attachmentid=925&stc=1
https://forums.opensuse.org/attachment.php?attachmentid=928&stc=1

Screenshot from 2020-09-14 16-57-12.png

Well my screen is different. No three coloured dots top left, no three dots top right, Top left has a down arrow for window settings. Top right has up-arrow, dash, plus sign, and x.

So we seem to have different versions. I could try re-installing, which I did from the usual repositories, but zypper has never misbehaved.

/home/ion/Screenshot_2020-09-14_16-51-29.png

Hi
Try guvcview instead, cheese is a GNOME app, maybe dconf-editor can get you there?

Yes, that works a lot better once I changed the resolution. And it has just enough adjustments to suit my simple tastes. Many thanks for helping me out.

Gnome is ignoring this patch Allow headerbar to appear on all desktops (81f9be8b) · Commits · GNOME / cheese · GitLab

Install package home:jpenguin / cheese has the patch

Screenshot 20210423 120156 — Postimages](Screenshot 20210423 120156 — Postimages)

OBS is an option but it’s probably too complex.
https://obsproject.com/

This happens trying to install that version:


Problem: nothing provides libgnome-desktop-3.so.19()(64bit) needed by cheese-3.38.0-1.1.x86_64
 Solution 1: do not install cheese-3.38.0-1.1.x86_64
 Solution 2: break cheese-3.38.0-1.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c/d/?] (c): 2
Resolving dependencies...
Resolving package dependencies...

Problem: cheese-lang-3.34.0-lp152.2.5.noarch requires cheese = 3.34.0, but this requirement cannot be provided
 Solution 1: deinstallation of cheese-lang-3.34.0-lp152.2.5.noarch
 Solution 2: do not install cheese-3.38.0-1.1.x86_64
 Solution 3: break cheese-lang-3.34.0-lp152.2.5.noarch by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c/d/?] (c): 3
Resolving dependencies...
Resolving package dependencies...

Tumbleweed Repo?

Problem: nothing provides libgnome-desktop-3.so.19()(64bit) needed by cheese-3.38.0-1.1.x86_64
Solution 1: do not install cheese-3.38.0-1.1.x86_64
Solution 2: break cheese-3.38.0-1.1.x86_64 by ignoring some of its dependencies

I would not install that package on Leap, Leap 15.2 has only version 3.34…

Since this thread is titled LEAP 15.2 Webcam software
I assumed the link was for 15.2.

No, only for TW: Show home:jpenguin - openSUSE Build Service

Tumbleweed is primary, Leap 15.3 is under SLE

I personally get better results with webcamoid