Webcam doesn't work in openSUSE only!


I have a Microsoft LifeCam NX-6000 webcam which I have been able to use in Ubuntu, Fedora, Windows (obviously) but in openSUSE the program Cheese doesn’t detect it at all.

If it were all Linux’s that failed, then that would be one thing. Having other Linuxes work, though, means openSUSE must be missing something in the Gnome LiveCD installation.

What could I be missing?


My webcam only work with cheese using this command in openSUSE 11.1 and 11.2

env LD_PRELOAD=/usr/lib/libv4l/ cheese

So first I should make sure libv4l is installed, and then preload it?

I also had this command recommended for me for Skype (related to a distro where it worked in Cheese but not in Skype), is this something openSUSE doesn’t do for one purpose or another?

> What could I be missing?

maybe one of these:“NX-6000”


Yes, it is a UVC compliant webcam according to that list.

HCL/Web Cameras
Most modern webcams support the USB Video Class (UVC) and work without specialized drivers. Check the list of webcams supported by the UVC driver. If your one is supported, check the UVC Webcams page.
So the drivers should be included. So I go to the UVC Webcamspage.
USB Video Class (UVC) web cams require the uvcvideo kernel driver. This driver has been included in linux-2.6.27 (openSUSE11.1/SLE11); for older kernels you need the uvcvideo-kmp-* package, which has been included openSuSE 11.0 or can be received from the openSUSE BuildService project

Since this is running on openSUSE 11.2, it should be included if I am reading that right.

The command never worked with Skype which is why I didn’t jump to it immediately.

It still doesn’t explain “why” don’t they just include it this way? Am I the one of only a handful it happens to?

Alright, I finally got to try it. I got the following error message:

ERROR: object '/usr/lib/libv4l/' from LD_PRELOAD cannot be preloaded: ignored.

So I went into thet software package manager to see if it was installed and found libv4l was not.

Ok, I tried the command supplied and it worked. Then I tried the change the resolution (from 800x600 to 1024x768, nothing big and well below the capabilities of the camera).

It completely locked up my system so I could do NOTHING! I could not get to tty2, click to close anything or do more than move the mouse around the frozen screen!

Luckily, Firefox remembered my pages and evereything I had in this textbox because I had to to a hard reboot. I’m going to post this before trying the command again and see what happens.

So this command has to be run every time I want to run cheese? Bummer!

Well, it worked and it kept my 1024x768 resolution.

When I open one of the menus, the whole webcam image would go black but the webcam was still working and taking a picture showed me that it was still receiving images just not displaying it.

So I turned off Desktop Effects. Now the webcam viewer doesn’t black out on me and I had no issue changing the resolution.

So now I guess I have to go change my shortcuts to make it work.

Glad to hear it works.
Yes you have to edit the command and happy viewing.:slight_smile:

Bummer… with the Gnome slab, I can’t just right-click and go into properties. In fact I also cannot go into “More Applications” and change the link there! WTF?!!:open_mouth:

I’ll figure something out…

I just installed Skype and with the command it works wonderfully! Complete with video which is better than Fedora and Ubuntu (for which Skype doesn’t like the webcam in)

One step back, two steps ahead.

I purchased yesterday the Microsoft NX-6000
my system is:

Linux version (geeko@buildhost) (gcc version 4.4.1 [gcc-4_4-branch revision 150839] (SUSE Linux) ) #1 SMP PREEMPT 2010-01-27 08:20:11 +0100

the installed version of libv4l is:


I already browsed the

HCL/Web Cameras - openSUSE

(BTW for a UVC cameras nothing special is pointed) but the webcam doesn’t work, neither with cheese using

env LD_PRELOAD=/usr/lib/libv4l/ cheese

nor with kopete using:

env LD_PRELOAD=/usr/lib/libv4l/ cheese

With kopete the camera light on but kopete hangs when selecting setting->device
where the cameras is correctly identified.
Cheese doesn’t complaint anything but there is only “snow” on the screen.
Thank you in advance for the help.

so I cant use my shiny new webcam?

this is the results of “dmesg” output after webcam plug-in

 1697.995212] usb 1-7: new high speed USB device using ehci_hcd and address 4
 1698.115380] usb 1-7: New USB device found, idVendor=045e, idProduct=00f8
 1698.115435] usb 1-7: New USB device strings: Mfr=1, Product=2, SerialNumber=0
 1698.115483] usb 1-7: Product: Microsoft® LifeCam NX-6000
 1698.115519] usb 1-7: Manufacturer: Microsoft
 1698.116060] usb 1-7: configuration #1 chosen from 1 choice
 1698.198062] Linux video capture interface: v2.00
 1698.264047] usbcore: registered new interface driver snd-usb-audio
 1698.272482] uvcvideo: Found UVC 1.00 device Microsoft® LifeCam NX-6000 (045e:00f8)
 1698.272973] uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
 1698.295716] input: Microsoft® LifeCam NX-6000 as /devices/pci0000:00/0000:00:1d.7/usb1/1-7/1-7:1.0/input/input8
 1698.296120] usbcore: registered new interface driver uvcvideo
 1698.296166] USB Video Class driver (v0.1.0)

and this is the log of kopete

kdeinit4: preparing to launch /usr/lib/kde4/
VIDIOC_ENUMSTD: Invalid argument
VIDIOC_ENUM_FMT: Invalid argument
VIDIOC_ENUMSTD: Invalid argument
VIDIOC_ENUM_FMT: Invalid argument

I should be obliged if anyone can give some hint.
Thank you

In ekiga I get the following error message:

The driver does not support the requested image format.

Probably it is an application problem

I do not use correctly the command for luvcview and now the driver and the webcam seem to work correctly

luvcview -d /dev/video0

but the others cheese, kopete and skype don’t work

Hmm… I know I’ve had problems but it would work on at least SOMETHING.

So to reiterate, and make sure we’re understanding correctly;

It works in luvcview, but not Kopete, Cheese or other?

It doesn’t work when you try using

env LD_PRELOAD=/usr/lib/libv4l/ cheese

Have you tried running it as root? I’m not in front of my openSUSE box right now for launching it with the GUI Root password request.

Don’t get discouraged for a response, it’s the end of the weekend over here so I suppose it’s only beginning to be Monday elsewhere in the world.

Microsoft webcam?
No wonder why it doesnt work.
Take it back, buy logitech.

I upgraded libv4l at the webcam driver repository and now:

  1. skype works without any workaround
    2 ekiga works with the “env LD_PRELOAD=/usr/lib/libv4l/ ekiga” command
    3 cheese and kopete don’t work in any way

P.S. Is it possible to increase the video dimension in skype?

roberto60 wrote:
> P.S. Is it possible to increase the video dimension in skype?

i think it is fixed at “pretty small” (to minimize the size of the
video stream’s needed pipe)…