Wayland. Unable to login to Wayland session in Gnome 3.26

Hello all!

First off I just want to say that Gnome 3.26 on my Lenovo N22 is much speedier and with very little lag. I appreciate the hard work that went into that release of Gnome. :slight_smile:

My problem is that I am unable to login to the Gnome (Wayland Session). When I try, the system will just revert to the login page after going blank for about 5 sec.

I’ve tried the Arch recommendations here: https://bbs.archlinux.org/viewtopic.php?id=225487

and reviewd here: https://forums.opensuse.org/showthread.php/527032-Even-if-I-chose-Gnome-on-Wayland-I-think-I-get-X11?highlight=Wayland+tumbleweed

and read nrickert’s blog.

I must be missing something or is it really just not ready for Gnome yet? Any suggestions?


Are gnome-session-wayland and xorg-x11-server-wayland installed? But still some chatter on IRC (#opensuse-gnome) about issues, so may not be quite ready yet…

Thanks for replying malcomlewis!

Yes, both are installed. i check out the irc. Perhaps I can glean, some info. If not I will just patiently wait.

Thanks again!

The folks on the IRC were helpful. I suspect, that out of habit, I used “zypper up” rather than “zypper dup” and broke something. I don’t know.

Anyway. I downloaded the current iso and reinstalled. After that I was able to login to the Wayland session. It didn’t really seem that
different than Xorg. I did experience the YAST, not opening up issue. I know that there is a work around for that.

For me, on the N22, Gnome, doesn’t appear to be the right choice. I think that I will need to let it mature a bit more, before I can use it
comfortably on that particular laptop. I’ll keep it on and play around with it though. I like what the Developers are doing.

Thanks everyone for your help. :slight_smile:


I have the same issue with gnome and wayland. The strange thing is that it worked yesterday, but today I could not login in a wayland session. A gnome xorg session works, but the resolution is randomly broken (e.g. the font is extremely small in the top panel as if it is not handling HI-DPI correctly. Sometimes apps open with small font, and something the work normally. I think the update to gnome 3.26 was botched.

Any solutions out there to this issue other than reinstalling everything?