Wayland and X11 on updated PC's

I successfully updated 3 different TW PC’s today to the latest snapshot with KDE 6 by using tty and zypper dup. Two of them automatically switched to Wayland while the third remain on X11. Any explanation why different?

Different video cards?? Wayland and NVIDIA on KDE do not always play well. :people_wrestling:

In this case it seems not related to Nvidia…

  • Dell laptop with Intel CPU + Nvidia - switched to Wayland, works fine.
  • Home built Asus MB with AMD Ryzen 5 7600 (integrated GPU) - switched to Wayland, works fine.
  • GMKtec K1 mini PC with AMD Ryzen 7 6800H Mobile Processor (integrated GPU)- still on X11, works fine.

I also noticed that when I’m in a Wayland session and reboot, my machine starts up in X again. Plasma 5 didn’t do this. I’m going to wait a few more days in case there are some more updates. If this persists, I’m going to report it as a bug.

What do you mean by switched to wayland?
You don’t have an option at display manager login to choose either/or
it isn’t remembering the choice on next reboot or suspend /wake?

I did have trouble on wake with opensuse defaulting back to x11 some time back. I think I created (edited after checking my current value)



Possibly autologin isn’t ideal for ya though

I’m not 100% on the syntax but possibly instead


1 Like

From Info center, no I do not have an option, this is what came up after the update.

This is the case for two of three pc’s (see above for details) the third says X11.

Can you log out and at login screen usually bottom left side change to wayland for the problem PC successfully?

1 Like

Will have a look and report back

Yep, that was it, just selected Wayland in lower left corner in the login screen.
Autologin was on, that might had an impact.
Anyhow, learned a something new today as well.

Thanks :slightly_smiling_face:

1 Like

Update, enabling autologin again, switches back to X11, so autologin needs to be disabled at least for now, but no problem. The login process is way faster with Wayland, with X11 it stops a long period with the Plasma logo on a black screen.

Yes, that has been my experience with both Plasma 5 and 6 with respect to Wayland. A lot of optimization work and bug fixing has been going on to improve the desktop experience.

1 Like


This folder is empty on my system.

I had this problem with my set up - whenever I logged in to my account it would default to X11. But when I tried forcing it to run in Wayland and got a black screen with just the cursor. I have Nvidia drivers installed which are notorious for problems with Wayland on KDE.

However I stumbled across a solution on the web that worked for me (I don’t recommend trying this necessarily, but it may be illustrative of some of the issues). I created a new account (guest) and tested that and Wayland worked. So I then went into my own account and renamed “.config” to “.config.backup”. I logged out and then logged in and my desktop launched in Wayland. Obviously all my personalisations were gone and I had mostly the OpenSuSE default desktop. I manually set back up my KDE desktop settings, and copied across folders for apps I could identify from “.config.backup” to “.config”.

Note before doing that I’d tried and implemented all the common KDE NVidia solutions (e.g. enabling Nvidia DRM modeset in grub) - these did not seem to fix my issues but the .config change may have needed those changes first too.

Obviously this is a blunt fix.

Also I’m separately having issues with SDDM since the upgrade; SDDM also gets stuck on a black screen with a cursor too and test mode give me an SIGSEGV error, plus the config options have disappeared from the KDE settings screen. I have tried multple methods to try and fix that, including forcing X11 and no themes but no luck. I had to switch LightDM to get my system into a semblance of normality. I’m wondering if something with SDDM is broken with the Tumbleweed KDE 6 update, although I can’t see any other mentions of this issue in the forums.

Yeah it will usually be empty and you create it. I tested my backup config and it doesn’t actually autologin for me in any case anymore. I re-tested w same format as archwiki and also doesn’t auto login. So you can disregard my above comment I suppose

If that isn’t working, it’s probably not going to get fixed, if you don’t go file a bug, to let the Maintainers know it’s a problem.

I noticed something today when reinstalling the nvidia drivers after the kernel update 6.7.9-1. After the nvidia installer restarted the gui, my system booted into Wayland instead of X. So I tried rebooting into runlevel 3 and starting the gui with

systemctl start xdm.service

but I got X again.

Anyone know how the nvidia installer managed to do this?

Or is there a different command that I can use that will start Wayland?

I’m not sure but I did find that recently selecting wayland at sddm login wasn’t sticking on reboot. My old autologin wasn’t working but I did find this in

# prevent gnome-session from failing (boo#1163262)

I changed this line to wayland instead of x11 to set session type and at login now, it defaults to wayland being selected. I dont currently have autologin setup so can’t speak to that.
Also, just commenting out this export also prevents it and wayland is remembered

I never had gnome installed so I’m guessing this is common on everyone’s plasma system

I edited that file and when I restarted, all I got was a black screen with a cursor, and the cursor was the size it is in X. Changed it back and things went back to normal.

Normal meaning my system still boots into X.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.