Wayland + AMD GPU Full Screen Issues

Kernel: 6.8.7-1-default
Resolution: 3840x2160
CPU: AMD Ryzen 9 7950X3D
GPU: AMD ATI 59:00.0 Raphael (iGPU)
GPU: AMD ATI Radeon RX 7900 XTX
Wayland

Just installed openSUSE yesterday and booted straight into a Wayland session. Installed the opi codecs via the packman repo, and everything is all fine and dandy. I’m using Brave Browser and I’m aware it currently has a problem with Wayland right now, but the issue I’m about to describe is persistent across other browsers such as Firefox as well. I’m running a dual 4k monitor setup, one at 144hz, one at 60hz.

Everything works fine until I put a video, for example a youtube video, in full screen. once I full screen and attempt to use another monitor or even start using the full screened window itself, my performance is very laggy. Something about full screening is conflicting. I could switch to X11 but I want to see if there is a work around but I couldn’t find anything, since I’ve heard normally AMD works fine with Wayland. I’ve also tried manipulating Adaptive sync between Automatic, Never, and Always and doesn’t seem to make any difference, with Always actually giving me weird black screen flickers.

Any help fixing this full screen lag would be appreciated, if known. I’ll be here to answer any follow up questions as well. Thanks in advance.

UPDATE: Fixed it, somehow my clock wasn’t synced and when I set the timezone automatically it fixed it. Don’t know how or why but a win is a win?

UPDATE: I lied (sort of). While resetting my clock last night, somehow it did fix the issue … temporarily. Regardless, I noticed the problems again today and actually isolated the issue this time. Basically TLDR if I turn off Freesync on my monitor, everything is fine, but if it’s on is when I get the issue. So it has something to do with Freesync + Wayland (because I don’t have this problem in X11 somehow). My monitor is 144hz for context, but lowering the refresh rate to 60 also didn’t seem to help. Any ideas?

Do you have a means to collect logs when this happens ? Add “drm.debug=0x116 log_buf_len=20M” to your kernel cmdline through grub, and collect the dmesg log when you run into this issue.

I was able to add the command to my grub file, however I’m not exactly sure specifically how to capture the desired information via a dmesg log while the issue is occurring.

You could just run “sudo dmesg > filename” in a terminal to get the dmesg. Ensure you reboot after editing /etc/default/grub and re-generate the grub config ( like grub2-mkconfig -o /boot/grub2/grub.cfg) and then try to repro and get the dmesg.

Can’t seem to reproduce the issue, appears to be very sporadic. The only thing that will consistently fix it is turning off free sync completely, which isn’t what I’m desiring as a solution. The weird thing is I’ll turn it back on, change my values exactly how they were when the problem was ongoing, and I won’t be able to reproduce the issue until it seemingly at random happens again. Next time it happens I’ll post it here, but my best guess based on everything I’ve researched is it is some conflict involving freesync and Wayland, as I don’t have this issue on X11 or Windows at all.

[ 2796.812810] amdgpu 0000:03:00.0: [drm:dcn20_program_pipe [amdgpu]] Un-gated front end for pipe 2
[ 2796.815612] amdgpu 0000:03:00.0: [drm:optc1_wait_for_state [amdgpu]] REG_WAIT taking a while: 1ms in optc1_wait_for_state line:833
[ 2796.822627] amdgpu 0000:03:00.0: [drm:dc_commit_streams [amdgpu]] dc_commit_streams Finished.
[ 2796.823000] amdgpu 0000:03:00.0: [drm:drm_atomic_state_default_clear] Clearing atomic state 000000009e7fd97c
[ 2796.823005] amdgpu 0000:03:00.0: [drm:__drm_atomic_state_free] Freeing atomic state 000000009e7fd97c
[ 2796.829209] amdgpu 0000:03:00.0: [drm:drm_mode_addfb2] [FB:136]
[ 2796.829231] amdgpu 0000:03:00.0: [drm:drm_atomic_state_init] Allocated atomic state 000000002c71cdbf
[ 2796.829236] amdgpu 0000:03:00.0: [drm:drm_atomic_get_plane_state] Added [PLANE:80:plane-7] 00000000a54592d3 state to 000000002c71cdbf
[ 2796.829241] amdgpu 0000:03:00.0: [drm:drm_atomic_set_fb_for_plane] Set [NOFB] for [PLANE:80:plane-7] state 00000000a54592d3
[ 2796.829247] amdgpu 0000:03:00.0: [drm:drm_atomic_get_plane_state] Added [PLANE:52:plane-2] 00000000b3df91a2 state to 000000002c71cdbf
[ 2796.829252] amdgpu 0000:03:00.0: [drm:drm_atomic_get_crtc_state] Added [CRTC:83:crtc-1] 00000000a9442956 state to 000000002c71cdbf
[ 2796.829256] amdgpu 0000:03:00.0: [drm:drm_atomic_set_fb_for_plane] Set [FB:136] for [PLANE:52:plane-2] state 00000000b3df91a2
[ 2796.829262] amdgpu 0000:03:00.0: [drm:drm_atomic_check_only] checking 000000002c71cdbf
[ 2796.829271] amdgpu 0000:03:00.0: [drm:drm_atomic_state_default_clear] Clearing atomic state 000000002c71cdbf
[ 2796.829274] amdgpu 0000:03:00.0: [drm:__drm_atomic_state_free] Freeing atomic state 000000002c71cdbf
[ 2796.831976] amdgpu 0000:03:00.0: [drm:drm_atomic_state_init] Allocated atomic state 000000000675fa77
[ 2796.831983] amdgpu 0000:03:00.0: [drm:drm_atomic_get_plane_state] Added [PLANE:52:plane-2] 000000006468b4dd state to 000000000675fa77
[ 2796.831989] amdgpu 0000:03:00.0: [drm:drm_atomic_get_crtc_state] Added [CRTC:83:crtc-1] 00000000d3f49524 state to 000000000675fa77
[ 2796.831994] amdgpu 0000:03:00.0: [drm:drm_atomic_set_fb_for_plane] Set [FB:136] for [PLANE:52:plane-2] state 000000006468b4dd
[ 2796.832001] amdgpu 0000:03:00.0: [drm:drm_atomic_check_only] checking 000000000675fa77
[ 2796.832009] amdgpu 0000:03:00.0: [drm:drm_atomic_nonblocking_commit] committing 000000000675fa77 nonblocking
[ 2796.848700] amdgpu 0000:03:00.0: [drm:dcn20_program_pipe [amdgpu]] Un-gated front end for pipe 2
[ 2796.855339] amdgpu 0000:03:00.0: [drm:optc1_wait_for_state [amdgpu]] REG_WAIT taking a while: 3ms in optc1_wait_for_state line:833
[ 2796.863806] amdgpu 0000:03:00.0: [drm:drm_mode_addfb2] [FB:139]
[ 2796.863826] amdgpu 0000:03:00.0: [drm:drm_atomic_state_init] Allocated atomic state 00000000686210c5
[ 2796.863830] amdgpu 0000:03:00.0: [drm:drm_atomic_get_plane_state] Added [PLANE:76:plane-6] 00000000b3df91a2 state to 00000000686210c5
[ 2796.863834] amdgpu 0000:03:00.0: [drm:drm_atomic_set_fb_for_plane] Set [NOFB] for [PLANE:76:plane-6] state 00000000b3df91a2
[ 2796.863839] amdgpu 0000:03:00.0: [drm:drm_atomic_get_plane_state] Added [PLANE:58:plane-3] 000000009efe8d72 state to 00000000686210c5
[ 2796.863843] amdgpu 0000:03:00.0: [drm:drm_atomic_get_crtc_state] Added [CRTC:79:crtc-0] 00000000a9442956 state to 00000000686210c5
[ 2796.863847] amdgpu 0000:03:00.0: [drm:drm_atomic_set_fb_for_plane] Set [FB:139] for [PLANE:58:plane-3] state 000000009efe8d72
[ 2796.863851] amdgpu 0000:03:00.0: [drm:drm_atomic_check_only] checking 00000000686210c5
[ 2796.863855] [drm:dm_update_plane_state [amdgpu]] Disabling DRM plane: 58 on DRM crtc 79
[ 2796.864167] amdgpu 0000:03:00.0: [drm:drm_atomic_get_private_obj_state] Added new private object 00000000e05e5707 state 0000000083f98b8d to 00000000686210c5
[ 2796.864183] [drm:dm_update_plane_state [amdgpu]] Enabling DRM plane: 58 on DRM crtc 79
[ 2796.866800] amdgpu 0000:03:00.0: [drm:optc1_wait_for_state [amdgpu]] REG_WAIT taking a while: 6ms in optc1_wait_for_state line:833
[ 2796.867003] amdgpu 0000:03:00.0: [drm:drm_atomic_state_default_clear] Clearing atomic state 00000000f455e4df
[ 2796.867012] amdgpu 0000:03:00.0: [drm:__drm_atomic_state_free] Freeing atomic state 00000000f455e4df
[ 2796.867015] amdgpu 0000:03:00.0: [drm:drm_atomic_state_default_clear] Clearing atomic state 000000000675fa77
[ 2796.867020] amdgpu 0000:03:00.0: [drm:__drm_atomic_state_free] Freeing atomic state 000000000675fa77
[ 2796.867052] amdgpu 0000:03:00.0: [drm:drm_atomic_state_default_clear] Clearing atomic state 00000000686210c5
[ 2796.867060] amdgpu 0000:03:00.0: [drm:__drm_atomic_state_free] Freeing atomic state 00000000686210c5
[ 2796.867751] amdgpu 0000:03:00.0: [drm:drm_atomic_state_init] Allocated atomic state 00000000bd44f5df
[ 2796.867757] amdgpu 0000:03:00.0: [drm:drm_atomic_get_plane_state] Added [PLANE:58:plane-3] 0000000042c35711 state to 00000000bd44f5df
[ 2796.867762] amdgpu 0000:03:00.0: [drm:drm_atomic_get_crtc_state] Added [CRTC:79:crtc-0] 00000000f37dafe3 state to 00000000bd44f5df
[ 2796.867765] amdgpu 0000:03:00.0: [drm:drm_atomic_set_fb_for_plane] Set [FB:139] for [PLANE:58:plane-3] state 0000000042c35711
[ 2796.867770] amdgpu 0000:03:00.0: [drm:drm_atomic_check_only] checking 00000000bd44f5df
[ 2796.867774] [drm:dm_update_plane_state [amdgpu]] Disabling DRM plane: 58 on DRM crtc 79
[ 2796.868007] amdgpu 0000:03:00.0: [drm:drm_atomic_get_private_obj_state] Added new private object 00000000e05e5707 state 000000001942de09 to 00000000bd44f5df
[ 2796.868027] [drm:dm_update_plane_state [amdgpu]] Enabling DRM plane: 58 on DRM crtc 79
[ 2796.868252] amdgpu 0000:03:00.0: [drm:drm_atomic_nonblocking_commit] committing 00000000bd44f5df nonblocking
[ 2796.868278] amdgpu 0000:03:00.0: [drm:dc_commit_streams [amdgpu]] dc_commit_streams: 2 streams
[ 2796.868520] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] core_stream 0x00000000985e345d: src: 0, 0, 3840, 2160; dst: 0, 0, 3840, 2160, colorSpace:1
[ 2796.868764] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] 	pix_clk_khz: 1288580, h_total: 4020, v_total: 2226, pixelencoder:1, displaycolorDepth:3
[ 2796.868991] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] 	link: 0
[ 2796.869215] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] 	dsc: 1, mst_pbn: 0
[ 2796.869434] amdgpu 0000:03:00.0: [drm:dc_commit_streams [amdgpu]] 	dispname: M28U signal: 20
[ 2796.869619] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] core_stream 0x00000000f57defbe: src: 0, 0, 3840, 2160; dst: 0, 0, 3840, 2160, colorSpace:1
[ 2796.869803] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] 	pix_clk_khz: 533250, h_total: 4000, v_total: 2222, pixelencoder:1, displaycolorDepth:3
[ 2796.869986] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] 	link: 1
[ 2796.870167] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] 	dsc: 0, mst_pbn: 0
[ 2796.870349] amdgpu 0000:03:00.0: [drm:dc_commit_streams [amdgpu]] 	dispname: ASUS VG289 signal: 20
[ 2796.872729] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]     pipe topology update
[ 2796.872880] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]   ________________________
[ 2796.873034] amdgpu 0000:03:00.0: [drm:resource_log_pipe [amdgpu]]  | plane0  slice0  stream0|
[ 2796.873182] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]  |DPP0----OPP0----OTG0----|
[ 2796.873330] amdgpu 0000:03:00.0: [drm:resource_log_pipe [amdgpu]]  | plane0  slice0  stream1|
[ 2796.873483] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]  |DPP1----OPP1----OTG1----|
[ 2796.873631] amdgpu 0000:03:00.0: [drm:resource_log_pipe [amdgpu]]  |         slice0  stream2|
[ 2796.873780] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]  |DPG2----OPP2----OTG2----|
[ 2796.873928] amdgpu 0000:03:00.0: [drm:dcn20_program_front_end_for_ctx [amdgpu]]  |________________________|
[ 2796.874624] amdgpu 0000:03:00.0: [drm:dcn20_program_front_end_for_ctx [amdgpu]] Reset mpcc for pipe 2
[ 2796.874845] amdgpu 0000:03:00.0: [drm:dcn10_plane_atomic_power_down [amdgpu]] Power gated front end 2
[ 2796.875012] amdgpu 0000:03:00.0: [drm:dcn20_post_unlock_program_front_end [amdgpu]] Power down front end 2
[ 2796.875204] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]     pipe topology update
[ 2796.875366] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]   ________________________
[ 2796.875521] amdgpu 0000:03:00.0: [drm:resource_log_pipe [amdgpu]]  | plane0  slice0  stream0|
[ 2796.875670] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]  |DPP0----OPP0----OTG0----|
[ 2796.875818] amdgpu 0000:03:00.0: [drm:resource_log_pipe [amdgpu]]  | plane0  slice0  stream1|
[ 2796.875967] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]  |DPP1----OPP1----OTG1----|
[ 2796.876115] amdgpu 0000:03:00.0: [drm:resource_log_pipe [amdgpu]]  | plane0  slice0  stream2|
[ 2796.876264] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]  |DPP2----OPP2----OTG2----|
[ 2796.876419] amdgpu 0000:03:00.0: [drm:dcn20_program_front_end_for_ctx [amdgpu]]  |________________________|
[ 2796.876647] amdgpu 0000:03:00.0: [drm:dcn20_program_pipe [amdgpu]] Un-gated front end for pipe 2
[ 2796.883129] amdgpu 0000:03:00.0: [drm:optc1_wait_for_state [amdgpu]] REG_WAIT taking a while: 3ms in optc1_wait_for_state line:833
[ 2796.890312] amdgpu 0000:03:00.0: [drm:dc_commit_streams [amdgpu]] dc_commit_streams Finished.
[ 2796.892238] amdgpu 0000:03:00.0: [drm:dcn20_program_pipe [amdgpu]] Un-gated front end for pipe 2
[ 2796.897023] amdgpu 0000:03:00.0: [drm:optc1_wait_for_state [amdgpu]] REG_WAIT taking a while: 2ms in optc1_wait_for_state line:833
[ 2796.900134] amdgpu 0000:03:00.0: [drm:optc1_wait_for_state [amdgpu]] REG_WAIT taking a while: 1ms in optc1_wait_for_state line:833
[ 2796.904085] amdgpu 0000:03:00.0: [drm:drm_atomic_state_default_clear] Clearing atomic state 00000000bd44f5df
[ 2796.904095] amdgpu 0000:03:00.0: [drm:__drm_atomic_state_free] Freeing atomic state 00000000bd44f5df
[ 2796.905156] amdgpu 0000:03:00.0: [drm:drm_mode_addfb2] [FB:129]
[ 2796.905170] amdgpu 0000:03:00.0: [drm:drm_atomic_state_init] Allocated atomic state 000000005697edd1
[ 2796.905174] amdgpu 0000:03:00.0: [drm:drm_atomic_get_plane_state] Added [PLANE:76:plane-6] 00000000b3df91a2 state to 000000005697edd1
[ 2796.905178] amdgpu 0000:03:00.0: [drm:drm_atomic_set_fb_for_plane] Set [NOFB] for [PLANE:76:plane-6] state 00000000b3df91a2
[ 2796.905183] amdgpu 0000:03:00.0: [drm:drm_atomic_get_plane_state] Added [PLANE:58:plane-3] 000000009efe8d72 state to 000000005697edd1
[ 2796.905187] amdgpu 0000:03:00.0: [drm:drm_atomic_get_crtc_state] Added [CRTC:79:crtc-0] 00000000a9442956 state to 000000005697edd1
[ 2796.905191] amdgpu 0000:03:00.0: [drm:drm_atomic_set_fb_for_plane] Set [FB:129] for [PLANE:58:plane-3] state 000000009efe8d72
[ 2796.905195] amdgpu 0000:03:00.0: [drm:drm_atomic_check_only] checking 000000005697edd1
[ 2796.905199] [drm:dm_update_plane_state [amdgpu]] Disabling DRM plane: 58 on DRM crtc 79
[ 2796.905497] amdgpu 0000:03:00.0: [drm:drm_atomic_get_private_obj_state] Added new private object 00000000e05e5707 state 0000000083f98b8d to 000000005697edd1
[ 2796.905536] [drm:dm_update_plane_state [amdgpu]] Enabling DRM plane: 58 on DRM crtc 79
[ 2796.905831] amdgpu 0000:03:00.0: [drm:drm_atomic_state_default_clear] Clearing atomic state 000000005697edd1
[ 2796.905839] amdgpu 0000:03:00.0: [drm:__drm_atomic_state_free] Freeing atomic state 000000005697edd1
[ 2796.905860] amdgpu 0000:03:00.0: [drm:drm_atomic_state_init] Allocated atomic state 000000005697edd1
[ 2796.905863] amdgpu 0000:03:00.0: [drm:drm_atomic_get_plane_state] Added [PLANE:76:plane-6] 00000000b3df91a2 state to 000000005697edd1
[ 2796.905867] amdgpu 0000:03:00.0: [drm:drm_atomic_set_fb_for_plane] Set [NOFB] for [PLANE:76:plane-6] state 00000000b3df91a2
[ 2796.905871] amdgpu 0000:03:00.0: [drm:drm_atomic_get_plane_state] Added [PLANE:58:plane-3] 000000009efe8d72 state to 000000005697edd1
[ 2796.905874] amdgpu 0000:03:00.0: [drm:drm_atomic_get_crtc_state] Added [CRTC:79:crtc-0] 00000000a9442956 state to 000000005697edd1
[ 2796.905878] amdgpu 0000:03:00.0: [drm:drm_atomic_set_fb_for_plane] Set [FB:129] for [PLANE:58:plane-3] state 000000009efe8d72
[ 2796.905882] amdgpu 0000:03:00.0: [drm:drm_atomic_check_only] checking 000000005697edd1
[ 2796.905885] [drm:dm_update_plane_state [amdgpu]] Disabling DRM plane: 58 on DRM crtc 79
[ 2796.906188] amdgpu 0000:03:00.0: [drm:drm_atomic_get_private_obj_state] Added new private object 00000000e05e5707 state 0000000083f98b8d to 000000005697edd1
[ 2796.906201] [drm:dm_update_plane_state [amdgpu]] Enabling DRM plane: 58 on DRM crtc 79
[ 2796.906490] amdgpu 0000:03:00.0: [drm:drm_atomic_state_default_clear] Clearing atomic state 000000005697edd1
[ 2796.906496] amdgpu 0000:03:00.0: [drm:__drm_atomic_state_free] Freeing atomic state 000000005697edd1
[ 2796.909428] amdgpu 0000:03:00.0: [drm:drm_atomic_state_init] Allocated atomic state 000000003e9d8354
[ 2796.909434] amdgpu 0000:03:00.0: [drm:drm_atomic_get_plane_state] Added [PLANE:58:plane-3] 00000000a18ece52 state to 000000003e9d8354
[ 2796.909440] amdgpu 0000:03:00.0: [drm:drm_atomic_get_crtc_state] Added [CRTC:79:crtc-0] 00000000f67184ca state to 000000003e9d8354
[ 2796.909444] amdgpu 0000:03:00.0: [drm:drm_atomic_set_fb_for_plane] Set [FB:129] for [PLANE:58:plane-3] state 00000000a18ece52
[ 2796.909449] amdgpu 0000:03:00.0: [drm:drm_atomic_check_only] checking 000000003e9d8354
[ 2796.909453] [drm:dm_update_plane_state [amdgpu]] Disabling DRM plane: 58 on DRM crtc 79
[ 2796.909745] amdgpu 0000:03:00.0: [drm:drm_atomic_get_private_obj_state] Added new private object 00000000e05e5707 state 00000000ffea97d7 to 000000003e9d8354
[ 2796.909778] [drm:dm_update_plane_state [amdgpu]] Enabling DRM plane: 58 on DRM crtc 79
[ 2796.910104] amdgpu 0000:03:00.0: [drm:drm_atomic_nonblocking_commit] committing 000000003e9d8354 nonblocking
[ 2796.910119] amdgpu 0000:03:00.0: [drm:dc_commit_streams [amdgpu]] dc_commit_streams: 2 streams
[ 2796.910314] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] core_stream 0x00000000985e345d: src: 0, 0, 3840, 2160; dst: 0, 0, 3840, 2160, colorSpace:1
[ 2796.910507] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] 	pix_clk_khz: 1288580, h_total: 4020, v_total: 2226, pixelencoder:1, displaycolorDepth:3
[ 2796.910692] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] 	link: 0
[ 2796.910877] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] 	dsc: 1, mst_pbn: 0
[ 2796.911061] amdgpu 0000:03:00.0: [drm:dc_commit_streams [amdgpu]] 	dispname: M28U signal: 20
[ 2796.911255] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] core_stream 0x00000000f57defbe: src: 0, 0, 3840, 2160; dst: 0, 0, 3840, 2160, colorSpace:1
[ 2796.911434] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] 	pix_clk_khz: 533250, h_total: 4000, v_total: 2222, pixelencoder:1, displaycolorDepth:3
[ 2796.911589] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] 	link: 1
[ 2796.911744] amdgpu 0000:03:00.0: [drm:dc_stream_log [amdgpu]] 	dsc: 0, mst_pbn: 0
[ 2796.911898] amdgpu 0000:03:00.0: [drm:dc_commit_streams [amdgpu]] 	dispname: ASUS VG289 signal: 20
[ 2796.914082] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]     pipe topology update
[ 2796.914233] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]   ________________________
[ 2796.914382] amdgpu 0000:03:00.0: [drm:resource_log_pipe [amdgpu]]  | plane0  slice0  stream0|
[ 2796.914535] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]  |DPP0----OPP0----OTG0----|
[ 2796.914683] amdgpu 0000:03:00.0: [drm:resource_log_pipe [amdgpu]]  | plane0  slice0  stream1|
[ 2796.914831] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]  |DPP1----OPP1----OTG1----|
[ 2796.914979] amdgpu 0000:03:00.0: [drm:resource_log_pipe [amdgpu]]  |         slice0  stream2|
[ 2796.915127] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]  |DPG2----OPP2----OTG2----|
[ 2796.915279] amdgpu 0000:03:00.0: [drm:dcn20_program_front_end_for_ctx [amdgpu]]  |________________________|
[ 2796.915982] amdgpu 0000:03:00.0: [drm:dcn20_program_front_end_for_ctx [amdgpu]] Reset mpcc for pipe 2
[ 2796.916195] amdgpu 0000:03:00.0: [drm:dcn10_plane_atomic_power_down [amdgpu]] Power gated front end 2
[ 2796.916358] amdgpu 0000:03:00.0: [drm:dcn20_post_unlock_program_front_end [amdgpu]] Power down front end 2
[ 2796.916552] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]     pipe topology update
[ 2796.916707] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]   ________________________
[ 2796.916859] amdgpu 0000:03:00.0: [drm:resource_log_pipe [amdgpu]]  | plane0  slice0  stream0|
[ 2796.917011] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]  |DPP0----OPP0----OTG0----|
[ 2796.917162] amdgpu 0000:03:00.0: [drm:resource_log_pipe [amdgpu]]  | plane0  slice0  stream1|
[ 2796.917313] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]  |DPP1----OPP1----OTG1----|
[ 2796.917468] amdgpu 0000:03:00.0: [drm:resource_log_pipe [amdgpu]]  | plane0  slice0  stream2|
[ 2796.917621] amdgpu 0000:03:00.0: [drm:resource_log_pipe_topology_update [amdgpu]]  |DPP2----OPP2----OTG2----|
[ 2796.917772] amdgpu 0000:03:00.0: [drm:dcn20_program_front_end_for_ctx [amdgpu]]  |________________________|
[ 2796.917995] amdgpu 0000:03:00.0: [drm:dcn20_program_pipe [amdgpu]] Un-gated front end for pipe 2
[ 2796.924813] amdgpu 0000:03:00.0: [drm:optc1_wait_for_state [amdgpu]] REG_WAIT taking a while: 3ms in optc1_wait_for_state line:833
[ 2796.933469] amdgpu 0000:03:00.0: [drm:optc1_wait_for_state [amdgpu]] REG_WAIT taking a while: 4ms in optc1_wait_for_state line:833
[ 2796.933899] amdgpu 0000:03:00.0: [drm:dc_commit_streams [amdgpu]] dc_commit_streams Finished.
[ 2796.935979] amdgpu 0000:03:00.0: [drm:dcn20_program_pipe [amdgpu]] Un-gated front end for pipe 2

The problem appears to reproduce after waking up from sleep or rebooting. This is what I got.

Looks like the dmesg is clipped off. This doesnt show any hangs or freesync related issues. Please upload the full dmesg next time.

The dmesg is 289,000 lines so unfortunately I can’t paste the entire thing without it crashing. Maybe I’m doing it wrong? Please excuse my ignorance.

Somehow launching brave browser with the --ozone-platform=wayland flag seems to fix it at least for videos (maybe, it’s sporadic), since I used to launch it as wayland before it broke a few days ago, and we are currently pending a patch for that. So it might have been a compatibility issue but if it happens again maybe I can adjust my process to provide a better dmesg log.

https://wiki.archlinux.org/title/Variable_refresh_rate

Already read this top to bottom like 14 times, didn’t seem applicable to my situation with AMD + Wayland + KDE. Haven’t experienced the problem in 2 days after downgrading my monitors firmware to its ACTUAL latest version (because gigabyte installs a different monitors firmware by default lul?) and updating brave to run the ozone platform as Wayland. Going to mark this as the solution.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.