Waydroid does not start properly

I am trying to get Waydroid running. This is the log I get after running waydroid -v session start

(024531) [15:45:58] % /usr/lib/waydroid/data/scripts/waydroid-net.sh start
vnic is waydroid0
(024531) [15:45:59] % systemctl is-active -q nfcd
(024531) [15:45:59] % chmod 777 -R /sys/kernel/debug/sync/sw_sync
(024531) [15:45:59] % chmod 777 -R /dev/dri
(024531) [15:45:59] % chmod 777 -R /dev/fb0
(024531) [15:45:59] % chmod 777 -R /dev/video0
(024531) [15:45:59] % chmod 777 -R /dev/video1
(024531) [15:45:59] % chmod 777 -R /dev/video2
(024531) [15:45:59] % chmod 777 -R /dev/video3
(024531) [15:45:59] % mv /var/lib/waydroid/config_session /var/lib/waydroid/lxc/waydroid
(024531) [15:45:59] % mount -o ro /var/lib/waydroid/images/system.img /var/lib/waydroid/rootfs
(024531) [15:45:59] % mount -t overlay -o ro,lowerdir=/var/lib/waydroid/overlay:/var/lib/waydroid/rootfs,upperdir=/var/lib/waydroid/overlay_rw/system,workdir=/var/lib/waydroid/overlay_work/system,xino=off overlay /var/lib/waydroid/rootfs
(024531) [15:45:59] % mount -o ro /var/lib/waydroid/images/vendor.img /var/lib/waydroid/rootfs/vendor
(024531) [15:45:59] % mount -t overlay -o ro,lowerdir=/var/lib/waydroid/overlay/vendor:/var/lib/waydroid/rootfs/vendor,upperdir=/var/lib/waydroid/overlay_rw/vendor,workdir=/var/lib/waydroid/overlay_work/vendor,xino=off overlay /var/lib/waydroid/rootfs/vendor
(024531) [15:45:59] % mount -o bind /var/lib/waydroid/waydroid.prop /var/lib/waydroid/rootfs/vendor/waydroid.prop
(024531) [15:45:59] Save config: /var/lib/waydroid/waydroid.cfg
(024531) [15:45:59] % lxc-start -P /var/lib/waydroid/lxc -F -n waydroid – /init
(024531) [15:45:59] New background process: pid=26006, output=background
(024531) [15:45:59] % lxc-info -P /var/lib/waydroid/lxc -n waydroid -sH
tail: cannot watch ‘/var/lib/waydroid/waydroid.log’: Permission denied
tail: cannot watch ‘/var/lib/waydroid/waydroid.log’: Permission denied
tail: cannot watch ‘/var/lib/waydroid/waydroid.log’: Permission denied
tail: cannot watch ‘/var/lib/waydroid/waydroid.log’: Permission denied

and then nothing. Same with waydroid show-full-ui

waydroid status

Session: RUNNING
Container: RUNNING
Vendor type: MAINLINE
IP address: UNKNOWN
Session user: Computer2(1001)
Wayland display: wayland-0

I am stumped; there is no error in the log so I don’t know what to look for. I followed the steps in https://forums.opensuse.org/t/tumblewed-waydroid-install/167927/1,
https://codeberg.org/cream/waydroid-openSUSE-setup
as well as the Archwiki page and the Waydroid docs.

On the other hand waydroid app list gives this output:

(026342) [15:55:10] Waiting for binder Service Manager…
(026342) [15:56:10] Service Manager never appeared
(026342) [15:56:10] Failed to access IPlatform service

I did manage to launch waydroid on leap 15.5, but I could not get it to rotate properly (so I have proof it is possible on my hardware). I migrated to Tumbleweed in the hopes of doing better since TW has more waydroid associated repos, but no luck so far.

Any advice or recommendations would be much appreciated.

It says “Permission denied”, so you can try running as root if you are able to.

Thanks! But that is just for access to the log. Running waydroid session start as root does not work. I think I am going to start over with a fresh install of waydroid…