Warcraft III: The Frozen Throne

Hey all,

I’ve seen that may members have install Warcraft III: The Frozen Throne with Wine on OpenSUSE 11.0 without any issues. I’ve tried to install Frozen Throne multiple times, but it seems to be crashing at the same spot on installation every time. The Reign of Chaos installs fine and minus some resolution issues, it runs great. I submitted a bug report to Wine (found here) but so far, I have gotten no definitive answer to this problem. When running the installer (see screenshot below [while the shows me running the installer as root, I have tried with a normal user, and the same problem occurs]), it stops at the “C:/Program Files/Warcraft III/War3xlocal.mpq” step. It’s pretty frustrating because I have to force quit the installer, remove the program files folder for Warcraft, and reinstall Reign of Chaos.

Running Wine 1.1.2 as that is the newest version in the Wine repository.

Any ideas on what the problem could be?

man you should read that wine could not run as root for first…

  1. than make backup of your .wine by this

>mv .wine .wine.old

try dx8

after that try clean install of your WC3 you may have some troubles with sound… but it is another question…

also you should check that you have direcct rendering is work proparly

glxinfo can help to check this

Sorry, didn’t say clearly enough: while the screenshot shows me running it as root, but after I was told that I should run Wine as a normal user, I tried it multiple times as a normal user. This is just the only screenshot. That aside, Thank you very much for the reply. I’ll try that as soos as possible.

Thanks again. :slight_smile:

Error still occurs with this as a terminal readout:

err:wave:wodPlayer_WriteMaxFrags Error in writing wavehdr. Reason: Resource temporarily unavailable

Thank you.

did you select dx8 for your WC3 in winecfg


i have some problem like you have, but forgot how i solved it :frowning:

if you use pulseaudio, try to shut down it
pulseaudio stop
or you have some troubles with that use
padsp winecfg
padsp wine “pathtowc3\War3.exe”

i hope it will be helpfull for you :slight_smile:

did you select dx8 for your WC3 in winecfg


Please don’t use DX and don’t change these libraries in winecfg. Warcraft III has the ability to use opengl natively. Just use the opengl flag when running it:

wine “Frozen Throne.exe” -opengl


I keep getting the following error (given non-stop at some points):

err:wave:wodPlayer_WriteMaxFrags Error in writing wavehdr. Reason: Resource temporarily unavailable

Any ideas?

Thanks. :slight_smile:

You can try changing the audio driver:

run ‘winecfg’
select the audio tab at the top.
select ALSA. (If it doesn’t help, next time select OSS. ALSA should work and should be the default.)

This may, however, be completely unrelated.


I added “-opengl” to my KMENU warcraft entry and now I am able to play human campaigns. Very nice fix. And it plays faster too. At first my mouse was going NUTS all over the place. I just quit game, and restart. Ok now.

I get this error when saving my progress (during the middle of a game) Any ideas how to avoid this??


I have gotten that error before, but it was with saving games on certain custom maps.

Different versions of WINE have worked with saving games on custom maps. You might want to try a different version.

I haven’t actually saved a game in quite a while - many version of WINE have been released since. I always play multiplayer LAN games nowadays.


Can i use a version of wine from OBS for suse 10.2 10.3 etc? i am running 11 now and am using wine from OSB suse 11. (wine 1.1 i believe)

I tried appdb.winehq.org for answers. And tried google too. I can’t play WC3 on my lappy with Intel Graphics. All i get is a BLACK screen, but I hear the sound coming through (faintly)).

I have enabled “-opengl” flag, I enabled 3D accel from SAX, aiglx is OFF, composite is OFF. I have original disk. It works from my desktop (nvidia.com drivers) and “-opengl” flag turned on.

What else can I try? i just wanna play a LAN game.

Have you tried to rename the video folder? I also had trouble with black screen before I removed the videos. Playing battlenet sometimes on wine 1.1.3-1.1 and War3TFT_122a_English patch.

Have you tried installing from another copy of the disk? Same key and all.

It sounds like your disk might be damaged. I have installed on 1.1.2 without any headache. My trick is associating .exe files with wine, so just click and bam, works.

Are you running on anything funky like x86, or ppc, or maybe a FS that isn’t EXT or REISERFS?

Renmaing video folder suggest - i have not yet tried.

As for the above quote, you said something funky like x86. I think you mean 64-bit? No - i run only 32 bit. And only run ext3 on all partitions, on all drives, on all computers. I don’t think the disk is the problem, because it runs fine on winxp and suse 11.0 with nvidia-blobs installed.


I installed warcraft: frozen throne.

When I click the shortcut icon, open suse 11.1 prompt me ‘no disc’ pls insert the disc and click retry.

how to resolve this issue?


If you apply a patch at least 1.21b, then you do not need to have a CD anymore. Try this first.

If this patch is already installed, then read the WINE game information at:
WineHQ - Warcraft III The Frozen Throne: 1.x

specifically, the “WARNING: Patch 1.22” section.