Wait! What? Where is yast-sound?

Hi. I recently switched from Leap 15.4 to Tumbleweed (20230220) - today I went to try and fix an issue with the audio mixer failing to detect a connection to a bluetooth sound sink and wanted to check the sound card set-up, so reached for YAST > Hardware > Sound

what? where? w’happen? It’s no longer there!

I’ve done some cursory Internet digging, but there’s no mention of the quiet demise of the yast-sound module - is there something I missed?

04:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Renoir Radeon High Definition Audio Controller
	Subsystem: Tongfang Hongkong Limited Device 109f
	Flags: bus master, fast devsel, latency 0, IRQ 79, IOMMU group 5
	Memory at fe6c8000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
Welcome to PulseAudio 16.1! Use "help" for usage information.
>>> list-sinks
2 sink(s) available.
  * index: 0
        name: <alsa_output.pci-0000_04_00.6.analog-stereo>
        driver: <module-alsa-card.c>
    index: 1
        name: <alsa_output.pci-0000_04_00.6.analog-stereo.echo-cancel>
        driver: <module-echo-cancel.c>
~> bluetoothctl info EC:81:93:9A:75:85
Device EC:81:93:9A:75:85 (public)
        Name: Logitech BT Adapter
        Alias: Logitech BT Adapter
        Class: 0x00240414
        Icon: audio-card
        Paired: yes
        Bonded: yes
        Trusted: yes
        Blocked: no
        Connected: yes
        LegacyPairing: no
        UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)

for some reason I couldn’t save my edit, so here’s the additional text:

I checked the repos: 15.4 has https://download.opensuse.org/distribution/leap/15.4/repo/oss/x86_64/yast2-sound-4.4.1-150400.1.6.x86_64.rpm, and 15.5 has 5 (!) alternative options in https://download.opensuse.org/distribution/leap/15.5/repo/oss/x86_64/ but, as for Tumbleweed? Nada! https://download.opensuse.org/tumbleweed/repo/oss/x86_64/ goes straight from yast-snapper to yast-squid - that just don’t seem fair!

Not sure where you are at with this, but for most users there is no need to configure audio hardware explicitly. If you get into that space we can advise how to do it manually, following diagnostic steps if required.

That’s fair enough (and I just plugged in an external sound card that was detected straight away and added to the audio mixer control) - but I was mostly looking to use a familiar GUI tool for my initial troubleshooting of the failed detection/connection to the bluetooth audio sink.

It seems odd that the yast-sound module is present in Leap 15.4 and 15.5 but not Tumbleweed.

@jack_sprat It was on the Factory Mailing List 01/25/23 Drop of yast2-sound - openSUSE Factory - openSUSE Mailing Lists

Also see;

Not really see Malcolm’s answer.

With respect to diagnostics if/when they occur, refer to the following guide

In particular the alsa-info.sh utility is good for providing low-level audio information and errors.

1 Like

Ah. Okay. Cool.

So the bash commands to know are:

> inxi -A
> pacmd (if using PulseAudio)
>>> list-sinks
> cat /proc/asound/cards
> sudo /usr/sbin/alsa-info.sh

I had a look at pw-cli but it’s not super-intuitive, TBH.

This is a good wireplumber command to run for high level audio information, including available sinks…

wpctl status

If ‘pipewire-pulseaudio’ and ‘pulseaudio-utils’ are installed, then

pactl list sinks
1 Like

If Pulse then either, “pavucontrol” (GTK) or, “pavucontrol-qt” (KDE Plasma).

  • I cant find anything similar for Pipewire – the current tool-set seems to only CLI – “pw-top” is similar to “top” – CLI curses graphical presentation …
    I’m not swearing – “man curses” → “CRT screen handling

BTW, because of this Post, I’ve been cleaning up some bit dust – in particular the contents of ‘/etc/modprobe.d/’ –

  • I moved the “50-sound.conf” and “50-yast.conf” files off to a SysAdmin archive and rebooted.
    The sound came up with no issues, despite the YaST Audio module complaining that, the hardware needs to be configured – which I’ve now ignored – after many years of not ignoring that indication …

Just for completeness - and not really related to the original question - I ‘fixed’ the failure to connect by restarting the bluetooth service, since when it’s all been hunky-dory!

sudo service bluetooth restart


Thanks to everyone who suggested alternative troubleshooting tools.