VSFTPD problems

I have upgraded a web server from 10.1 to 10.3. Everything works except VSFTPD. The ftp application does not come up and the only error message I see is “exit status of parent of /usr/sbin/vsftpd: 1”. I have searched the other logs and find no additional messages. Any hints as to what is going on here?

  1. Have you actually installed the vsftpd package?

  2. Have you configured vsftp.conf?

  3. Have you started up the vsftpd service, or alternatively, configured it to run under xinetd?

Yes the package is installed and I have been through the configuration of vsftpd.conf. I’ve run vsftpd for quite some time under 10.1. It is when I go to start the service that I get the error message in my first post. The results are the same starting it via inetd or manually, same error message.

Turnj on the debugging in vsftpd.conf and view the log when you try to connect.

Not really anything to see except that in another log I find that the modules “ip_nat_ftp” and “ip_conntrack_ftp” are missing and could not be loaded. A complete search of the systems fails to find these modules, any idea where they should have come from during the installation?? I am sure I have some other problems but it appears I need to solve this one first.

They are called nf_nat_ftp and nf_conntrack_ftp these days I think.

Try these:

ldd /usr/sbin/vsftpd # or wherever it lives

That’ll tell you if there are any missing libraries.


and watch for messages.

O.K., some serious research on the web turned up the solutions.

  1. I did find the modules and got past that but I was right, it did not fix the big problem…

  2. After doing some more research I did find another post on the web that fixed the big problem. Per instructions there I editted /etc/xinetd.d/vsftpd and changed DISABLE = YES to DISABLE = No. A quick restart of xinetd and all works as it should.

I thought you had also tried running it standalone without xinetd?