Vraagje bepaald niet acuut. (Plymouth gerelateerd,…. denk ik.)

Goedenmiddag mede forumleden en linuxgoeroes Henk, Knurpht, Malcom, etc.

Mijn broertje (inmiddels ook met openSUSE op Laptop) heeft Plymouth verwijderd.

Door:

> sudo zypper rm plymouth plymouth-plugin-label plymouth-plugin-script plymouth-scripts plymouth-plugin-two-step

en vervolgens voorkomen dat het terugkomt door

> sudo zypper addlock plymouth

Vervolgens is geen grafische en herkenbare schermen meer voor hem.
Ik kon vanuit rescue prompt nog als root inloggen en heb dat weer hersteld met

systemctl isolate graphical.target

. Vervolgens met

zypper in plymouth plymouth-plugin-label plymouth-plugin-script plymouth-scripts plymouth-plugin-two-step

alles weer teruggezet (dat kan wellicht handiger enfin dit was mijn gedachte) en daarnamet

zypper removelock plymouth

de addlock verwijderd.

Broertje krijgt weer keurig zijn een grafisch vakje om LUKS password in te typen en systeemstart loopt door naar zijn login scherm etc.

Echter voorheen kreeg hij, net als ik, bij het aanzetten van de laptop (identieke configuratie als mijn laptop) direct het volgende bekende tekstje in beeld:

[FONT=century gothic]Booting ‘opeSUSE Tumbleweed’[/FONT]*

Loading Linux 5.5.1-1-default …
Loading Initial ramdisk …*

en dan start alles soepel door.

Nu komt er,na de aan-uit schakelaar te hebben ingedrukt, direct 5-6 seconden lang het fabrikanten logo, zonder Tumbleweed eronder, in beeld. Alvorens de bekende hierboven aangehaalde tekst verschijnt en dan start ook alles soepel door.

Hoe kan dat (kennelijk) vertragende fabrikanten logo (weer) verwijderd worden en direct bij aanzetten de tekst.

[FONT=century gothic]Booting ‘opeSUSE Tumbleweed’[/FONT]*

Loading Linux 5.5.1-1-default …
Loading Initial ramdisk …*

weer in beeld komen. Dus terug naar hoe het voorheen was?

Zoals al geschreven het heeft bepaald geen prioriteit, die 5-6 seconden daar kan hij wel mee leven, echter hij heeft voorkeur dit weg te laten. Ik weet gewoon niet hoe dat te doen en kon het ook niet vinden.

Alvast dank voor jullie altijd verhelderende input.

Meestal is dat een BIOS setting. Hoe die precies heet is per BIOS fabrikant wel eens verschillend.

Dank voor je snelle reactie.

Broertje draait zelfde type DELL E7250 ook met de laatste BIOS update A23 van vorige week, alleen in zijn machine zit een Samsung mSATA SSD in die van mij zit een Apacer mSATA SSD.

Hardware en BIOS/UEFI zijn de facto identiek (op de SSD na) en dat mag de pret niet drukken zou ik denken.
OS is identiek op identieke hardware.

Ik speel nu dus ook met precies zo’n Laptop en bij mij geen logo en direct de Boot tekst, net als bij m’n broertje, voor het verwijderen van Plymouth. Nu na het wederom installeren van Plymouth (zoals in initiële post beschreven) laat het systeem steevast allereerst het DELL logo zien, zonder Tumbleweed onder in beeld. Hetzelfde DELL logo dat voor het bereiken van het inlogschermwordt getoond, na het invoeren van het LUKS /home wachtwoord met Tumbleweed er onder, .

Enfin ik zal eens in zijn BIOS instellingen neuzen morgen en kijken of daar iets anders werd ingesteld dan bij mij.

Het is allemaal geen ramp, alleen erg raar dat dit DELL logo zomaar ineens opduikt, na het Plymouth verwijderen en terug zetten en daarvoor niet, terwijl aan de BIOS/UEFI instellingen niets werd gewijzigd. Het systeem draait prima, dat is het belangrijkste.

Overigens weet ik echt niet of die 5-6 seconden dat het DELL logo getoond wordt, echt vertraging zijn of dat bij mij bijvoorbeeld alleen de Boot tekst eerder en langer in beeld is. Dat zal ik ook eens bekijken.

Sinds september 2019 installeer ik steeds met UEFI en geen legacy BIOS meer en toch vind ik BIOS fijner, zal wel gewenning zijn.
Is die secureboot met UEFI variant nu echt zoveel veiliger vraag ik mij af en zo ja; waarom?

Ik ga de BIUOS/UEFI instellingen besnuffelen en zal je op de hoogte houden of de BIOS anders was ingeregeld.

Fijne avond.

Eh, daar zit ook een technische reden achter. Schijven met een traditionele MBR partitie tabel kunnen alleen met Legacy BIOS booten, de moderne standaard is een GPT partitionering.

Ik had ook iets verkeerd begrepen, zie ik nou. Dacht nl. dat je 't logo zag voordat GRUB ( de bootloader ) startte, maar je bedoelt erna. Dat heb ik ooit eens eerder gezien, weet niet precies zeker, maar ik meen me te herinneren dat 't na 't forceren van het opnieuw configureren van de bootloader in YaST - niks meer dan die openen, de wachttijd van 8 op bijv. 6 seconden zetten en OK geven, weer ‘normaal’ was.
De komst van dat fabrikanten logo vond ik eerst schokkend. Had net een nieuwe laptop, het HP logo, en de Windows toets afgeplakt met openSUSE sticker(tje)s, krijg ik 't verdorie knalgroot op mijn scherm.

Kun je overigens 's denken over je titel? Die moet als het goed is een indicatie geven over je vraag. In dit geval bijv. “Geen logo na herinstallatie Plymouth”. Zaken als “URGENT” of “HELP” of “Noodkreet” helpen niet. Als ik ( en Henk doet dat precies zo ) kijk naar nieuwe posts/onderwerpen in de forums pak ik eerst de draadjes waarvan ik weet dat ik er zelf al in gereageerd heb, of waarvan ik aan de titel zie dat ik er misschien wat mee kan. Als er dan nog tijd overblijft komen de “(URGENT) Help needed”, “Leap problem”, “Bug” pas aan de beurt. :smiley: .

Hi Knurpht;

Dank voor je reatcie

1- Titel:
Ik zal in vervolg de titel beter benoemen.
Ben nog niet zo ervaren met Fora etc.
Zie wel in waarom je dit vraagt.

2- GRUB2-EFI
Je had het weldegelijk goed gelezen. Ik zie dus het DELL logo (zonder daaronder de Tumbleweed vermelding), voordat de volgende bootloader tekst verschijnt.

*Booting ‘opeSUSE Tumbleweed’

**Loading Linux 5.5.1-1-default …
*Loading Initial ramdisk …

In beeld komt het DELL logo duurt 5-6 sec.
Dan komt de bootloader tekst zoals hierboven cursief (inmiddels nieuwe versie).

Daarna 2-3 sec het DELL Logo met daaronder de Tumbleweed vermelding.

Dan komt password voor LUKS encryptie.

Dat DELL logo voor de Bootloader tekst zie ik op geen van mijn andere openSUSE installaties en is verschenen sinds broertje zijn Plymouth had verwijderd en ik die heb teruggezet, zoals in de eerste post beschreven.

Wachttijd staat op 0 sec.

3- UEFI/BIOS & GPT/MBR
Ik begrijp niet helemaal wat je bedoelt hier.
Ik heb namelijk recent allemaal UEFI installaties gedaan en daar bij partitioneren gekozen voor MBR (MS DOS) partitietabel. En die starten allemaal gewoon op met UEFI secure-boot
Bij het gewone gebruik heb je niet snel meer parities nodig en Meestal bouw ik 128GB of 256GB SSD’s in dus geen mega grote schijven. Waarom zou je dan voor voor GPT kiezen en niet voor het bekende MBR?

Wat zegt


sudo systemd-analyze blame? 

Goedenavond Knurpht,

Ik heb daar ook al naar gekeken.
Ik zie niks geks.
Als ik het vergelijk met mijn DELL E7250 (identiek alleen zit er bij mij een kleinere Apacer SSD in) dan is mijn systeem met [size=2]15.155s ongeveer 5 seconden sneller (precies de tijd die het DELL logo in beeld is).[/size]

[FONT=century gothic]

localhost:~systemd-analyze blame
20.775s systemd-cryptsetup@cr_ata\x2dSamsung_SSD_860_EVO_250GB_S4CJNF0M841763N\x2dpart3.service     
2.139s display-manager.service                                                                   
2.037s plymouth-quit-wait.service                                                                
1.163s apparmor.service                                                                          
1.146s systemd-logind.service                                                                    
572ms systemd-udevd.service                                                                      
499ms initrd-switch-root.service                                                                 
496ms firewalld.service                                                                          
450ms systemd-journald.service                                                                   
376ms upower.service                                                                             
211ms systemd-rfkill.service                                                                     
194ms systemd-vconsole-setup.service                                                             
187ms polkit.service                                                                             
168ms systemd-udev-trigger.service                                                               
166ms systemd-journal-flush.service                                                             
163ms initrd-parse-etc.service                                                                   
140ms plymouth-switch-root.service                                                               
140ms avahi-daemon.service                                                                       
139ms smartd.service                                                                             
136ms mcelog.service                                                                             
135ms kbdsettings.service                                                                        
123ms issue-generator.service                                                                    
110ms user@1003.service                                                                          
106ms nscd.service                                                                                
90ms sound-extra.service                                                                         
82ms udisks2.service                                                                             
81ms ModemManager.service                                                                        
71ms chronyd.service                                                                             
71ms systemd-tmpfiles-clean.service

Wellicht dat jij wel iets ziet.

[/FONT]

Wellicht wil je deze ook nog zien.

**localhost:~ #** systemd-analyze critical-chain   
The time when unit became active or started is printed after the "@" character. 
The time the unit took to start is printed after the "+" character. 

graphical.target @24.721s 
└─**display-manager.service @22.582s +2.139s**
 └─**systemd-logind.service @21.433s +1.146s**
   └─nss-user-lookup.target @21.424s 
     └─**nscd.service @21.315s +106ms**
       └─basic.target @21.282s 
         └─sockets.target @21.282s 
           └─pcscd.socket @21.282s 
             └─sysinit.target @21.278s 
               └─**systemd-update-utmp.service @21.267s +11ms**
                 └─**auditd.service @21.230s +35ms**
                   └─**systemd-tmpfiles-setup.service @21.191s +38ms**
                     └─local-fs.target @21.187s 
                       └─**home.mount @21.165s +22ms**
                         └─**systemd-fsck@dev-disk-by\x2duuid-d61fb3e0\x2d9ca4\x2d49bc\x2d8c89\x2df55a5c06401a.service @21.113**>
                           └─local-fs-pre.target @21.110s 
                             └─cryptsetup.target @21.110s 
                               └─**systemd-cryptsetup@cr_ata\x2dSamsung_SSD_860_EVO_250GB_S4CJNF0M841763N\x2dpart3.service @334m**>
                                 └─system-systemd\x2dcryptsetup.slice @323ms 
                                   └─system.slice 
                                     └─-.slice 
lines 1-24/24 (END)
  

Kun je


rpm -qa | grep plymouth
zypper se plymouth

eens laten zien?

Jazeker!

Bij deze zie hieronder:
Ik heb gemakshalve even de laptops omgeruild en een eigen account aangemaakt, zodat ik wat sneller kan reageren en niet steeds eerst langs “broertje” moet.

Ik zie wel verschil met mijn eigen systemen.
Na eerste commandoregel, heb ik op mijn systeem slechts 9 x in rood vermeld: plymouth-…
Deze ontbreekt op mijn systemen

plymouth-plugin-script-0.9.5+git20190908+3abfab2-2.1.x86_64

Verder staat het rijtje op ieder systeem in een andere volgorde, dat doet er niet toe lijkt mij.

Na tweede commandoregel op beide DELL systemen en mijn overige systemen een identiek resultaat.

admin@localhost:~> rpm -qa | grep plymouth
plymouth-branding-openSUSE-84.87.20191004-3.6.noarch
plymouth-plugin-label-ft-0.9.5+git20190908+3abfab2-2.1.x86_64
plymouth-scripts-0.9.5+git20190908+3abfab2-2.1.x86_64
plymouth-theme-bgrt-0.9.5+git20190908+3abfab2-2.1.noarch
plymouth-plugin-label-0.9.5+git20190908+3abfab2-2.1.x86_64
plymouth-dracut-0.9.5+git20190908+3abfab2-2.1.x86_64
plymouth-plugin-two-step-0.9.5+git20190908+3abfab2-2.1.x86_64
plymouth-plugin-script-0.9.5+git20190908+3abfab2-2.1.x86_64    **<--- DEZE HEB IK NIET OP MIJN DELL EN MIJN ANDERE SYSTEMEN**
plymouth-theme-spinner-0.9.5+git20190908+3abfab2-2.1.noarch
plymouth-0.9.5+git20190908+3abfab2-2.1.x86_64
admin@localhost:~> zypper se plymouth
Gegevens van opslagruimte laden...
Lezen van geïnstalleerde pakketten...

S  | Naam                                | Samenvatting                                              | Type  
---+-------------------------------------+-----------------------------------------------------------+-------
   | blog-plymouth                       | Replaces plymouth by blogd                                | pakket
i+ | plymouth                            | Graphical Boot Animation and Logger                       | pakket
i  | plymouth-branding-openSUSE          | openSUSE Tumbleweed branding for Plymouth bootsplash      | pakket
   | plymouth-devel                      | Libraries and headers for writing Plymouth splash plugins | pakket
i  | plymouth-dracut                     | Plymouth related utilities for dracut                     | pakket
   | plymouth-plugin-fade-throbber       | Plymouth "Fade-Throbber" plugin                           | pakket
i+ | plymouth-plugin-label               | Plymouth label plugin                                     | pakket
i+ | plymouth-plugin-label-ft            | Plymouth FreeType label plugin                            | pakket
i+ | plymouth-plugin-script              | Plymouth "script" plugin                                  | pakket
   | plymouth-plugin-space-flares        | Plymouth "space-flares" plugin                            | pakket
   | plymouth-plugin-throbgress          | Plymouth "Throbgress" plugin                              | pakket
   | plymouth-plugin-tribar              | Plymouth "script" plugin                                  | pakket
i+ | plymouth-plugin-two-step            | Plymouth "two-step" plugin                                | pakket
i+ | plymouth-scripts                    | Plymouth related scripts                                  | pakket
i  | plymouth-theme-bgrt                 | Plymouth "bgrt" theme                                     | pakket
   | plymouth-theme-breeze               | Plymouth "Breeze" theme                                   | pakket
   | plymouth-theme-breeze-plugin-breeze | Plymouth "breeze" plugin                                  | pakket
   | plymouth-theme-fade-in              | Plymouth "Fade-In" theme                                  | pakket
   | plymouth-theme-script               | Plymouth "Script" theme                                   | pakket
   | plymouth-theme-solar                | Plymouth "Solar" theme                                    | pakket
   | plymouth-theme-spinfinity           | Plymouth "Spinfinity" theme                               | pakket
i  | plymouth-theme-spinner              | Plymouth "Spinner" theme                                  | pakket
   | plymouth-theme-tribar               | Plymouth "Tribar" theme                                   | pakket
admin@localhost:~>

Ben benieuwd naar je advies.

P.S. Ik merkte eerst nu op dat ik de titel gewoon kan veranderen.

Dit is wat ik heb, met ‘normaal’ werkende plymouth* pakketten:


knurpht@Knurpht-HP:~> rpm -qa | grep plymouth
plymouth-theme-bgrt-0.9.5+git20190908+3abfab2-2.1.noarch
plymouth-branding-openSUSE-84.87.20191004-3.6.noarch
plymouth-theme-spinner-0.9.5+git20190908+3abfab2-2.1.noarch
plymouth-plugin-label-ft-0.9.5+git20190908+3abfab2-2.1.x86_64
plymouth-plugin-label-0.9.5+git20190908+3abfab2-2.1.x86_64
plymouth-0.9.5+git20190908+3abfab2-2.1.x86_64
plymouth-scripts-0.9.5+git20190908+3abfab2-2.1.x86_64
plymouth-plugin-two-step-0.9.5+git20190908+3abfab2-2.1.x86_64
plymouth-dracut-0.9.5+git20190908+3abfab2-2.1.x86_64
knurpht@Knurpht-HP:~> 




Meer heb je dus niet nodig. Die jij vermeldt staat er niet tussen, dus die zou ik 's deïnstalleren, dan rebooten en kijken of 't fenomeen weg is,

Ik heb verwijderd als volgt:

admin@localhost:~> sudo zypper rm plymouth-plugin-script-0.9.5+git20190908+3abfab2-2.1.x86_64
[sudo] wachtwoord voor root: 
Lezen van geïnstalleerde pakketten...
Pakketafhankelijkheden oplossen...

Het volgende pakket zal worden VERWIJDERD:
  plymouth-plugin-script

1 te verwijderen pakket.
Na de bewerking zal 83,6 KiB worden vrijgemaakt.
Doorgaan? [j/n/v/...? alle opties tonen] (j): j
(1/1) Verwijderen van plymouth-plugin-script-0.9.5+git20190908+3abfab2-2.1.x86_64 ....................................[gereed]

Daarna een reboot …

Helaas geen verandering.
Zelfde resultaat DELL logo nog steeds als eerste 5-6 sec in beeld

Check zie hieronder. Ziet er nu hetzelfde uit als in mijn systemen.

admin@localhost:~> rpm -qa | grep plymouth
plymouth-branding-openSUSE-84.87.20191004-3.6.noarch
plymouth-plugin-label-ft-0.9.5+git20190908+3abfab2-2.1.x86_64
plymouth-scripts-0.9.5+git20190908+3abfab2-2.1.x86_64
plymouth-theme-bgrt-0.9.5+git20190908+3abfab2-2.1.noarch
plymouth-plugin-label-0.9.5+git20190908+3abfab2-2.1.x86_64
plymouth-dracut-0.9.5+git20190908+3abfab2-2.1.x86_64
plymouth-plugin-two-step-0.9.5+git20190908+3abfab2-2.1.x86_64
plymouth-theme-spinner-0.9.5+git20190908+3abfab2-2.1.noarch
plymouth-0.9.5+git20190908+3abfab2-2.1.x86_64
admin@localhost:~> 

En dit, ook hetzelfde ?


knurpht@Knurpht-HP:/etc/plymouth> cat plymouthd.conf 
# Distribution defaults. Changes to this file will get overwritten during
# upgrades.
[Daemon]
Theme=bgrt
ShowDelay=0
DeviceTimeout=8



Hi Knurpht;

Het volgende gedaan:

admin@localhost:~> cd /etc/plymouth
admin@localhost:/etc/plymouth> cat plymouthd.conf
# Distribution defaults. Changes to this file will get overwritten during
# upgrades.
[Daemon]
Theme=bgrt
ShowDelay=0
DeviceTimeout=8
admin@localhost:/etc/plymouth>

Geen veranderingen, behalve dat het erop lijkt dat DELL logo nu nog langer zo’n 10 sec in beeld is voordat ik de boot tekst in beeld krijg.
Verder loopt het systeem echt super.
Ik vind het zo raar dat het DELL logo na de rm en opnieuw in van plymoth nu voor de boottekst in beeld is, terwijl dat daarvoor nooit zo was en op mijn andere systemen ook niet zo is.

De UEFI/BIOS heb ik ook doorgelopen en daar is geen instelling te vinden die dat aanstuurt.

Hi Knurpht

Ik merket nog iets op:

Als ik doe

systemd-analyze

dan zie ik op dit syteem steevast:

Startup finished in 9.946s (firmware) + 1.047s (loader) + 2.528s (kernel) + 2.623s (initrd) + 17.174s (userspace) = 33.320s graphical.target reached after 17.158s in userspace 

Dus de waarden voor ‘firmware’, ‘loader’, ‘kernel’, ‘initrd’ en ‘userspace’ (bovenstaand is na een koude start. in geval van een herstart is firmware ongeveer 50% sneller).

Op mijn andere systemen zie ik alleen de waarden voor ‘kernel’ ‘intrd’ en ‘userspace’, de waarden voor ‘firmware’ en ‘loader’ zie ik dan niet.

Dit viel mij op. Geen idee of het er toe doet.