VPN SSTP client

My office VPN recently changed to SSTP.
After a bit of snooping the sstp-client project seems to be ignored by suse devs and users and anyway the last update was 2013?.
To make matters apparently worse it depends on libopenssl.

Someone throw me a lifesaver, or put me out of my misery by telling me to forget it?


Version 1.0.10 was uploaded to SF on 2015-05-28; last commit to repository was 2016-08-17.

If you mean version in openSUSE 13.1 - I do not even see official package for openSUSE anywhere and unofficial packages offer the latest version. So I am not sure which lazy devs you mean here.

Where have you got this package from?

Heh, heh. I read the OP again after your response, but …

I could not find where that message actually said “lazy devs”.

Probably my aging eyesight, so could you highlight it for me? lol!

Yes. Absolutely no intent to imply any obligation (or laziness) on suse devs, I’m grateful to you guys for your work, and apologies for the lack of clarity there:
Is SSTP worthy of anyone’s attention? I don’t know, but would have been convenient for me if it was integrated - so I looked for it.

Meanwhile I didn’t see the “recent” updates on SF, because I was looking at Github. Shame on me for that one as well.

Has anyone tried it?

13.1 is now out of support no new or fixes for it.

Yeah OK I get it, I should update my 10 year old half broken laptop
I didn’t ask for support, I don’t expect support. I only asked if anyone tried it.

Well out of support means that you can not get new updates for the OS does not mean we can’t help;)

But you want to use newer stuff you must move to newer OS. You can always get the source and compile it for yourself or organization but that requires a certain level of knowledge. Some here may help. Remember the openSUSE is a community project not a product. All here are volunteers

For the record, I am still running 13.1. KDE reasons.

However, I have a couple old fellas in the neighbourhood running 42.1 on machines older than 10 years, and both machines were not top of the line back when they were new.

If you change your mind, you might give it a try. But, if not, I am sure some here will try to help you with your problem.

Good luck.:wink:

Hi Guys,
Firstly some love - I do understand you are all volunteers. I appreciate the replies and conversation. Thankyou.
Back on topic:
Has anyone tried SSTP?
For reference: I’ve booted a live tumbleweed snapshot 30th Nov, and the plasma nm plugins complain that the vpn client isn’t working. <- please don’t tell me how to fix this: I will put time into it if someone can tell me they have made it work. That will be appreciated.
I don’t mean to be difficult, you guys and I have better things to do than debug upstream libraries (apologies if my terminology is wrong).
I do have workarounds.

Thanks again,