Volume hotkey configuration.

Hello, just began using linux and i am loving opensuse with gnome thus far. I seem to have overcome leagues of configuration problems on my own but i have a problem with using volume control hotkeys. I have assigned shift+pgup/pgdown/end for volume up/down/mute using “keyboard shortcuts” in the control panel but when i use them all I get is a pop-up graphical volume control indicator that shows correspondence to my volume adjustments but no adjustments are made to the actual volume. I am most appreciative to any help I receive on this, and use the most complex linux moon-speak you can fathom if you must, but be prepared for me to politely request that you dumb it down for me.

May I ask why so difficult way to get it done ?
If you select as master channel front than the standard volume up /volume/down and mute works

I have chosen the difficult way because i dont know what i am doing of course.I am using a laptop, and on windows vista i am used to holding down the Fn key and pressing pgup/pgdown/end for volume adjustments. Where might I find the option that you are speaking of, so I may adjust it?

On the taskbar is a loudspeaker icon right click on it and
select master channel > front
In gnome the loudspeaker icon is on a different place , but in my case if a use gnome it works too.
I use sometimes Gnome and sometimes Kde I am on Kde now
My keyboard is a Windowsz keyboard top left are 3 loudspeaker
symbols being loudspeaker/mute , loudspeaker/increase/
loudspeaker/ decrease
Hope works for you to

i see the loudspeaker and when i right click it i go into preferences i see “select the device and track to control”.

I am given the options of Playback: ALSA PCM on front, Sigmatel STAC 9200 (OSS Mixer), and a few other options. i have tried all of these and some now correspond to the loudspeaker as well as the pop up gui indicator, but still none of them actually change the level of the volume.

I have openSUE 11.0 Gnome. I have the very same issue as w4gn0r. I have a win keyboard and whenever I click on the special keys that control volume (increase volume, decrease and mute) I see the splash animation of the volume bar actually going up down and mute but it doesn’t do anything to the volume. But when I open Volume Control and manually slide the bar, volume does increase and decrease.
I tried dobby9’s recommendation switching all configurations (front, rear, etc.) but with no success. Do I need to click close on the window for the changes to take effect? or restart? Total noob here, could be something very simple I may be overlooking.

Wow that is absolutely identical to my problem.

The difference could be the sound card we use mine is a Intel ICH7 family
Although I get this advice from someone who use a other sound card
And in my case it works

Ditto here. The exact same problem. I’ve been living with this issue since 11.0. I thought this would magically be fixed by upgrading to 11.1. No such luck. Still have the exact same issue. I need to slide the sound bar up and down manually to increase or decrease sound.
I’ve already tried all of the different configurations with no avail… has somebody found a fix for this???

I need to setup mine VIA8237 (Alsa Mixer) PCM to actually be able to control the volume through the taskbar speaker with the mouse.

I’ve looked around in the forum and found several similar posts with no solution so far.