Volume and Mute soft buttons doesn't work

Using HP Pavilion dv5-1030en
Fn buttons works fine.

There are some soft buttons (touch leds, “quick buttons” in HP terminology):
[li]“QuickPlay” - to launch Vista media center. No interest[/li][li]Mute - doesn’t work[/li][li]Volume +/- - doesn’t work[/li][li]|<<, >||, >>| and Stop - manipulating Media player. No interest[/li][li]Wireless - works fine[/li][/ul]

How can make Mute and Volume buttons to work?

Under KDE4.

  1. Start menu
  2. Configure desktop
  3. Keyboard and mouse
  4. Keyboard shortcuts
  5. KDE Component: KMix (But this one should be selected by default)
  6. Configure a custom key to Decrease Volume
    , Increase Volume and Toggle Mute

Screen you’re looking for is something like http://wiki.msiwind.net/images/Key_binding.png

Do you mean by “custom” key something like Ctrl+XXX or configure a hardware key?

I have by default those settings:


When I’m trying to configure a custom key for Mute and pressing notebook’s mute button - the new key is not being recognized (no reaction)

Guess you got some extra work to do then, need to get the buttons recognized first. That is however something I can’t help you with, hope someone else who isn’t shy about posting the solution can.